Drobo

Droboshare unable to resolve hostnames/ping external IP's

I;m not 100% sure what’s happened, but the droboshare is now unable to ping external ip’s or resolve hostnames to ip’s!?

Any idea how I can debug this. I have SSH access to the droboshare, and am fairly linux savvy, but this has me stumped!

BTW the droboshare is in my DMZ (to make sure the router isn’t getting in the way for some stupid reason)

show us the output of:
ifconfig -a
netstat -nr
cat /etc/resolv.conf

Although from your post it sounds like you’ve done all this already…

Can you ping your default gateway?

The stuff you want is below… but it looks like it thinks the nameserver is 192.168.1.254? That’s not correct, it should be 192.168.1.1 (that’s my router)

How do I resolve this? Edit resolv.conf and fix the nameservers to be the correct ip?

/mnt/DroboShares/Drobo/DroboApps/fuppes $ ifconfig -a
egiga0 Link encap:Ethernet HWaddr 00:1A:62:00:30:A5
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1058 errors:0 dropped:0 overruns:0 frame:0
TX packets:673 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:512
RX bytes:201284 (196.5 KiB) TX bytes:186629 (182.2 KiB)
Interrupt:21

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:37 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3052 (2.9 KiB) TX bytes:3052 (2.9 KiB)

/mnt/DroboShares/Drobo/DroboApps/fuppes $ netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 egiga0
0.0.0.0 192.168.1.254 0.0.0.0 UG 0 0 0 egiga0

/mnt/DroboShares/Drobo/DroboApps/fuppes $ cat /etc/resolv.conf
nameserver 192.168.1.254
nameserver 192.168.1.254[hr]
btw I’ve never setup networking on linux, hence why I may seem a little n00bish![hr]
Note: I’ve tried to edit resolv.conf, but it just gets overwritten when the drobo restarts

It thinks that both your DNS server and your router are at 192.168.1.254 so you need to change both.

What I would suggest you do is statically assign the network details via the drobo dashboard. I do that anyways because I personally hate the idea of my storage moving on my network without my permission or knowledge :slight_smile:

Check your router config first… most do DHCP from 100->254 and leave 2->99 available for static assignment.

Kind Regards,

Red

Hey Red,

thanks for getting back to me. I didn’t think about checking the dashboard settings. It must be incorrect in there because of an old router!

I found a way of manually fixing it anyway. I made a new folder in the DroboApps folder called custom-config then made a file inside that called resolv.conf, inside which was the line

nameserver 192.168.1.1

then I made another file called custom-config-start.sh which had the lines

cp resolv.conf /etc/resolv.conf
route add default gw 192.168.1.1 egig0

I can’t remember if that is exactly right (replying from iPhone at work so can’t check the commands) but I’m sure you understand what I’ve done if you know Linux.

I will check the dashboard conf when I get home. I bet that’s the problem!

Adios,

Briz

Sure you can do it that way but why contort :smiley:

Remember, if you’re going to manually set the default router like that you need to remove the previous default route first.

route delete default gw 192.168.1.254

Kind Regards,

Red

OK, I can now ping and contact the outside world from drobo the… unfortunately that hasn’t fixed my other problem! - See this post http://www.drobospace.com/forums/showthread.php?tid=1203