Drobo

DroboShare JFFS recovery?

A script that I was working on was executed in the wrong working directory on the DroboShare, and I believe filled up the jffs /dev/mtdblock1 volume on the DroboShare. (in /root/). It now does not boot far enough to start dropbear, so I cannot delete the file over SSH.

Is there any way to reset the internal jffs volume? I tried on another Droboshare using the reset button and procedure. This resets only the settings (password, etc), but does not delete any files added to the jffs /dev/mtdblock1. I also tried forcing a re-flash of firmware on the other DS using the CTRL-ALT hotkeys in the Dashboard, and it also only resets the settings, but seems to leave everything in mtdblock1 (specifically in /root/) intact.

The “dead” Droboshare is not noticed by the dashboard any longer. It still is listening and responding on ports 5000-5001 after booting, and sending some encoded information back on 5000.

So is there any way to delete a file from mtdblock1, or wipe it out and repopulate it? JTAG necessary?

Of course, my warranty is long gone, so no fears about voiding it :stuck_out_tongue: Any knowledge appreciated.