Drobo

DroboPro via iSCSI REQUIRES Dashboard?

Last night, I booted up my Mac Pro, logged on to my normal non-Admin account, and was going to rerun the Xbench tests to confirm the radical performance drop-off I reported earlier.

However, the DroboPro never woke up, even after 10 minutes. And obviously the drive never mounted.

Not having any other ideas, I switched to an Admin user account, in hopes that Drobo Dashboard would be able to tell me something. Dashboard came up, said it was waiting to connect, and almost immediate the DroboPro booted up and everything was fine!

This tends to confirm my suspicion that the DHCP connection is being initiated by the Dashboard.

Now, for reasons that I don’t understand, the Drobo Dashboard cannot run in non-Admin mode – it fails immediately, and relaunching doesn’t help.

If the iSCSI connection DEPENDS on the Drobo Dashboard to launch the service, that would be a huge annoyance, because I would have to log on as Admin, start the Dashboard (which comes up automatically they way I’ve set it up), and then log off and log on as a limited user again. What a pain! And in a corporate environment, where most users do not a have admin privileges, this would be a complete deal-breaker.

I thought that perhaps I could get around this by making use of a manually assigned IP address. I tried doing it while the DroboPro was still connected via the LAN, but that didn’t seem to work. So I shut it down, and connected it via USB, and set the IP address to 192.68.1.230.

But after reconnecting the iSCSI link, DroboPro wouldn’t come up at all, and I gave up and went to bed.

So four questions:

  1. Is Drobo Dashboard in fact required to be running in order to wake up the DroboPro if automatic (DHCP) registration is used?
  2. Is that also the case if a manually assigned IP address is used?
  3. What did I do wrong in configuring the manual IP address?
  4. Is there any way to run Drobo Dashboard as a service, rather than as an application, so that it isn’t necessary to log on as Admin to bring it up? I don’t mind switching to Admin mode in order to actually USE it, but it ought to be possible to have it do its e-mail thing automatically, in the background, with no explicit effort on my part to launch it.

OK, I can definitively say that Drobo Dashboard is REQUIRED to be executed in order to mount the DroboPro via iSCSI, at least when using DHCP to assign the address.

It won’t come up at all when logging on in limited user mode, because Dashboard crashes.

In admin mode, with the Dashboard option to start a logon unchecked, the volume never mounts, but it does mount as soon as the Dashboard invoked.

Now I’ll try to reconfigure it to use static IP again.

I’m apparently not doing something right, because I can’t get the manually-assigned IP address function to work at all with my Mac Pro.

If someone HAS gotten this to work, please describe what you had to do, including how you configured the Mac’s port

Hi Suite B

I had lots of frustrations with this too. From what I can tell, the DroboPro doesn’t use DHCP at all. If you’ve manually configured an IP address, it uses that. But if you have not, it hard-codes itself to 169.254.1.100 or something like that (you can look up APIPA addressing on google to see how this works). I found that I had to configure the IP address while connected by USB, and then it would work ok over a network.

But if you do a dashboard or firmware update, you have to reconnect the USB again and set the IP address once more. Really frustrating…

I have my DroboPro and my Server in different locations down a hallway from each other, and have had to cart the Pro over to the other room several times just to configure an IP address. I think my fingerprints are melted into the sides of the DroboPro because I was so angry!

I’d like to thank Jeff in Technical support for resolving several problems. I’m not terribly happy with the result, but I don’t mean to shoot the messenger.

His answer:

“Mac’s do not come with a iSCSI initiator built into the OS like Windows Vista, or Windows Server. We had to add one into the Drobo Dashboard so that the DroboPro would work with Mac OS.”

"So that would explain “DroboPro won’t wake up without running Dashboard”

“As far as installing Drobo Dashboard on a STANDARD account: The installer will require admin privileges. However once installed everyday use should work just fine.”

I responded:

Please confirm that this also applies when using a fixed IP address, as
I suspect it does.

“Yes, static and dynamic(DHCP) IPs will need the Dashboard running because the initiator is part of the dashboard.”

Now, as to the failure of Dashboard when running as a standard user, does
Dashboard have to be specifically installed in the user’s account, as
opposed to the Admin account?

“You did not tell me it was failing, that is just because it can only be installed on one user per computer at a time. The last one to install it will be the only one that works. The rest of the desktops will get that error.”

So…

Since I am the only person who uses my Mac Pro (assuming some kind of a 'bot hasn’t infected me), it doesn’t matter that much which user initiates the connection. However, in a enterprise environment, I believe this would be a HUGE, show-stopping issue, because most ordinary users (other than system admins) are not allowed to run with Admin privileges. And because some of the commands supported by the Dashboard are positively dangerous if misused, using a DroboPro in its directly connected, highest-speed mode, doesn’t seem possible or at least practical.

The simplest solution would seem to be to remove the iSCSI initiator from Drobo Dashboard, and make it available separately, ideally as a daemon that would work on the system level, just as on Windows. (I wonder whether there is any chance that this problem might be fixed by Snow Leopard? Let’s hope so, as it is really an OS deficiency.)

BTW, I installed the original Dashboard (1.4. something), but when I tried to upgrade it via the update command in Dashboard, it tried, but couldn’t download it for some unknown reason. In addition, and much more frightening, it informed me that I didn’t have a volume on the drive, although it knew the name of the drive and showed that it had 2.46 TB used and 4.75 TB free.

Downloading the file form www.drobo.com/Support section and installing it worked OK, and now it see the volume. Whew!

Corndog, what is the reason why you want or need a manual IP address? Do you have two DroboPros, are you trying to share one DP between multiple computers, does it perform better or come up faster, or do you just enjoy self-flagellation? :slight_smile:

heh - self flagellation - you do NOT want to get to know me that well :slight_smile:

Anyways, to be honest, I started using the manual IP simply because it’s MY network and I don’t want to have anyone telling me how to set it up. Of course, I’m also testing multiple machines on the DroboPro (and failing so far), and I’m also using Nagios to ping it and monitor it’s uptime on my network diagram. I get paged if it goes offline. All this requires it to be a proper good citizen on my network with everyone else.