Drobopro suddenly read only!??

Bit concerned, my iMac seemed to crash earlier… when i restarted the iMac … i got the following message:

[b]OS X can’t repair the disk “DroboPro.”

You can still open or copy files on the disk, but you can’t save changes to files on the disk. Back up the disk and reformat it as soon as you can[/b]

I googled this and found these two articles:

  1. http://support.drobo.com/app/answers/detail/a_id/42/~/why-is-my-drobo-storage-device,-connected-to-my-mac,-suddenly-read-only-and
  2. http://support.drobo.com/app/answers/detail/a_id/318/~/if-disk-utility-(mac)-cannot-repair-my-drobo-storage-device,-what-should-i-do%3F

it seems like the issue is to do with permissions. as per the first article, i tried using drobo dashboard to shut down the drobopro, then restart my imac and then bring the drobopro back up again. that didn’t work. i actually tried that twice

when i go into disk utility on the imac, and click on the drobo disc… i cannot click on the repair permissions button, its greyed out. i can click on verify disk… when i read the details that come up… in red it says Invalid Node structure, The Volume DroboPro could not be verified completely, the File system check exit code is 8; Error: The disk needs to be repaired, click Repair disk.

I have not clicked repair disk because i wasn’t sure if wanted disk utility to start messing with the drobo. i felt like it should be the drobo dashboard if anything. HOWEVER, the repair disk button is greyed out. i am sure the first time i verified disk it wasn’t greyed out… but it seems certainly this time it is greyed out

i checked the tools in drobo dashboard and according to drobo dashboard the disk is healthy. its about 50% utilised; so definitely no space issues. i have 4 x 2TB disks in it and setup i a high redundancy mode so actual available space is about 5.4TB, and there is 2.62 TB available.

I then looked back at the first article again - and it says to get cocktail disk utility. i got that and went to PILOT tab as suggested, but the only option is to repair permissions on Mackintosh HD. i cannot select DroboPro anywhere. anyway, the article said to use the default settings in the PILOT tab so i went ahead and repaired the permissions on Mackintosh HD, but that hasn’t fixed the issue either. The last options seems to be to do a super user move via the Apple Terminal, which i am a little apprehensive about doing. So before proceeding i wanted to ask for help.

at the time it crashed, i was downloading some torrents and i was also importing a movie into iTunes. the files were being saved to the drobo, and my iTunes library file is also on the drobo…

look forward to see if anyone can help. i wrote to Drobo and they advised i am out of warrantee and therefore support. so i have to buy a new drobo model to get support or post on here!?

It’s a common OS X problem with external drives.

You need to check ‘ignore permissions’ in the drives ‘Get Info’ window.