Drobo

DroboPro on Mac having problems with FireWire 800 but not USB2

Hardware:

  • DroboPro 8 Bay with 8x 3TB NAS drives
  • iMac running 10.13.6
  • MacBook Pro running 10.13.6
  • 4 different FireWire 800 cables from 3 different manufacturers

Problem:
If I boot with USB2, everything is fine. I can factory reset the drobo, create volumes, delete volumes,etc. The only issue is I’m restricted to 480Mbps.

If I boot with FW800, it comes up fine, but I get something like “unable to complete task” errors from the Drobo Dashboard when I try to factory reset, create volumes, delete volumes, etc.

Also, If I setup the DroboPro with USB2 (which I have to do if I want to create volumes) and then power down -> switch cables to FW800 ->power up, then the DroboPro will see the new volumes (called “apps” and “backup”) and I can write to them, which is great.
However, if I have to switch back to USB2 for maintenance purposes or even just to test, and then switch back to FW800… ALL the volumes have been renamed to “Drobo” and the data is gone.

I have tried different FW800 cables, I have tried two different computers, I have tried different combinations of hard drives.

Has anyone experienced this before?

Thanks.