Drobo

DroboPro Firmware (fails)

I have a DroboPro with firmware version 1.1.5. I would like to update it to the current version of 1.2.2. It detects that an update is available and appears to download version 1.2.1 (not 1.2.2) but immediately fails on installation.

I’ve tried manually downloading version 1.2.2 and updating after extracting it from the zip file, but that fails as well. The DroboPro download page seems to suggest you should update to 1.2.1 before updating to 1.2.2 but I can’t find 1.2.1.

I’ve rebooted the Drobo and the computer a few times. I am running the current version of the Dashboard firmware. I am in Windows 8.1 (but running everything from the part that looks like Windows 7).

Any suggestions for getting the firmware update to work or locating earlier versions of the firmware if going from 1.1.5 to 1.2.2 isn’t an option?

Thanks,

Try:
http://drobo.com/support/updates/firmware/DroboPro_Firmware_1-2-1.dmg

The Drobo download page no longer lists the 1.2.1 firmware, but I just manually changed the hyperlink for 1.2.2 to 1.2.1 and it offered me the download.

Thanks. The link is to a file with an extension the DroboPro doesn’t recognize for firmware, but I was able to use it to download the 1.2.1 zip file and extract the regular firmware file. Unfortunately it gives me the same error as with 1.2.2. (the installation reports a failure at 0% completion).

Any suggestions would be appreciated. Thanks again,

Wait… you’re on windows… And I gave you a OSX based link.

Are you saying you changed the link to this (windows zip):
http://drobo.com/support/updates/firmware/DroboPro_Firmware_1-2-1.zip
and it still failed?

Yes. I changed the link to that zip file, downloaded it, extracted the firmware, and used the manual install within the Dashboard. It opens the file and then the install immediately fails at 0%. This is the same thing that happens with the automatic installation and when I tried to manually install version 1.2.2 after downloading it.

I have the same issue with my drobo pro. It runs with firmware 1.1.11. Tried out all the stuff you offered in this thread.