Drobo

DroboPro Failure reboots endlessly yellow lights

I’m experiencing what I think is a hardware failure with my long out of warranty 8 bay DroboPro. Yesterday, my MacBook Pro failed to recognize the DroboPro even though all eight drive lights on the DP were green. After rebooting the Mac a few times with no success, I turned off the power to the DroboPro to reboot it. But when the DP came back on, the drive lights were all yellow and it continued rebooting over and over for a half an hour.

I found a troubleshooting page on Drobo Support that advised me to unplug the DP and remove the drives, setting them aside in strict order. Then it advised me to plug in the DP without any drives in it, and turn the power on. I did so, and the DP continues doing the same thing: it boots on for about 30-45 seconds and then goes dark for a few seconds before it reboots again all eight lights under the (empty) drive bays are steady yellow, and the top three blue side status lights on the right side glow blue. The two lights on the bottom right corner show the top light green, and the light under it yellow. These two green and yellow lights come on for a few seconds when the reboot starts, then go off, and then come on again for another few seconds before the DP reboot cycle ends. They come back on again when the next reboot begins.

At this point, I have my eight drives outside the DP and have no idea how to proceed. If the DP has an unfixable hardware failure, can I just find an older used DroboPro of the same model and reinstall the drives in the same order?

Thanks for your help!

Drobos are quite notorious for misbehaving in unpredictable ways when the power supply begins to fail. The first thing I would try is to replace the power brick by a known good one then try to boot with no drives. If that works, then you can try with the drives inserted.

Good luck!

Regards,

Dom

Thanks, Dom, for that tip. Unfortunately, this model DRPR1-A doesn’t have a power brick–just a simple power cord that goes direct from the wall outlet into the back of the DroboPro. Power transformer must be built in to the Drobo itself.

I’ve just about given up on reviving this one. What do you think about my idea to find another used DRPR1-A and simply re-install the 8 HDDs into that one? Will a different DroboPro simply recognize the data set from the disks and be able to reconstruct my old Drobo in a new case? The one thing I don’t know is whether the Firmware version of the old and new DroboPros would match. Because the old Drobo died before I could confirm the Firmware version installed, I can only guess that it was the most recent update. If the Firmware in the new DroboPro is different than the one used in the Drobo that created the files on the disks, is there a danger the new DroboPro will simply not recognize the disks as Drobo disks and proceed to erase them?

Migrating a disk pack should work from one DroboPro to another, provided you move the drives in the same order they were installed in while the Drobo is off. The documentation does mention that firmware should be the same across both devices, though:

You can also look into getting a Drobo 8d as disk pack migration is supported from DroboPro to Drobo 8d, as per the above link.

In my experience, I was able to migrate a DroboFS disk pack directly to a Drobo 5N2, which obviously had different firmware. The only caveat was that my Drobo 5N2 was slower with the FS disk pack and I couldn’t create a volume larger than 16TB. In the end, I temporarily moved all my data to external drives, created a new disk pack on my 5N2 with the improved filesystem and larger volume capacity.

Back to your case, I don’t think moving from one DroboPro with older firmware to another DroboPro with a newer firmware will cause an issue, but it’s your data at play, so better safe than sorry. :frowning: That said, if you remember opening Drobo Dashboard prior to your DroboPro dying, it would have nagged you into updating your firmware if it was not the latest. The last DroboPro firmware update was in 2017 (http://files.drobo.com/webrelease/DroboPro/Release_Notes_Firmware_DroboPro_1_2_3.pdf), so as long as you opened Drobo Dashboard in the last 4 years and didn’t see a firmware upgrade message, you are likely on the latest version.

If you do by some miracle find and buy a Drobo 8d (I haven’t seen new Drobo devices for sales since about January 2020), you might want to open a support ticket to ask Drobo directly what their thoughts are on this topic.

If you’d like to try to repair you DroboPro, you can check out this disassembly video:

(Suggestion: watch it at 2x speed, as it gets long otherwise).

He diagnoses the problem, but doesn’t repair it. It’s NOT for the faint of heart, as it seems like a complicated fix. Though if you’re technically inclined and know your way around a soldering station, it might be doable.

Best of luck!

Dom

What a great reply, Dom. Thank you.

I’m on track to get a replacement DroboPro DRPR1-A, and hope to drop the sequenced disc array into that one when it arrives and hope for the best.

DroboPro support did contact me, amazingly enough, and although they didn’t suggest an immediate fix for the issue that rendered my current DroboPro inoperable, they did send me instructions for using Dashboard to temporarily reset my DroboPro to READ ONLY mode, which would presumably offer some measure of data protection to the existing data set while I undertake the steps needed to re-install them safely.

On the offchance anyone reading this thread might be interested, I’ve copied below the steps Drobo Support suggested to change a DroboPro to READ ONLY status.

PROCEDURE TO CHANGE DROBO TO READ ONLY:

Please follow this procedure to put the Drobo into Read Only mode,

  1. Put your Drobo into Standby/Shutdown via the Drobo Dashboard (if it’s not already) and remove the power. With the Drobo completely powered off eject your drives at least 1 to 2 inches.

  2. Power up the empty Drobo.

  3. Once the Drobo connects to the Drobo Dashboard, double-click the Drobo icon and press keystroke: CTRL-ALT-SHIFT-R in Windows or CTRL-OPTION-SHIFT-R if you are running Macintosh.

  4. You should get two prompts, one right away, and one a few minutes later. Please click to reboot the Drobo at that time (if you don’t get the second prompt for 5 minutes standby the unit using Drobo Dashboard and then cycle the power).

  5. Once the Drobo connects to the Drobo Dashboard please check that the Drobo is in read-only mode (RO) by looking at the name of the Drobo in the Status or Capacity screens and verifying that there is an (RO) after the name. If it is not in read only mode please start over at step 4.

  6. Once verified Drobo is in Read Only (RO) Mode, put Drobo into Standby. Once in Standby/Shutdown disconnect power. It is Critical that step 5 above is confirmed. Data loss can occur if the Drobo is not in read only mode.

  7. Once the drives are securely seated in the Drobo, power On the Drobo. The Drobo should connect to the Dashboard.

1 Like

That’s great news! I hadn’t thought about putting the Drobo into Read-Only mode. Though if it doesn’t work in RW mode, I’m not sure it will work in RO mode.

If you do manage to get your DroboPro into RO mode with your disk pack installed, you can at least back up your data elsewhere. That way, if on the off chance the disk migration to your new-to-you DroboPro fails and you need to start from scratch, you’ll at least have a backup.

Have you tried to put your DroboPro into RO mode, as per the instructions above? Did it work?

Also, you mentioned that you were able to boot the DroboPro with your disk pack removed, in order to create a diagnostic file. If you can do that again, you should be able to check the firmware version from Drobo Dashboard, to set your mind at ease for your disk pack migration.

I hope everything works out and you can regain access to your data!

Regards,

Dom

I was unable to change the DroboPro to READ ONLY mode using those instructions, since they rely on using the Dashboard to manipulate the DroboPro, which I have been unable to do throughout this issue, contrary to what I may have implied earlier. In fact, this whole thing started when I noticed that the DP had disappeared from my desktop and I, perhaps unwisely, in retrospect, turned off the power to the DP in the hope of rebooting it so that it would be recognized by my computer and Dashboard.
It was after that less than gentle reboot that the DP refused to come back on normally, instead slipping into the endless reboot cycle state in which it remains. I’ve got a line on a replacement DP, and am crossing my fingers that it will be able to read my disc data set without any problem when I re-install them in that replacement DP in the same order in which they were placed in my old broken DP case. I’ll check back in and let know what happens.

If if the replacement DroboPro does end up allowing me access to my data, I’m not sure I have enough confidence in Drobo to continue relying on them at this late stage in their hardware life. Do have any experience to share about any other hot swappable redundant back-up systems? I’ve read positive things about Synology systems, and I’ve heard some buzz around QNAP. Any recommendations?

If I had to buy another pre-built system, I would check out Synology. Lots of support from both the company itself and from the community. I just bought one for my company.

I’m a bit of a tinkerer, though. So for personal use, I’m looking into building my own FreeNAS or UnRAID system. Still a ways off, though. I hope to get a few more years out of my 5N2.

I’m happy to report some positive developments in my quest to save my data from my ailing DroboPro.

I was lucky enough to get my hands on a used DRPR1-A DroboPro, and when I connected it (without any discs installed) to my Mac, Drobo Dashboard recognized it without any issues, and immediately prompted me to update the Drobo’s Firmware, which I took to be a good sign. Once I updated the Firmware, I installed the 8 drives into the “new” Drobo in exactly the same order in which they resided in my old DroboPro. Then I rebooted it and prayed. Fortunately, the “new” Drobo was able to pick up right where the old one left off before it died, and I could see all of my data was still present and readable. Needless to say, I inititated an immediate back-up of the data on the DroboPro to a different external drive.

Interestingly, before I turned the new DroboPro on with the old drives installed, I was tempted to put it into READ ONLY mode using the instructions Drobo support supplied. That way, I figured, even if the new DroboPro didn’t recognize my existing disc array, it at least wouldn’t inadvertently erase them. However, I finally decided to take my chances and skip that step, for the simple reason that Drobo hadn’t provided me with any way to reset the Drobo back to READ/WRITE mode in the event the new DroboPro did reoognize my disc array without any issues. When I was unable to find any instructions on restoring a Drobo to Read/Write on the Drobo support site, or anywhere else on the web, I decided not to risk switching it to READ ONLY after all, since I was worried that doing so might run the risk of turning my “new” DroboPro into a permanent READ ONLY machine, which would have been a shame.

Bottom line, the migration to the new machine was a rousing success, and it probably didn’t hurt that I was able to update the Firmware as soon as I connected it.

Thanks again for your considered and most helpful replies!

Glad to hear it all worked out!