DroboPro connected via iSCI no longer detected after upgrading to OS X 10.10

I have a DroboPro connected via iSCI which is now no longer detected after upgrading to Mac OS X 10.10 (Yosemite).

I found this KB article and followed the guidance for upgrading Java, but the issue still persists:


I also uninstalled and reinstalled the Drobo Dashboard v2.5.3, but no luck.

Has anyone else had any luck getting this to work?

Same issue here. DroboPro connected via iSCSI. I have three Macs. The two Macs I’ve upgraded to Yosemite no longer see the DroboPro. The one Mac still on Mavericks sees it fine. I’ve re-upgraded Java, am running DD 2.5.3, and have rebooted all machines repeatedly.

Same issue here.

The same, after updating to Yosemite my Drobo Pro is no longer detected. Reinstallation of Drobo Dashboard v2.5.3 doesn’t help. Has anybody a solution?

Same issue here, please Drobo, need to fix this!

This should be the fix

I had this same problem but was able to finally mount mine. I have three Drobo Pros, two B1200i and one b800i connected to my server. After updating to 10.10, both 1200is and the 800i mounted very quickly. All three Drobo Pros were unrecognized. Did the Java thing, no help.

I ended up hooking one of the Pros up via USB to see if it would mount and it did. Hooked it back up via iSCSI and no dice. Hooked it back up via USB, mounted fine. Went in to the network settings in Drobo Dashboard to make sure the iSCSI was configured properly and it was. Shut it down and hooked it back up with iSCSI and it mounted beautifully. Did the same with the other two and they both mounted as well.

Long story short, it appears that if you hook it up via USB and then go into your network settings in Drobo Dashboard and hit OK then shut down and hook your iSCSI back up and restart it, it works fine. At least it did for me, YMMV.

Hi guys. Created an account just to comment on this issue. I’ve just migrated to a 2014 MacBook Pro with Yosemite using the Thunderbolt/Ethernet adapter, and have had the same issue described here.

That said, I’ve found a solution. It’s not ideal, but it is reliable and quick.

Failure to connect to DroboPro via iSCSI on newer Mac with Mavericks/Yosemite. May connect ocassionally, but not reliably. Problem occurs despite install of Drobo Dashboard 2.5.3 with free iSCSI initiator, and despite install of Java 6 runtime as suggested by by offical support.

To use this fix you must: (or else behavior is undefined)

  • MUST install Drobo Dashboard 2.5.3
  • You MAY then install newer Drobo Dashboard 2.6.x
  • MUST install the Java 6 runtime

Actual issue:
The iSCSI initiator is actually a separate program from the Drobo Dashboard. DD just calls it. It appears that for whatever reason, Drobo fails to make the necessary calls on a reliable basis in Yosemite/Mavericks.

Call the initiator yourself.

First things first, you should connect your Drobo via USB, and set the network settings to manual. The default IP with manual settings is This will work fine, but if you change it, you’ll need to revise my script accordingly. If your Drobo is connected indirectly, you may need to do further network maintenance here, beyond the scope of this article.

Disconnect from USB and reboot your Drobo Pro.

Connect your Drobo via Ethernet. If you’re on a newer Macbook Pro the Thuderbolt/Ethernet adapter will work fine here.

Give your Drobo a few moments to get on the network. Next, you’ll want to test the network connection. Open terminal, and write:

[color=#FF4500]ping -c 5[/color]

(or the IP you choose)

This pings the Drobo 5 times. If it responds, we can move forward. Otherwise, you need to work on your network settings until ping is successful.

Your Drobo is on the network, but Drobo dashboard hasn’t noticed. We move into the actual commands to open it manually. The iSCSI initiator is called “xtendsancli” and we can call it in terminal. There are three basic steps to connecting your Drobo. They are “discoverTargets”, “addTargets” and “loginTargets”. In some cases, Drobo Dashboard or xtendsancli automatically completes the first two of these three steps, but we can safely execute all three steps, and ignore the error messages generated if what we’re doing is redundant.

This is what the three commands look like for me:

[color=#FF4500]sudo xtendsancli discoverTargets -address -verbose | head -1
sudo xtendsancli addTargets -address iqn.2005-06.com.datarobotics:drobopro.tdb093540182.node0 -autoLogin Yes
sudo xtendsancli loginTargets -address iqn.2005-06.com.datarobotics:drobopro.tdb093540182.node0 -autoLogin Yes -security[/color]

When I run “discoverTargets” the program answers “iqn.2005-06.com.datarobotics:drobopro.tdb093540182.node0”. Your answer may be slightly different, in which case it alters your response for “addTargets” and “loginTargets”. I believe each Drobo probably has a unique ID, but I only own one Drobo, so I’m not sure. And of course, you have to adjust the IP address.

These commands require admin access, and you’ll have to give your password.

You can combine all of these steps into one automated shell script:


target=$(sudo xtendsancli discoverTargets -address $serverAddress -verbose | head -1)
sudo xtendsancli loginTargets -address $serverAddress $target -autoLogin Yes -security[/color]

The shell script can then be called directly by terminal. You also can potentially build an app with this code as the basis, so it’s just a click.

Everytime you connect your Drobo you’ll need to run these commands, but as soon as you do, your Drobo should wake up from sleep and come to work. It will display properly in Drobo Dashboard and should mount properly as well.

This may work for other Drobo iSCSI products as well, but I’ve only tested on Drobo Pro.

Please let me know if this works for you guys!


Thank you for the all the posts. I have tried everything mentioned as well as other B800i support blogs on the internet. The drive still won’t mount. My iMac does find it when using the USB cable but not via ethernet.

I have a documentary film inside the Drobo waiting to be edited. I have already invested a very frustrating day and 1/2 on this issue. I called Drobo support several times. They can’t help because my Drobocare expired. My fault for letting it expire, but I must say… I used to really love the Drobo service… no so much these days. Basically they are saying since my current Drobo is not connecting I need to buy a new Drobo - ugh - such a waste of time and money!

Any ideas on who I might call or what I might do would be greatly appreciated! At this point I am willing to pay someone a reasonable sum to help. Thank you!!!

I’m happy to try troubleshooting with you, but you’ll need to write a detailed post explaining each step you’ve already taken, in order.

Unfortunately, saying “I’ve tried everything” doesn’t give me enough information to begin to troubleshoot.

thank you very much for your explanations.
I followed your instructions and i am able to ping the DroboPro at

Unfortunately i get the error

[quote]SEVERE 03/23/2015 00:02:31 Unable to communicate with the iSCSI target: Permission denied
SEVERE 03/23/2015 00:02:31 An error occurred discovering the target(s). [/quote]
when doing the

[quote]sudo xtendsancli discoverTargets -address -verbose | head -1

Any idea what might be wrong?


  1. Uninstall Dashboard (whatever version you are on right now)
  2. Remove All Java https://www.java.com/en/download/help/mac_uninstall_java.xml
  3. Reboot Mac
  4. Go to java.com and install latest Oracle Java http://javadl.sun.com/webapps/download/AutoDL?BundleId=105219
  5. Reboot Mac
  6. Install Apple Java (https://support.apple.com/kb/dl1572?locale=en_US)
  7. Reboot Mac
  8. Install Dashboard 2.5.3 or 2.6.2 (https://links.connecteddata.com/CgtiiV6T4YKvDm/Drobo-Dashboard-2.6.2.dmg/06)
  9. Reboot Mac
  10. Launch Dashboard

Does it help?

Any idea what might be wrong?


Sorry. I don’t know the answer. I would make sure you only have one network adapter running, but beyond that I can’t really guess. Doing the steps Sebastian mentions would also be advisable.