DroboElite - Tried hot-swapping bad drive for new one of same size, all lights red


Our DroboElite was at about 95% capacity (16TB total (8 x 2TB), only using 12TB with the rest as redundancy) when one of the drives started blinking red (6th slot from the left, Slot #5 for Drobo). We ordered another 2TB drive and it arrived 1 week later.

We tried hot-swapping the bad drive for the new one (didn’t turn off the Drobo, just pulled one out and put the other in) and then all of the lights on the Drobo were a solid red. We were also presented with the following message:

“Too many hard drives have been removed. Please re-insert the removed hard drives.”

So we then tried the following and have continued to receive the same error message as above:

  • Removed the new drive, put the old one back in. Flashing red light on the old drive and solid red light on the other drives.

  • Tried swapping Slot 6’s drive with Slot 5’s and vice versa

  • Tried the Slot Flush method where I turned off the Drobo, removed all of the drives, turned it back on and waited. Then I turned the Drobo off, inserted one drive, turned it back on, let it load, and repeated this step for all 8 drives.

Nothing appears to be working at this point. Thankfully we were backing up to an online solution so anything immediate we can grab. However, anything at least a year or so back was on the Drobo and we can’t access it.

Is all of our data at this point un-recoverable? Should we just reset/format it?

Please advise.

hi clandrew,
hotswapping like you did, is the usual process… can i check if all the other lights were solid (mostly green apart from 1 of them being solid red if you were over 95% full, and with the failed drive blinking/flashing red?)

can you also remember, if the message appeared (and if all drive lights went red) after removing the failed/flashing red drive, or was that only after putting in a replacement new drive? (understandably there may not have been that much time delay for each of these steps but can you remember?)

if you were using 2 drives (for ddr), then as far as i know, with 1 drive failing (as it did), you have a good chance of being ok, unless another 2 drives fail in some way… (which is rare, though still with a chance)

if i understood correctly, and if all of the original drives are inside your drobo, at this point in time, then would you be able to try the following when you get a moment:

if dashboard can not recognise the drobo, then you might need to power all off,
and to remove all drives (remembering the order of your diskpack drives for later)
and to power it up empty
(and to try putting it into read onlymode via dashboard here)

  • and then to power all off
  • and to put yoru diskpack drives back into where they were
  • and to power up (still in readonly mode to see if anything happens regarding drives and access?)

it is always good that you have some backups, though if you are still having a drobocare (or if you need to try to recover things), then it may be worth creating a ticket with the support team, (which i believe should still be possible for a paid incident if you wish, even in case out of support), as they may be able to help advice further (especially if certain drives have suddenly failed and require block cloning etc), though please do refer them to this page too so that they are fully aware of all steps you have carried out so far since the issue.

Thank you for your suggestions Paul. Prior to this issue, the lights were all solid green with the exception of the one bad drive where it was indeed blinking red. It continues to blink red in this current situation while the other drives are a solid red. When I hot-swap the bad drive out for the new one, the blinking continues until I shut down/restart the Drobo and then it becomes a solid red light.

I tried your process of setting the Drobo to Read Only, shutting it down, removing the drives, turning it back on to let it load, shut it down again, re-inserted the drives, and turned it back on but I am still receiving the too many hard drives have been removed message. I tried this with both the bad drive and the new drive.

thanks for trying that and for the update clandrew,

now that you have tried the readonly mode, as you mentioned above, (and while there may be a few more tests that could be attempted, such as to try again but this time without the bad or new drive), i do think raising a ticket would be a good way forward, to either gain more information as to what might have caused it for future reference, or as a better chance for recovery.

either way, seeing as you do have a backup, a full reset and then copying back your data onto your reset drobo could be an option like you said, though i would try to do a reset from scratch and then put only known good / working drives back in while on, one at a time, to let the drobo assimilate each good drive into a new pack. (if you have enough time, possibly inbetween copying, it would be good to run some full surface scans of the drives before re-using them, just in case they have a lot of softer errors that could lead into harder ones)