DroboApps won't install (or uninstall) properly.

Hi gang, I’ve tried asking tech support, but they can’t seem to help me, since the DroboApps are 3rd party… Kind of uncool, given how much they hype up the increased functionality the apps (supposedly?) provide…

Anyway, I can’t get the DroboApps to install properly on my FS. I’ve enabled DroboApps on the Dashboard, and am dumping the .TGZ files directly onto the DroboApps share. After rebooting, they seem to inflate properly, creating new files and folders, but I can’t actually DO anything with them after that…
I can’t figure out how to access Apache, DroboAdmin won’t load properly, have no idea how to even begin accessing PureFTP or Wake on LAN. To top it all off, I’ve been trying to uninstall the apps by deleting the app directories and rebooting, but Apache leaves behind a couple of junk folders that I’ve been unable to delete, even using the Windows Command shell.
I’ve tried some of the other suggestions on the forums, like copying the DroboAdmin files into Apache’s ‘www’ directory, completely shutting down and unplugging the Drobo instead of just doing a restart, but no luck.
Anyone out there have any suggestions? Sorry, I know this is probably noob stuff, but I don’t really know where else to look for answers…

I guess on a related note, is there a way to re-format the DroboApps share, to wipe it clean so I can try to re-install everything from scratch, or is the only solution to wipe EVERYTHING off of my drives…?


Did you disable DroboApps before trying to delete stuff?

Yup, disabled DroboApps & restarted, but the share is still active, and I’m still unable to delete the orphaned folders.

Hmm… Unfortunately I can’t help much more since I don’t have an FS, but hopefully one of the others here will be able to help you out!

That’s OK, thanks for the suggestion, anyway!

have you tried http://<ip.of.your.drobo>:8080/ ?

have you tried http://<ip.of.your.drobo>:8080/admin/ ?

Configuration for it requires shell (SSH) access, if I’m not mistaken.

Same as PureFTP.

We could help more if you listed which files are stuck.

Wiping (i.e. deleting) everything wouldn’t help at all, since the apps are on a different area than your files. (I guess reformatting the disk pack on another machine would do it, but that is textbook definition of overkill :slight_smile: )

If you enable shell access you can SSH into it and clean the DroboApps folder quite easily.

Something like this would do the trick:

rm -fr /mnt/DroboFS/Shares/DroboApps/

Warning: be careful when deleting stuff from the shell access. Bad things happen when you mistype.

Thanks for the tips, Ricardo!
http://:8080 only gets me a placeholder page for Apache, telling me to “click here if i’m looking for DroboAdmin” (the link send me to a "file not found page)

I haven’t tried http://:8080/admin, but the address to access DroboAdmin is supposed to be http://:8080/droboadmin, and that just gets me a “file not found page”

Um, stupid question, but how to enable shell access to the Drobo…? Is that through DropBear? Sorry, kind of a noob here & don’t, uh, really know what SSH is… :stuck_out_tongue:

When I go to delete the apps, there are 13 files that can’t be deleted from the Apache/Lib folder because they’re not in the expected location (or something like that). Both the “Apache” and the “Lib” directory are un-deletable, and there don’t appear to be any hidden files in them, even looking at the directories in the Command shell.

The only thing I can think I may have done wrong is install DroboAdmin before installing Apache the first time I tried to set up the Apps. My thought was that if I could totally wipe them off of the share, I could start fresh without any possibly corrupt (?) or generally 'effed (?) files in the way… The official word from Tech Support is that the only way to ensure they’re gone is to blank the entire system… Ugh.

Figured it out! (kinda). Most unintuitive fix EVER. I’ve at least figured out how to install DroboAdmin…
you have to unzip the .TGZ file for Apache onto the DroboApps share and reboot the Drobo (this will install Apache). Once it’s started up again, drop the DroboAdmin .TGZ file onto the share and reboot the Drobo again. When it comes back up, Cut the “DroboAdmin” folder that’s in the root directory, navigate to Apache/www and Paste the entire “DroboAdmin” folder in there.
At that point, the link:
should take you to the Apache placeholder page. Clicking on the “looking for DroboAdmin” link will start the web interface for DroboAdmin.

Now to figure out how to use these other apps!

I Have some trouble browser dont opened droboadmin …
Please Help Me …