DroboApps.sh install - dependency issues

I went to install the latest Plex DroboApp (1.1.3) and ran into problems with my usual method of installation, which is to copy the tgz to the DroboApps folder and then SSH in and use “DroboApps.sh install” to avoid a reboot. It’s worked ever since I had an FS years ago.

Well, until yesterday. When I ran it, it oddly said there was a dependency on apache (there isn’t), and then failed starting plex dependencies (it has none). Meanwhile, the apache DroboApp is installed, up-to-date, and running fine, as was the previous version of Plex (1.0.3, the latest that’s available via Dashboard). The Plex devs confirmed nothing has changed with their service.sh or update.sh, and indeed they’re about as simple as it gets. I finally dug into the Drobo’s bowels and disabled the following section from /etc/service.subr:


Check dependencies before untar and mkdir

_depends="$(_extract_depends “${_tgz}”)"
if [ -n “${_depends}” ]; then
echo “Checking service dependencies for ${_appName}.”
if ! _start_depends ${_depends}; then
eval echo “Unable to start dependencies for ${_appName}.” ${STDERR}
return 1

After this point all dependencies have been installed.[/code]

In a nutshell, since I knew there were no dependencies and plex was running fine, I killed off the code that messes with them. Indeed, after I did this my usual “DroboApps.sh install” worked fine. I reverted my change as I don’t really want to go mucking with the Drobo’s internals - but something is rotten in there.

This sounds like a problem in apache more than anything else. Which version are you running? Also, would you mind sending me diags from that Drobo? Feel free to PM me, I’m curious to see how that dependency manifested itself.

I’d love to send the diagnostics, but the forum software won’t allow posting >4MB. You know, because storage is so expensive and complex…

Dug up my old Dropbox account - here you go.