Drobo

DroboApps Admin : Install DroboApps problem

Hi there
I have an odd issue with installing apps from the DroboApps Admin web interface. It gives me this output when clicking ‘Install DroboApps’:

[code]Below are the available DroboApps that you don’t currently have installed on your Drobo FS. By installing any of these applications, you are agreeing to the disclaimer.

Warning: file() [function.file]: php_network_getaddresses: gethostbyname failed. errno=11 in /mnt/DroboFS/Shares/DroboApps/droboadmin/www/index.php on line 301

Warning: file(http://www.drobo.com/droboapps/feed/textfs.php) [function.file]: failed to open stream: php_network_getaddresses: gethostbyname failed. errno=11 in /mnt/DroboFS/Shares/DroboApps/droboadmin/www/index.php on line 301
[/code[/code]]

I get the same when clicking ‘Upgrade DroboApps’.

The Drobo FS is connected directly to a Mac Pro, and it self-assigns an IP. Shares work fine.

Possibly related is that I managed to install Firefly once (by copying the tgz into the DroboApps share), but I changed the name of the Drobo from ‘Drobo-FS’ to ‘DroboFS’, and then back again. Since then I haven’t been able to install Firefly so that I could enter it’s webinterface. If I install it, I can see it running (scanning my media) in top under Bugbear.

Any ideas?

Since you plugged your FS directly to your machine, the FS is not able to resolve DNS names. Therefore, when it tries to call “gethostbyname”, it fails.

If you plug your FS to the router, this error should disappear.

Thanks Ricardo. I had a feeling that might be the cause.

This is my setup ADSL > Airport Extreme > Mac Pro > Drobo. Could I connect a Gigabit switch to the Airport and then connect the Mac Pro AND the Drobo to this switch. Would that fix the issue?

Yes, although if your Airport Extreme is a gigabit model (and your physical layout allows for it) you could always plug both directly into the Airport, as it has an integrated 4-port switch.

It’s the 2nd oldest Airport Extreme, so it only have a/b/g/100Mb. Thanks!

It worked! Thanks guys.

It worked – some of it, it appears. The Drobo FS and the Mac is now on the same subnet, each getting an IP from the Airport via DHCP. So far so good.

From the ‘DroboApps Admin’ I then installed Firefly, and changed the .conf to point to my share that I have created called ‘Music’ with all the music on it. I can see in ‘top’ that Firefly was running scanning the files. I checked the ‘cache’ dir and opened the 7MB ‘songs.gdb’ file. It seemed to have all the music files listed.

Now to the problem. When I go to the ‘DroboApps Admin’, then choose ‘Configure DroboApps’, then choose ‘firefly (Configure)’ I get this:

Firefox can't establish a connection to the server at 10.0.1.3:3689.

Any hints?

Here is the log


2011-02-14 11:45:17: Starting rendezvous daemon
2011-02-14 11:45:17: Starting signal handler
2011-02-14 11:45:18: Loading playlists
2011-02-14 11:45:18: Initializing database
2011-02-14 11:45:18: Starting mp3 scan
2011-02-14 12:52:59: Short read: /mnt/DroboFS/Shares/DroboApps/firefly/media/Music/(One Part) Universal Indicator/Live at Bangface 31 April 14th 2006/01 BF31_Rem01 1.mp3
2011-02-14 13:07:25: Rendezvous socket closed (daap server crashed?) Aborting.
2011-02-14 13:07:25: Aborting
2011-02-14 16:13:48: Starting rendezvous daemon
2011-02-14 16:13:49: Current database version: 8
2011-02-14 16:13:49: Starting signal handler
2011-02-14 16:13:50: Loading playlists
2011-02-14 16:13:50: Initializing database
2011-02-14 16:14:09: Starting mp3 scan
2011-02-14 16:16:04: Rendezvous socket closed (daap server crashed?) Aborting.
2011-02-14 16:16:04: Aborting