Drobo

DroboApp announcement: rTorrent 0.8.8 and ruTorrent svn-1696

Hello everyone,

Here is the latest rTorrent release and the very latest ruTorrent svn revision packaged for your leisure:

http://www.droboports.com/app-repository/rtorrent-0-8-8

Disclaimer: I took a completely different approach with 0.8.8 than with 0.8.6. With this release you have to download the different DroboApps that are required (don’t worry, they are indicated in the link above) and install them before installing ruTorrent.

In fact, the rTorrent DroboApp itself is now just a package with the rTorrent binary and nothing else. This means that if you just want the command-line interface you don’t need to carry all the weight of the web interface with it.

This move will also make it easier to update the web UI, since it is updating at a faster pace than rTorrent.

As usual, comments and feedback are welcome.

Hello,ricardo.
Thank you for porting new rTorrent and ruTorrent to DroboFS.

I just install this apps at first time.
I installed each required files with restarting drobo several times.(lighttpd,php,screen,curl,rtorrent and rutorrent)
and I accessed to Drobo ‘http://mydroboip/rutorrent/’, WebUI showing up , but it says “Torrent list not available,connection to rtorrent not established.”, and I cannot add new torrent .

so I try to use rtorrent through sshd command line access, and it work well and can download some files ok.

How can I use WebUI ?
I didn’t change any configuration .

thank you.

Apparently rtorrent is not running in the background. I wish I could help you more, but to fix this you need to get SSH access to check whether or not rtorrent is running or if the problem is elsewhere.

thank you for reply,ricardo.

I access to my DroboFS,and do ps.
it shows

ps

PID USER VSZ STAT COMMAND
1 root 3032 S init
2 root 0 SW< [kthreadd]
3 root 0 SWN [ksoftirqd/0]
4 root 0 SW< [watchdog/0]
5 root 0 SW< [events/0]
6 root 0 SW< [khelper]
28 root 0 SW< [kblockd/0]
43 root 0 SW [pdflush]
44 root 0 SW [pdflush]
45 root 0 SW< [kswapd0]
46 root 0 SW< [aio/0]
47 root 0 SW [crypto]
48 root 0 SW [crypto_ret]
180 root 0 SW< [dri_dnas_thread]
183 root 0 SW< [mtdblockd]
184 root 0 SW< [nftld]
195 root 0 SWN [jffs2_gcd_mtd1]
203 root 0 SWN [jffs2_gcd_mtd2]
218 root 2004 S /bin/ntpclient -l -h pool.ntp.org
221 root 1584 S /sbin/netplugd -P
230 root 3036 S /bin/sh /usr/bin/nasdLogRotate
232 root 11236 S /usr/bin/nasd
233 root 3036 S -/bin/sh
248 root 0 SW< [dri_shared_res_]
249 root 0 SW< [dri_scsi_resp_2]
250 root 0 SW< [dri_scsi_req_3]
252 root 0 SW< [scsi_eh_0]
272 root 0 SW< [kjournald]
320 root 5420 S /sbin/nmbd -s /mnt/DroboFS/System/samba/conf/smb.conf
322 root 10008 S /sbin/smbd -s /mnt/DroboFS/System/samba/conf/smb.conf
323 root 10008 S /sbin/smbd -s /mnt/DroboFS/System/samba/conf/smb.conf
336 avahi 2688 S avahi-daemon: running [Drobo-FS.local]
339 root 2580 S /sbin/cnid_metad
341 root 5872 S /sbin/afpd -F /mnt/DroboFS/System/netatalk/conf/afpd.conf -P /mnt/DroboFS/System/netatalk/security/afpd.pid
365 root 11196 S /mnt/DroboFS/Shares/DroboApps/apache/httpd -f /mnt/DroboFS/Shares/DroboApps/apache/conf/httpd.conf
374 root 11328 S /mnt/DroboFS/Shares/DroboApps/apache/httpd -f /mnt/DroboFS/Shares/DroboApps/apache/conf/httpd.conf
429 root 5076 S /mnt/DroboFS/Shares/DroboApps/lighttpd/sbin/lighttpd -f /mnt/DroboFS/Shares/DroboApps/lighttpd/etc/lighttpd.conf
453 root 2736 S /mnt/DroboFS/Shares/DroboApps/screen/bin/SCREEN -dmS rtorrent /mnt/DroboFS/Shares/DroboApps/rtorrent/bin/rtorrent -n -o import=/mnt/DroboFS/Shares/DroboApps/rtorrent/etc/rtorrent.rc
455 root 15412 S /mnt/DroboFS/Shares/DroboApps/rtorrent/bin/rtorrent -n -o import=/mnt/DroboFS/Shares/DroboApps/rtorrent/etc/rtorrent.rc
479 root 3740 S /mnt/DroboFS/Shares/DroboApps/openssh/sbin/sshd -e
490 root 11196 S /mnt/DroboFS/Shares/DroboApps/apache/httpd -f /mnt/DroboFS/Shares/DroboApps/apache/conf/httpd.conf
902 root 10564 S /sbin/smbd -s /mnt/DroboFS/System/samba/conf/smb.conf
12622 root 10008 S /sbin/smbd -s /mnt/DroboFS/System/samba/conf/smb.conf
12626 root 2900 S sleep 30
12627 root 6352 R sshd: root@pts/1
12629 root 3036 S -sh
12632 root 3036 R ps

so I think rtorrent is working backgrond .

Best,

Yup, you are right. That is actually bad news, because this would be a simple problem to fix. If rtorrent is running and there is no connection then there is a whole lot of things it could be, but none that I haven’t preconfigured it for. In other words, I have no clue.

But let’s start with this. Does your /mnt/DroboFS/Shares/DroboApps/rtorrent/etc/rtorrent.rc contain anything about SCGI? If so, could you please post it?

this is my rtorrent.rc.
i don’t change anything from download and installed it.

directory = /mnt/DroboFS/Shares/Public/Torrents/download/
system.method.set_key = event.download.finished,move_complete,“execute=mv,-u,$d.get_base_path=,/mnt/DroboFS/Shares/Public/Torrents/finished/;d.set_directory=/mnt/DroboFS/Shares/Public/Torrents/finished/”
schedule = watch_directory,10,10,load_start=/mnt/DroboFS/Shares/Public/Torrents/watch/*.torrent
schedule = tied_directory,10,10,start_tied=
schedule = untied_directory,10,10,close_untied=
schedule = low_diskspace,5,60,close_low_diskspace=100M
ratio.enable=
ratio.min.set=0
ratio.max.set=1
ratio.upload.set=1M
system.method.set = group.seeding.ratio.command, d.close=,
session = /mnt/DroboFS/Shares/DroboApps/rtorrent/var/session/
min_peers = 10
max_peers = 20
min_peers_seed = 1
max_peers_seed = 2
max_uploads = 1
download_rate = 500
upload_rate = 50
port_range = 6882-6889
use_udp_trackers = yes
encryption = allow_incoming,try_outgoing,enable_retry,require
dht = auto
dht_port = 6881
peer_exchange = yes
scgi_port = localhost:5050
execute = {sh,-c,/mnt/DroboFS/Shares/DroboApps/php/bin/php /mnt/DroboFS/Shares/DroboApps/rutorrent/www/php/initplugins.php &}

SCGI entry is only “scgi_port = localhost:5050”.
do you need any info?

I think I have an idea. Could you please post the content of /mnt/DroboFS/Shares/DroboApps/lighttpd/etc/conf-enable? I think you might have the old rtorrent.conf file disrupting the new rutorrent.conf file.

These files are in /mnt/DroboFS/Shares/DroboApps/lighttpd/etc/conf-enable.

access_log.conf
cgi.conf
debug.conf
dirlisting.conf
droboadmin.conf
mime.conf
rutorrent.conf

and rutorrent.conf is here.

server.modules += ( “mod_scgi” )
scgi.server = (
“/RPC2” => (
“127.0.0.1” => (
“host” => “127.0.0.1”,
“port” => 5050,
“check-local” => “disable”
)
)
)
alias.url += ( “/rutorrent/” => “/mnt/DroboFS/Shares/DroboApps/rutorrent/www/” )

Is this old (0.8.6) one?
Should I delete this file?

rutorrent.conf is the new one. There was no rtorrent.conf there at all or did you remove it? If you removed it, then you need to restart lighttpd like this:

/mnt/DroboFS/Shares/DroboApps/lighttpd/service.sh restart

What are the limits of this on the FS? Max torrent downloads, top download speed etc. before it maxes out the ram/cpu and crashes the drobo?

Well, the only thing I can tell you is that I have saturated my connection way before the FS was maxed. But then again I have a crappy 5000/500 plan.

On the other hand, given that the FS has only 180MB of usable memory and a single 800 MHz ARMv5 core, I don’t think you could host that many downloads simultaneously. My guess is that it probably would be as good as a cheap seedbox.

Okey doke, I might give this a test later and try and max it out so I know the limits on my connection.

I do currently have a seedbox but can no longer afford the cost, so if this can match my needs or at least come close I can have the drobo on while my main computer is off.

Let me put it this way: the downloading doesn’t really tax the CPU. What really maxes it out is the checksumming when the download is complete.

Ah OK, I have that disabled anyway.

Onto something else. Every time I want to get into rutorrent I have to start the service.sh manually, is there a way to auto start this (I’m guessing it should do it by default)

EDIT: Nevermind, I read what the other guy did. I had the same problem with .conf file

I thought I had solved it but I haven’t. I still have to start the service.sh file every time it boots to get it working. Any ideas why its not executing by itself?

Most likely a bug on the script. I’ll have to check again to see if I messed up somehow. In the meantime, are there any special messages when you start it?

This is in the “logger”

[09.07.2011 21:11:25] WebUI started.
[09.07.2011 21:11:26] Bad link to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

Also there are two lots of rtorrent in my drobo admin configure, one is configurable, the other is unavailable.

Do you reckon it’s a conflict somewhere? I only have one version in my droboapps?

Hmm. Do the values mentioned match? They should be at host=localhost and port=5050.