DroboApp announcement: OpenSSH 6.0

OpenSSH has received a security update ( http://www.openssh.com/txt/release-6.0 ), so I have updated the DroboApp as well.

As usual, you can find the DroboApp package and the compilation tutorial here: http://www.droboports.com/app-repository/openssh-6-0

Besides the new openssh, this version is compiled with the latest zlib (1.2.7) and openssl (1.0.1c).

As before, there are instructions to upgrade your current openssh install without losing any configuration, and without needing to reboot the FS.

Comments, suggestions and feedback are welcome.

Interesting that we finally get the version bump to the big 6.0. Major changes, or is it just because they don’t like the look of 5.10?

According to the changelog:

I’m guessing they don’t like the look of 5.10.

Although this has been out for a while, I ran into an issue today. The SSHd server is running fine, but when I tried to SSH out from the DroboFS to another machine, I got the following:

jochs@Drobo ~ $ ssh mini PRNG is not seeded

This seems odd since the server doesn’t have any issues. So far, everything I’ve found online is for fixing issues with the server, and I assume they don’t apply (things like /dev/urandom not existing, etc).

I had the same problem. If I remember correctly, it was the permissions on both /dev/random and /dev/urandom. Only root could read them.