DroboApp announcement: minidlna 1.1.0

This is a major update on the classic DLNA/UPnP media server. The upstream code has been significantly improved, which means a simpler cross-compile for me, and better performance for everyone.

This version is fully SDK 2.0 compatible, but unfortunately still doesn’t have a web interface. It preserves the configuration files, but it will recreate the media index.

Both DroboFS and Drobo5N versions are available:

DroboFS: http://www.droboports.com/app-repository/minidlna-1-1-0/drobofs
Drobo5N: http://www.droboports.com/app-repository/minidlna-1-1-0/drobo5n

As usual, comments, suggestions and feedback are welcome.

For those interested in enabling TiVo support in MiniDLNA the following has been tested with a DroboFS serving to TiVo Series3 HD.

  1. Create a cross-compilation VM per DroboPorts "Setting up a VM"
  2. Add the gettext package. It is needed by minidlna but is not in the default machine created in #1 sudo apt-get install gettext
  3. On the final ./configure for minidlna add "--enable-tivo"
  4. If like me you have a bunch of .mkv videos, you will need to transcode them to mpeg since unlike pyTivo the MiniDLNA TiVo interface will not transcode for you. I used the following based on what pyTivo does: convertfile() { avconv -i "$1.mkv" -f vob -b:v 16384k -bufsize 4096k -copyts -maxrate 30000k -b:a 448k -ar 48000 -codec:a ac3 "$1.mpg" } convertfile

Very nice. I still love my Series3 OLED TiVos… One day, they will put a clock on the face again, and then my wife will let me upgrade. :slight_smile:

You guys should have said something. I’ll add a reminder to include support for TiVos on the next release.

I have pyTivo running on my server, so don’t do anything just on my account. :wink:

@bhiga maybe you can just print out an S3 image of the clock area, and stick it on to fool her :)[hr]
(well, you’d need to print a few different ones, to cater for the times that she’ll be likely to see… “morning”, “evening”, “weekend”, & “headache, not now” :smiley:

My wife’s way too smart for that, though I suppose if I had enough time I could rig something to scrape the status and display it. But time is something I am severely lacking these days.

I’ve just started looking for media server options for my Drobo-FS and thought MediaTomb was promising, but it apparently lacks the ability to stream to the Tivo. I was excited to see that minidlna can be set up to do so, but am I right that this feature isn’t bundled into the current release at http://www.droboports.com/app-repository/minidlna-1-1-0? Thanks in advance.

I’m not sure since I do not have a Tivo, but you can install it and if it does not work, I believe it is a matter of editing one or two config files.

Thanks so much, Ricardo. I tried for days to compile my own port. Linux is not my thing. I have downloaded your TGZ for the Drobo-FS and placed it in my DroboApps folder at the root. I rebooted and nothing happened. The 1.0.25 version was still in the MiniDLNA folder and the TGZ was still on the root. So I removed the 1.0.25 version (after backing up the configs) and rebooted again. The TGZ did not install. Any ideas?

Maybe the file got corrupted while downloading? Are you using a Mac? Safari has a bad reputation for messing up downloaded TGZ files.

I am not using a mac or safari. Is there anything Drobo-wise that would stop the file from self extracting?

I redownloaded using FF, put the file in the root of DroboApps and rebooted. It didn’t self-extract.

One thing, I can’t reboot from the Dashboard. I have to turn the device off. Otherwise it hangs.

At this point we’re going to have to have a look at the logs. What does “/var/log/nasd.log” say?

I don’t know how I would get to that log. I did install DropBear on it a few years ago but when I look at the logs for it, it appears it isn’t working correctly. So I downloaded it again. Just like the MiniDLNA, it won’t install upon reboot.

If not even dropbear will install, then you have a more fundamental problem. I suggest you open a ticket with Drobo support to see why you are unable to install even official apps, such as dropbear.

hi ricardo,
on some other threads here recently, it seemed as though dropbear had vanished off the face of the earth :slight_smile:

The problem was that a Dashboard update disabled DroboApps even though I could still browse to the folder. I re-enabled and poof. Thanks so much for the help Ricardo and for building MiniDLNA for us. It all works it seems.

I would like to be able to use my Drobo from my Tivo. I am not proficient with the low-level programming stuff, so would appreciate a simplified “duh-stupid” version. I’m not locked into a single way. pyTivo sounded promising until the instructions (I think step 2) went way over my head. I would use MiniDLNA, or whatever is out there. Does someone have something I can just drop on the Drobo?
I have the DroboFS.


I think pyTivo and MiniDLNA catter to different audiences. As far as I can tell MiniDLNA can only send JPEGs and MP3s to Tivos. See here for more details: http://forums.tivo.com/pe/action/forums/displaypost?postID=10433421

please help with building config file for my drobofs. if the name of share is “Media” what should be the line in config file