Drobo

DroboApp announcement: lighttpd 1.4.29

A new version of lighttpd is out, therefore a new DroboApp package follows:

http://www.droboports.com/app-repository/lighttpd-1-4-29

This version is statically linked, which means it is significantly smaller than the previous version. It behaves exactly the same as the previous version otherwise.

In any case, I recommend backing up the “www” folder before updating, and then copying it back after the update.

As usual, comments, suggestions and feedback are welcome.

For some reason, this is the only app I put in the DroboApps share, but I can’t access it for some reason? port 80 is forwarded to the drobo B800FS … help? :stuck_out_tongue:

For some reason, it can read the root index.html, but it doesn’t recognize any sub-directories (new or old ones I created) and gives a 404 error. Locally loaded (using local IP) and remotely (public WAN IP).

Wait, wait… is the DroboApp actually running on a B800FS?

yup, I can modify the index.html file I placed in the WWW subdirectory (and I can see those changes) … but I can’t access any subfolders.

lighttpd/www/index.html --> http://public.domain.com

lighttpd/www/stuff --> http://public.domain.com/stuff —> DOESN’T WORK, gives 404 error

even if I do it internally with internal IP addresses, it won’t load the subfolders

Wow, that is quite surprising. It means the B800FS contains the same motherboard/processor as the Drobo FS. It also means it shares the same limitations with regards to CPU power. I wonder how much RAM it has…

About your issue: it sounds like a file permission problem. You could try to make the subfolder world-readable (e.g. “chmod -R a+r lighttpd/www/stuff”).

I did the chmod by logging in via openSSH … terminal gives back:

4 drwxrwsrwx 31 root root 4096 Jan 4 17:13 stuff

The stuff directory still gives back a 404 error :frowning:

Okay, this might be a dumb question, but have you tried http://public.domain.com/stuff/ instead? Notice the trailing forward slash. Without the slash you are asking for a file called ‘stuff’, with the slash you are asking for a subfolder.

^ yup, have tried it with the trailing slash as well :slight_smile:

Previously, I used apache, and that showed the directory listing fine (with the list of files) BUT, when I tried to download a file, it said I didn’t have permission to.

So I think it may be a permission issue with the files.

SO

I created a new directory in the DroboApps share in lighttpd folder under www, and called it something new, like “new” … and that doesn’t load either :frowning:

Figured out the issue … lighttpd won’t allow for the directory to just list the files in there (one that doesn’t contain any index files).

Is there any way to change how that behaves in the config?

Sorry, I’m no lighttpd configuration expert. I’d recommend visiting http://redmine.lighttpd.net/projects/lighttpd/wiki

Now I’m having issues with lighttpd going down all the time? The only way to get it to start up again is to restart the drobo? :expressionless:

The only other droboapps I have installed is openSSH and PHP

You can restart it using SSH: “/mnt/DroboFS/Shares/DroboApps/lighttpd/service.sh restart”

Do you happen to know why it keeps going down?

No idea. Maybe there is some relevant information in the log folder?

side question: I’ve noticed that some files have “0 Kb” file size … looks like this is the case for large single files, is there a cap on single file sizes w/lighttpd? If so, is there any way to remove that?

I think the underlying filesystem has a file size limitation. I can’t remember what it is, but it is quite large.

Would upgrading to lighttpd 1.4.30 fix the shut-down issue? It seems like lighttpd for some reason keeps going down by itself, and I have to restart the service :frowning:

I can’t guarantee that, since you are the only one so far with that problem. To be honest with you, I’m pretty sure it won’t solve that problem, since nothing major has changed.