DroboApp announcement: CrashPlan 3.7.0

Short announcement since this week the apps will be coming fast and furious.

More info and links to download for both DroboFS and Drobo5N:


Comments, suggestions, and feedback are welcome.

A “clean” install of the version you point to on my Drobo 5N resolved my issues and everything is working fine so far. Backup continued where it stopped last Friday.

Will this version auto-update?

Eventually, yes…

But in another thread Ricardo said he may have a solution to make sure the update won’t failed. I have no more details on it, I hope he’ll find the time to implement it.

If you mean successfully auto-update, then no. It won’t stop it from trying, though.

The plan is that this new version caught me a little bit by surprise, so I had to rush the new DroboApp out with the same level of support as before. Hopefully I’ll be able to dedicate more time to it in the coming weeks to get a more definitive solution.

How do I manually install this version supplied by (you) Ricardo? I’ve tried several methods to get this installed and I am still seeing the issue where the application stops after 10 seconds. Issue started I believe with 3.7.0

Looks like the apps forced an update again this morning or something as it is stopped again and won’t restart.

Are there any update folders inside the app folder? I just checked the download from the CrashPlan website and it is still exactly the same.

I was trying more manual methods and deleted everything out (again). I tried the beta version as well without success. I don’t see it running at all when I’m SSH’d in and ran the “ps” command.

What do the log files inside /tmp/DroboApps/crashplan/ say?

The message I see when I try launching the app is the usual :

Error: Could not find or load main class com.backup42.service.CPService

That said, another thing I find really strange, when I look at the /tmp/DroboApps/crashplan/version.txt it shows (again) 3.5.3, while the latest I’ve installed is obviously 3.7.0. Where that version number is coming from? it is like if there is something corrupted somewhere in my directory structure that makes Crashplan think it is version 3.5.3 that is installed, even if I have a newer version.


I removed everything in the DroboApp/crasplan and /tmp/DroboApp/crashplan folders. I reinstalled again the beta version of 3.7.0 from the download link and reinstalled it in the DroboApp folder (I had to create the tmp folder in the crash plan folder manually, as I did the other day). I restarted it, and now the backup is syncing and should restart eventually, I guess.

I really do not get what’s wrong with my installation.

This also worked for me. I installed manually using the 3.7.0 version from the github.com site. To get the app to start I needed to manually create the tmp directory inside the crashplan directory:

mkdir /mnt/DroboFS/Shares/DroboApps/crashplan/tmp

That’s what I did exactly.

So after stepping back from this issue for a week or so, I decided to come back with a fresh take and mind on this issue. Here is what I did to finally resolve the issue where the application would start then close 10 seconds later (Thanks to those replies preceding this one as thats where I pieced this together from):

[*]I SSH’d into the Drobo5N and ensured there was nothing left of crash plan in the /Shares/DroboApps/crashplan and (and even the ._crashplan file) as well as the /tmp/DroboApp/crashplan directory. I used the following command in Terminal:

rm -r <directory/file to delete> []Restarted the Drobo via the Drobo Dashboard
]Downloaded and placed the crashplan.tgz file into the DroboApps folder.
[]Restarted the Drobo via the Drobo Dashboard
]Once the Drobo5N was back up, I verified the Crashplan application was running from within the Drobo Dashboard.
[]On my mac, I closed out of the Crashplan application from the status menu bar.
]I opened and edited the ui.properties file to this servicePort=4201 and saved.
[]Opened a Terminal session and ran ssh -L 4201:localhost:4243 root@<ip address of drobo> I entered the root password when I was prompted.
]Opened the Crashplan application from my OS (Mac). I had to login using my Crashplan account and configure all my settings again.

I have successfully been monitoring things backup for several hours so far! I hope this clears the air for anyone who is experiencing issues with the 3.7.0 version like I was!


I reset my Drobo FS to use as a decided Crashplan Client.

I got java8, crashplan, locale, openssh copied to DroboApp folder and rebooted the FS.
Then it stucks on “Your Drobo is on Final Stage”…12 hours already

Is there a way I can check and re-install the package? It would be great if it doesn’t reset what’s stored on the Drobo FS…

UPDATE: Checked the logs under app/ and tmp/ there is nothing there.
UPDATE2: Noticed that there are items under upgrade/ directory, I think Code42 could be forcing us to updates again :frowning:

I’m guessing this is a Bad Time™ to try running CrashPlan on my Drobo again. I assume from the content of this thread that Drobo Inc isn’t updating their Crashplan built-in DroboApp as they should be. :frowning:

How do I see what version I’m currently running?