DroboAccess - Internal Server Error


Trying to configure DroboAccess on my 5N. When I choose “open” to complete configuration I get an Internal Server Error. The “Troubleshooting” link at the bottom of the screen indicates “I cannot connect to DroboAccess on the Drobo from the Internet.”

Do i need to install another App before this one will work?

All firmware and software updates are current on my installation.


hi wayne, have you been able to install any other app?
maybe as a test you could find a basic app and try to install as a test, just to make sure that you can install? (then you can try removing that app again if you dont need it)

Please make sure that MySQL is running. DroboAccess needs it to work.

Yes, MySQL is running. I did not turn it on so it must be part of the DroboAccess configuration. Same thing with Python 2. I’ve rebooted everything, started and stopped the service. Still get the Internal Server Error.

We’ve had this error for about the same amount of time. Updated to latest dashboard and firmware on 5N. SQL running. Access NOT working. Help.

Drobo Access was successfully run previously until I’ve reset my Drobo 5N.

I’ve tried to configure Drobo Access again but is always unable to successfully complete it, with error message shown on “myDrobo” app as below:

DroboAccess registration failed.
Please try again later.
Error code: 21

What does Error 21 mean?
Is the problem with Drobo’s server rather than on my machine, and if so who should I look for support at Drobo (warranty expired)?

Many Thanks in advance

Error 21 is something else. This is related to your myDrobo account, and your access to the myDrobo relay servers.

Are you running the latest version of myDrobo? The latest version is supposed to have fixed this issue.[hr]

Would it be possible to reset DroboAccess? I believe that somehow your DroboAccess database got corrupted.

Keep in mind that reseting DroboAccess will delete all personal files (i.e., all the files that are not in Shares).

I’ve updated the apps and booted the Drobo5N but still have issue from my Original Post. Can you please clarify “resetting DroboAccess will delete all personal files …” I have nothing in Access since it’s not working. But if my files are safe on the drives / shares then I will reset in case the database got corrupted.


The way DroboAccess works is that all Shares that you create using Drobo Dashboard are linked inside your DroboAccess workspace. In other words, when you login you’ll see all the Shares listed as folders in there.

All files that are not inside the linked Share folders are in an area called “Personal files”. Since those files are not inside the Share folders, they are removed when you delete the user account. Since a DroboAccess reset deletes all accounts, it will also delete all personal files.

WARNING: A DroboAccess reset is NOT the same as a Drobo reset. A Drobo reset, which is performed from Dashboard, will delete ALL data from your Drobo. That is not what I’m talking about here.

With that being said, I just noticed that there is no simple way to reset DroboAccess from its configuration page. Hmm, that is somewhat of a complication.

How familiar are you with a command-line?

Ok, so i probably have zero “personal files” since all my files reside in shares. I’ve run command lines in DOS, windows and Mac computers. Never on a Drobo though. Something new to learn I guess. :slight_smile: