Drobo won't mount in Mac OS Catalina

Updated to Mac OS X Catalina Public Beta 3 and Drobo 5D won’t mount.
Does not show in Drobo Dashboard(which does run) and does not show up in Disk Utility.

All data is backed up and I’m am testing so no emergency.

Just wanted to see if community is having, seeing same issue. Drobo are you working on a fix?

Please post possible fixes.


I’m an Apple beta tester, not part of the public beta. I’ve used 3 different Drobos with no issue, Gen 2, Gen 3 and 5D3. Which build version are you currently using? I’m currently on 10.15 Beta (19A501i), but I’ve used prior without issue either. What ports are you using? have you tried a different cable?

I am having the same issue with my Drobo 5D3. Going to try the other USB-C port.

USB-C seems to bring it up, however it comes and goes and is not stable with it’s connection.

Update: Ok so it seems that it will connect via USB-C however once you start to view data it crashes and then disconnects.

I got it to mount. Had to reinstall Drobo dashboard. Looks like all third party drivers can be disabled when updating. I did a fresh install and then new Drobo dashboard install and that worked. Tested twice.

1 Like

When you mean a fresh install do you mean of the OS?

Yes clean install of Catalina public beta 2. Then Drobo dashboard. Just did it for third time as I’m testing other apps as well. So if your updating in place I would still try re-installing the dashboard first.

1 Like

I’ve done a reinstall of the os and the dashboard and still no joy with the latest public beta.

1 Like

I have 3 Drobo units - they can no longer format a Time Machine Backup partician. This is really frustrating for these devices to all go end of life. Hopefully the Dashboard SW will be upgraded.