Drobo

Drobo with WDTV

Anyone get a Drobo to work with Western Digital s WDTV media Players?

steve

as long as its formatted with a compatible files system it should just work?

(although a lot of “dumb” devices can only ever see the first volume on a multi-volume device)

exactly, it is a dumb device and I was hoping for some work arounds. I have the same question on the WDTV Forums. I would love to have a drobo with 4 x2 TB drives on it and would hope that it would show a single 5 something GB Drive, Here’s hoping someone out there has already tried this :slight_smile:

AFAIK WD TV players do not support large (>2TB) drives (MBR partition table has 2TB limit, GUID partition table must be used for larger drives).

Had a hunch there was a 2tb issue, so what if I make 3x2TB partitions on it? Why are some saying that the wdtv will only see one, and its a random choice?


Dumb devices do not have the chipset
and drivers needed for port multiplication
and therefore will only be able to see only
a single partition.

Thanks for the help all. Ill go annoy WD for a while… :slight_smile:

Steve,
I have had mixed success with my Drobo FS supporting my WD boxes. The best configuration is to use the WD Media Hub with the gigabit lan connection. Assuming you have a gigbit lan between both the Drobo and the WD Hub, the speed will generally support hi def material (.m2ts, .mkv, etc) But please reminded that WD does not at this moment support BD-ISO. I keep hoping. On a further note, I have been trying out the Netgear NeoTV 550 but finding the connection with the Drobo FS is not fast enough to support hi def. There is some kind of configuration problem that I have yet to figure out. The appeal of the NeoTV is that it does support BD-ISO and all of the hi def sound codecs. Good luck! Deman

Thanks, WD seems to be saying that the problem with large drives is the sector size of 4k, they seem to think that a 512 size will work… I have an old second Gen with 4 blank 2TB drives in it. Im going to play around.

If I have any luck Ill re post

Sector size is most likely not the issue here. The issue is partition types and multiple LUNs/volumes. You need either GPT support or multiple LUN/volume support to be able to access more than 2TB of storage.

Partition type is an issue because a >2TB volume requires a GUID partition table, or GPT.
“Dumb” devices tend not to understand GPT. Heck, Windows XP and earlier doesn’t understand GPT either.
If your device has GPT support, then you could format Drobo as a >2TB volume (usually we just go 16TB) and you’d be good until the grand day when drives are large enough to have more than 16TB of protected storage in your Drobo.

Multiple LUN/volume support, is what allows a host to see more than one logical volume on a single connected device.
If your device had multiple LUN/volume support, then you could format Drobo as 2TB (XP-compatible) volumes and it would present as many volumes as necessary to address all of the available protected storage. Your device would then see multiple drives.
For eSATA/SATA connections, the eSATA/SATA host must support Port Multiplier capability in addition to the host OS/software supporting “paying attention” to more than one volume.

I have a drobo G2 and wd live all newest firmware. I had 2 4tb partitions on my drobo and hooked it up to the wd live. It only detected the first partition but worked.[hr]
Also if your going to hook up a drobo to a NAS Router you have to do 2TB partitions. And maybe set it up for XP instead of Vista when you format it. I have tried 4 and 8TB partitions with the Vista way and it doesn’t work. And right now it looks like all routers are in the same boat.

Well it works to hook up a drobo G2 to a netgear WNR3500L. You have to do 2GB partitions in either Vista or XP mode. Both work. I only tested it for a few minutes but decided not to go that route. It would only do 2.5mb/s hardwired. My normal is around 20mb/s. So screw it will just leave it hooked up to the computer for now.