DROBO will not accept new drives

I currently have 4 -2TB drives in my Drobo S. I have about 24% open space and wanted to add a 4TB drive to the last open slot. When I insert the new drive the light continues to blink red and the dashboard says the slot is empty. I also tried taking out one of the current drives and replacing it with the 4TB and still got the blinking red light. I also tried this same process with another 2TB drive and got the same results.

The Drobo is currently running the “Data Protection”.

Anyone have any thoughts on what to try next?

What firmware do you have? According to this page you need to be at 2.1.0 or greater to support more than 2TB drives. http://support.drobo.com/app/answers/detail/a_id/506/~/does-drobo-support-drives-larger-than-2tb%3F

This page talks about the update procedure if you’re before 2.0.1 now. http://support.drobo.com/app/answers/detail/a_id/351/related/1

I have 2.1.5 firmware installed.

OK, you have to wait for the data protection to finish before we can try anything else. Do you have an external drive case or one of those USB to SATA adapters you could use to ensure that the new drive is OK? You can format it, put test data on it, whatever you like. When you put it in the Drobo it will reformat and “take over” the drive even if it’s a used one.

I have backed up everything on my Drobo. I dont have a way to test the HD’s.
Should i try and reset the Drobo?

hi ben,
as you probably are already aware, resetting with drives inside will wipe your data…can i check if the data protection/rebuilding process finished ok, as spiney mentioned?

and is the current problem, that the new blank (previously untested) 4TB drive, is showing up with blinking red lights when put into the last drive slot, as well as the 2TB drive? (potentially untested or was it used before somewhere else?)

i think there are some more ways forward but just to check on the above for when you get a moment.

It seems that any drive i put in the last open spot gets the bad drive error. I find it hard to believe that 2 drives would be bad right out of the box.
When i add the drive i get the blinking red lights.
I also tried moving one of the other good drives in the drobo to that open spot and got the red blinking light and was told that the drive was bad.

Thoughts?

Thanks for all the help so far

thanks for the info ben,
i think if you have a backup of all your data, then one thing you could try for testing the slot is the following:

  • to power all down
  • to unplug the power and connection cables from drobo
  • to remove a drive that was working fine (such as from the first slot)
  • and to simply move it to the bottom / last slot that is a suspect slot.
  • and then to plug the power cable in and to power up again.
    (what happens now?)

if it goes into the usual bootup sequence with blue leds and then goes into standby mode, can you then power up the computer, and once that is up and running, to then plug the connection cable back into the drobo.
(does it wake up and work fine as before, and the moved drive is detected ok in dashboard?)

if so, then the chances are that it is a problem encountered in some way with those 2 specific drives you tried before.
If the moved drive, no longer works and is not longer detected properly, then the chances are that the slot (or backplane) for that slot became damaged in some way.

Paul’s method is a good way to test and confirm is the fault is indeed a faulty bay connector or the drive itself…

(thanks don.esc) - am not sure what would be better for ben - to have a faulty slot, ending in 1 less slot to use, or to have 2 faulty drives which need replacing/re-purchasing etc.

Ok so i tried what Paul suggested. I put the drive from slot 1 in slot 5 and then powered up and all lights went green.
I then powered down and put the 4tb drive in slot 1 and fired it back up and am now getting a blinking red light in slot 1 indicating a bad drive.
Could it be that i just have 2 bad drives right out of the box. I hope not but looks like slot 5 is still good since it is now using one of the old drives with no issues.

I am going to see if i can swap our the 4tb for a new one from the place i purchased it.

Any other thoughts here???

thanks for the update ben,

since a 2TB drive (as well as a 4TB drive) were both giving problems (and in a seemingly working slot) then it does seem to point to something about those particular drives (since you do have what appears to be the latest firmware for the drobo-S regarding the bare minimums for using drives greater than 2TB)

if you do happen to have any more info you could post about the current drives that are working in your drobo, such as which slot, size and make/model, and also for the two problematic ones, it could be useful too if you get a chance, but please also let us know how things go with the replacements.

Paul
I returned the 4TB for a new one last night. Popped in the new drive and boom. Green light. Looks like it was a random case of 2 bad drives right out of the box. Something was being weird when trying to swap drives before unplugging all the cables. That seemed to help as well.

Everything is working as should be now.

Thanks for all the help

cool ben, sometimes drives can get damaged in the post or dropped during transport etc, but am glad to hear all is ok with the new drives :slight_smile: - and with that, now i can give myself permission to eat some more biscuits ive been holding off on :smiley: