Drobo

Drobo system extension has been blocked by macOS

Mac Pro (late 2013) running Mojave 10.14.6

I get an error message when the Drobo Dashboard is attempting to connect to the Drobo 8D.

It says "Drobo system extension has been blocked by macOS. Please go to “System Preferences >> Security and Privacy >> General” pane and allow the extension to be loaded.

When I go to the General pane, there is nothing there to allow the extension to be loaded.

I have tried uninstalling and reinstalling the Drobo Dashboard, turned off all of the virus and firewall systems.

Reboot your Mac. As soon as the Desktop/Finder reappears go into Sys Prefs (as above screenshot link) and then you’ll see the extension to approve. You only get a thirty minute window to approve the extension, if you don’t within that time then you have to reboot the Mac in order to see the approve button again for another thirty minute window.

Hope that helps.

Thanks for the reply! I have tried that, but when I go to approve, there is nothing there. It is very frustrating. Any other tips?