Drobo

Drobo support is terrible

I purchased a 2nd Drobo 5C as a backup and it shuts down and disconnects when trying to copy files to it. I reported this to Drobo support 10 days ago and they still haven’t sent a replacement unit. The support I’ve received from them is some of the worst service I’ve ever experienced… Here’s my most recent communication from them…

DROBO: Thank you for the update. The development team has reviewed the diagnostic file. When you are seeing the unit shutting down, what are the lights doing? Do the lights change?
Does it appear to reboot fully or is the power light still on? Do we know when the disconnects occur?

MY REPLY: I can’t believe it’s taken 10 days since I first reported the issue for you to now be asking those questions. These should have been asked a week ago. The lack of urgency on everyone’s part with Drobo is unbelievable. Also I have repeatedly asked for someone to pick up the phone and call me to help expedite the process… but all that you do is email a couple questions… a couple days after I reply you email a couple more questions. We’re 10 days into this problem and you’re still asking questions…

To answer your questions.

  1. When you see the unit shutting down, what are the lights doing… All of the lights on the Drobo go off, except the lower left light which goes from green to amber.

  2. Do the lights change… I have never seen this happen as the problem is intermittent and may happen in 30 minutes or 2 hours. As I’ve said before… I start files copying and walk away… when I come back to check on progress I see the errors on the computer screen (which I’ve sent to Drobo multiple times)… and the unit no longer shows up in the computer. To get the unit to reappear, I have to manually hit the power button on the back of the unit… or reboot the computer which reinitializes both Drobos.

  3. Does it appear to reboot fully or is the power light still on. I believe there have been cases to where the power light goes out completely. But to get the unit to power back up, I have to manually hit the power button on the unit or reboot the computer.

  4. Do we know when the disconnects occur… As I’ve said many times in my communication with Drobo, it is intermittant and random. In the time since I’ve first communicated with Drobo, it has disconnected 40-50 times as I’ve tried to copy data to it… and as I’ve also said repeatedly, this has happened on 3 different computers and with different USB cables and at different physical locations… both at my workplace and at home. Also, as I have repeatedly said, I have another Drobo that I’ve owned since earlier in the year and I have never had this issue with that unit. It’s pretty apparent to me that the unit is defective. Drobo should have long ago sent a replacement… if nothing else but as further testing.

Yes, it has always been dismal.