Drobo

Drobo shows disk space incorrectly

After drive failure and disk replace Drobo shows the amount of free disk space incorrectly. Df, du etc. shows that there is 1 TB used space, but Drobo dashboard and Drobo lights shows now that there is 2 TB of used. Why is Drobo showing the disk space incorrectly and is there any tips how to solve issue? I even tried replacing smallest HD with larger one. Actually Drobo showed incorrectly 1.37 TB of used disk space, but after changing HD it started to show 2 TB of used disk space. There is 2 x 1 TB and 2 x 640 GB disks mounted atm.

Have you run repair disk or chkdsk depending on your OS on your drobo?

No I haven’t. Is it allowed to do for Drobo? I’m on OS X.

After a disk failure Drobo showed the amount of free disk space properly, but in the middle of rebuild process it started to mess up with used disk space. I’m not even sure about how much there should be storage capacity totally. Dashboard shows used space 2.04 TB, free 15.82 GB, total 2.05 TB. Disks are what mentioned above.

yes, you should run it regularly to maintain volume integrity (monthly should suffice)

Yes exactly what Docchris said. :smiley:

:smiley:

hehe!

I just did disk repair and it reported that there is no problem with Drobo. Disk space is still reported incorrectly. However, I noticed that when Disk Utility unmounts Drobo the disk space is showed properly in Dashboard and when it’s mounted back it’s showed incorrectly again.

Looks like I solved the problem. Now used and remaining disk space is showed properly on both Dashboard app and Drobo’s LED lights.

How did you fix it?

I’ve noticed that problem occurred when I started Drobo Dashboard app. After reinstalling / updating Drobo Dashboard all went back to normal. Interesting is that bug in Dashboard app caused also malfunction on Drobos front panel led lights. In common sense I thought that the information traffic between app and Drobo is mostly unidirectional. Wrong kind of behavior in Dashboard app shouldn’t cause problems in Drobo hardware.

interesting, i knew that dashboard can “set” the capacity lights and that sometimes (mainly when things arent working) the lights display different things depending on whether you are running dashboard or not

im glad its fixed though :slight_smile: