Drobo

Drobo S with USB 3.0 not working in Linux

Hey folks,
Drobo newbie here, although I felt like I did my research before taking the plunge.

My goal is to replace my linux raid with my new Drobo S and continue using linux as the host system.

I’ve installed drobo-utils on Ubuntu server 11.04 without issue.

However, when I try and run: drobom view it tells me “no Drobos discovered”.

When I run drobom -v 16 I get the following:


sudo drobom -v 16 status
examining:  /dev/sda
id:  (0, 0, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sdb
id:  (0, 1, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sdc
id:  (1, 0, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sdd
id:  (1, 1, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sde
id:  (2, 0, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sdf
id:  (3, 0, 0, 0, 'ATA     ')
rejected: vendor is ATA      (not from DRI)
examining:  /dev/sdg
id:  (6, 0, 0, 0, 'USB 3.0 ')
rejected: vendor is USB 3.0  (not from DRI)
examining:  /dev/sdh
id:  (6, 0, 0, 1, 'USB 3.0 ')
rejected: vendor is USB 3.0  (not from DRI)
returning list:  []
No Drobos discovered

As you can see, the new USB 3.0 model lists the Vendor ID as USB 3.0

The sorceforge page says you can issue: drobo -s status and I’ve tried both
drobom -s USB 3.0 status
as well as
drobom -s ‘USB 3.0’ status
(and used double quotes)

both just return the help text, like -s isn’t valid.

Any ideas? I’d settle for a workaround, my only goal is to set the LUN size. Once set to 8gb, I’ll use eSATA for the transport. I have access to OSX machines and windows in a VM.

THANKS!