Drobo S stuck in data protection for 3 weeks

So the lights have been flashing on all four bays for 3 weeks, in that 3 weeks the dashboard has not given me a steady time frame or progress bar. There was a few time it said 64 hours, and 17 hours, but mainly no time estimation. All the while I could not access it.

Yesterday all bays were green… but my computer ( to which it’s connected to by USB ) could not see it. So, reset everything, now it’s back to data protection, with one difference, now I can access the content…slowly.

What should I be looking into? How can I fix this?

I’m ok to buy a new one ( I’d rather not yet, it’s still a little rich for my blood ), if I knew that I could just pull the 4 drives and install them without any data loss in the newer drobo.

However, I’d like to hold off until the end of the year and upgrade to a NAS.

I have a diagnostic of the drobo from the dashboard, but naturally, it’s way above my pay grade to understand it.

Drobo 4s
firmwear: 1.4.2 [1.254.50341]
HDD’s 4tb, 3tb, 2tb, 2tb ( 82%full )

hi if the dashboard shows you that data protection is in progress, then usually its 1 day per 1tb of data that you have on it.

the estimates can fluctuate and i actually just posted a similar post here just now :slight_smile:

usually you can still access your data if theres a drive failure (unless some particularly intensive rebuilding is taking place) but if you do, it will slow down the rebuild.

essentially it seems like a drive is failing and the rebuild is taking place so i would try to let the rebuild complete and get things stead again before you replace any failed drive etc…

if you get stuck feel free to post back later with an update and we can try and help

Well, a week later ( 2 days ago ) and the lights have stopped flashing, and were standing at 4 solid orange.

Drobo dashboard could not detect any drobos… so i power cycled it ( I moved it over to my laptop, where I could more comfortably observe it).

Powering on brought back the flashing green/orange and dashboard could now detect it.
I deleted 2TB of data to mopefully give it more room to play with.

2 days later…solid orange, and non-detectable…again.

power cycled again… same thing currently… flashing green/orange and detected by dashboard ( all the while window off the task bar stating drobo cannot currently protect my data…

I submitted a support ticket last week with dashboard diagnostic, but have yet to hear anything back.

Worst case question…I abandon this 4 bay and I buy a new drobo ( 5 bay NAS ) can i pull these 4 HDD and use them in the new box and still have all my data? I cannot afford to do this at this time… but if i just let this collect dust for a few months ( which I would prefer not to do )… and when i can afford a new box…

Before you head out to get a new Drobo 5N (5-bay NAS), just to let you know the Disk Pack migration path:

  1. Drobo S ( Older 5-bay, with 2x FW800, 1x USB and 1x eSATA)
  • Disk Pack from Drobo S can ONLY be migrated to Drobo 5D (5-bay, with 2x Thunderbolt and 1x USB 3.0)
  1. Drobo FS ( Older 5-bay NAS, with 1x Ethernet Port)
  • Disk Pack from Drobo FS can ONLY be migrated to Drobo 5N

You CANNOT migrate a “Direct Attached” Disk Pack from Drobo S to a “Network Attached” NAS Drobo 5N. You will need to manually mount the older Dorbo S, copy all the data into the new Drobo 5N.

OK, so what I get from that is that I can take my 4bay gen2 and put it in a 5D… OK I get it. If I want to switch over to a NAS, I would have to buy the box and more HDD… that’ll have to be the long term plan I guess…

Thank you for that info

OK besides that now, my Drobo now sits with 4 green lights, but is still undiscovered by the dashboard and the computer.

When I power cycle it my computer registers that something is disconnected, but nothing changes on the Devices and Drives window…

I’m unhappy about this disruption in my normal routine…

hi, can i check when you powercycled it too, did dashboard find it?

you may need to powercycle the computer as well
and possibly to go to services.msc from (start > run) to disable and stop the dashboard service, (and to quit dashboard app) and then to re-enable and start the service, and then to relaunch dashboard app.

does that get any further?

(also with the drive lights being all green, can you sense any activity / vibrations / disk access noises from the drobo? if so it might be finishing something before it makes itself available to the computer - though i would have thought not if all green).

if still no luck, then there is something else to try:

  • to power all off (computer first, and then drobo once it goes into standby mode)
  • to then unplug the computer connection cables, and power cable from drobo.
  • to discharge static from yourself as per usual and to then take out all drives (as a disk pack) and to keep the msomewhere safe in same order)
  • to then power up the empty drobo and let it boot up
  • to then power up the computer and let that boot up fully
  • to then connect the usb cable etc to the drobo and computer…
    does dashboard now see it and what do the drobo lights do and show?

Dashboard can only find it when it’s flashing and protecting data, which lasts about an hour after startup. I did notice only one hard drive ( 2TB, smallest of the 4 ) was red for about 30 seconds when i started it up once.

I’m getting this message quite late in the night, I will try your suggestions tomorrow. I appreciate your time.

ok hang in there :slight_smile:


ok, so a few days ago I swapped out the 2TB for a 4TB drive ( since that was the only drive showing failure ).

It started the data protection process as normal. It started by saying 600+ hours until complete ( 2 hours later it said 200 or so… ) which i didn’t balk at, due to taking that number as an estimate.

Now, however, it’s been data protecting for 5 days and I’ve gotten a different estimate every time I look at it. From 1766 hours to 24 hours, back to 700 hours, to 900 hours, to 60 hours… once was over 6000 hours! Half the time the progress bar isn’t even used ( just white with no blue sections filling it )

This is getting quite frustrating and am thinking maybe building a freeNAS box may be the route I take after I realize and accept that I’m not getting any of my data back… since none of the 3 tickets I’ve submitted to Drobo support have had any answer, I don’t know if I want to continue using their product.

I appreciate the help I’ve gotten from this thread though, it’s just disappointing that it hasn’t resulted in any progress as of yet.

hi, any time spent from us with posts for you is always well spent, though yes it might not seem like top progress from your side which is understandable.

if i remember correctly, your initial post of “HDD’s 4tb, 3tb, 2tb, 2tb ( 82%full )” is now having a 2tb with a 4tb?
i forgot how much actual data you have but if i do a quick calculation of raw space, 4 (-4) +3+2+2 = 7 (x.9) = 6.3 x.82(%) = about 5.2tb of data = about 5-6days all things being equal.

maybe you could try powering down the computer and to give it another day or 2 to blast away with the rebuild at full speed (just in case something is slowing it down)…

also just a thought… but once you get the all green lights again, could you try plugging it into another different computer as a test? (i ask this because another user recently had lots of problems getting his windows 7 to recognise the drobo again, but it worked perfectly on another computer and might have been a software issue) so was just wondering too for later on.

I swapped out the 2TB HD and deleted a bunch of information during the last window of access I had ( in an effort to lighten the load ). It now contains 4tb, 4tb, 3tb, 3tb ( 9.06 tb total- 57% used 43%free ).

It’s been rebuilding with the new HDD for the last week. it was stuck at ‘196 hours remaining’ for 4 days, after a power cycle it went down to 96 hours the next day, now I cannot get an estimate. I will try leaving it disconnected, however since it doesn’t recognize the drive, I’m not accessing it during the rebuild. ( that’s not to say that nothing is, so it’s worth a shot )

The computer I had it on before the issue was primarily an HTPC that runs Win7, the computer I’m doing the work from is running a newly upgraded Win10 ( from Win8 ).

Thank you,
I really do appreciate your attention with this matter.

hmm maybe it did get stuck somehow, and now is actually finishing the rebuild.
96 hours is about 4 days, so maybe if you leave it disconnected from the computer for 5days and see if all the lights become all green again.[hr]
the only other thing i can think of (though im not 100% sure), is that maybe there was a small problem or hiccup, with a drive which might have set the drobo-s doing its data scrubbing routine, where it cross-verifies the data to make sure its all ok across the drives, and that somehow it was running in conjunction with the rebuild, which slowed both down) but try to leave it for another 5days if you can.

OK, 10 days and no apparent progress. I don’t even get a time estimate now.

screen grab here: http://imgur.com/zmd7b5B

hi thanks for the screenshot:

can i check if the drobo blue led lights (on actual drobo unit itself) are also matching the 5 shown on the dashboard?
(and can you remember if those drobo leds have been changing/increasing at all?)

The lights do match up, however…for some reason, there are now only 4 of them…and the total data capacity has changed…? I haven’t accessed it at all, now its registering a smaller number…

This is what it is now: http://imgur.com/rXvDCdO

This drobo is really messed up, isn’t it?

ok thanks for that,

when ive had some issues with my drobos before, the physical capacity lights were not matching up as expected, and when they stabalised over time.

while it does look like yours is in a bit of a messed up state, i think its still beavering away…

am not sure as to what to advise next, but before anything drastic like pulling the plug and reformatting etc, it probably is good to just let it do its thing, at least for longer (since it shows varying data stats). if it hangs on certain values for longer than the last time duration for a change in stats, then you might be able to try rebooting it but for all we know a reboot adds more delays and reprocessing.

Hello djbtoxic,
Would you direct message me,I would like to check something with your configuration.