Drobo S on Mac connects but not as drobo.

I recently had to replace my hard drive in my iMac. I cloned it to an external drive then re-cloned it back to the new installed hard drive. Ever since my drobo mounts but the icon is the generic orange external drive. and I have to unplug the drobo and plug it back in for the icon to go back to the drobo icon. While it is generic orange, dashboard can’t find an attached drobo. But after the drobo reboot it does recognize it. After any outage of power or reboot of the iMac. The drobo goes back to generic orange. I have the highest Drobo S firmware and the most recent Dashboard 2.6.4 i think. I even transferred all the data on the drobo to an external hard drive. Re-formated the drobo and transferred it back to the drobo. That wasted 5 days and did not work either. Please help.

Latest OS Yosemite has been installed.

Are you running Yosemite??

This started happening to me when I upgraded to Yosemite!!

I used to do the EXACT same thing to make it work!!

I just picked up another 5D (Thunderbolt) and put this DROBO S on my older IMac running Snow Leopard!!

I am having the same issue. I contacted support. I will update if I find a solution.[hr]
I downgraded my Drobo Dashboard from Drobo-Dashboard-2.6.4 to Drobo-Dashboard-2.5.3 and the problem no longer exists. This is the only version I have. So I am unable to test with a newer one.

I will update when I here back from Support.

I contacted support and they recommended installing Drobo dashboard 2.6.5. I did this and it worked. It solved this problem.

I had a problem with Drobo Dashboard not finding my Drobo, so upgraded to 2.6.7, and I now see this problem of an orange Finder icon. At least Finder can see the Drobo - Dashboard still can’t find it!