Drobo S hangs after 2.1.5 firmware update

I have a Drobo S Gen 2 (circa 2011) that was running firmware 2.1.2. I did a manual update to 2.1.5 using dashboard 2.6.4.

From the very first restart, the Drobo freezes during its boot cycle. It seems to go through most of the cycle normally, then freezes with the following blue lights on (from left to right): 3,7,8,9,10. Power light solid green. Unit does not mount; can’t be found by Dashboard.

Any clues for a fix?

Here’s what I’ve tried so far:

  1. Disconnect from power and computer, wait 30 sec., restart.

  2. Power down, eject drives, re-start. It restarted normally (for a drive-less unit) and Dashboard found it right away.

  3. Soft reset from Dashboard (without drives)

  4. Hard reset with paperclip in pinhole (without drives).

  5. Let it sit turned on overnight.

None of the above has made any difference. Does anybody know where I can find a copy of firmware 2.1.2 so I can roll it back?

Here’s my setup:
HP Z400 workstation with Win 7-64
Drobo S Gen 2 (circa 2011)
Dashboard 2.6.4
5 Western Digital 1 TB drives
eSATA connection

hi greg, sorry to hear about your issue.
its good that your empty drobo was still found in dashboard (this means that the unit seems to be ok)

as i was reading your status steps above, it sounded as though at no point was your drobo reset with your diskpack drives still inside it (which would be bad thing to do),

having said that though, i wasnt sure if you have put your drives back inside the drobo after steps 4) or 5), (or how you put them back in - for example was the drobo powered OFF and with power cable unplugged, before you put your disk pack drives back into where they came from, ideally?)

it may not be this, though just in case you have not put them back in, please power all off and remove all cables from the drobo, and then if you put your drives back inside…

in case the drives are already inside (or are now currently inside), then a couple of ideas would be these:

  • to fully shutdown windows for at least 10minutes

  • to power up the drobo (which has your drives inside but no computer connection cables attached)
    (does the drobo boot up with blue leds ultimately from 1 through to 10, even if it takes an hour or longer to get there, and does it then end up going into standby mode?)

  • to then boot up windows, and once that is running, to load dashboard.

  • to then connect your drobo-s-gen2 directly to the computer via a usb cable
    (does the drobo wake up shortly afterwards, and then start becomming recognised by dashboard and then hopefully the computer too?)

in case not, then you could try putting the drobo into ReadOnly mode, as mentioned here, as it might be able to stabalise things?

Thanks for your helpful response, Paul. I tried all those suggestions but still made no headway.

I ended up acting on a hunch. Surmising that it was a disk pack problem, I thought perhaps it might be the fault of just one drive. I decided to power down/disconnect power, eject a single drive at a time, and restart. I ejected the top drive first, reconnected power, and restarted. The unit completed its boot cycle and entered rebuilding mode for about 4 hours. After that, it operated normally and all my data seemed to be present with just 4 out of 5 drives. I then powered down, put the top drive back in, and restarted. It completed its boot cycle without a hitch. Now the unit is operating normally with all 5 drives and the updated firmware, and all my data seems to be present.

It’s a weird mystery as to why that would happen. I think I maybe made a lucky guess at a solution, but my unit is back to being fully functional with a firmware update.


hi greg, thanks for the info. am glad its all up and running again :slight_smile:

if you had put that top drive back in (after removing it), while the unit was actually on, it would seem that it would simply be assimilated back into the disk pack if the drive was ok, though being removed while off, and put back in while off, triggered the rebuild (which appears to have been successfully completed). with this in mind, it’s good to have a few mysteries from time to time, though it might be worth double checking the status of the drives (via dashboard) from time to time, just in case there is a Warning, or Healed status message, especially for that drive which you removed?