Drobo-S Gen2 power switch wont power on - fixed

hi guys, i guess it was just a matter of time…

my Drobo-S gen2 wont power on after clicking the on switch(toggle)

I tried another power socket, and the psu brick seems fine, with a solid green light.

I tried unplugging the usb cable and power cable and re-inserting the power cable, but still the switch will only click and not actually power anything up.

I rang support and luckily still had some drobocare in warranty, and we even tried ejecting all the drives with the same test, but it seems that the unit had a fault - so hopefully i’ll go through the rma process in the next few days and ship the old one back etc.

very good support experience so far… lets see if i can get my data working again from the original disk pack :slight_smile:

just wondering if any of you have seen or had a similar problem with the power toggle microswitch?

Sorry to hear about your experience, Paul. I’m pretty sure your diskpack will work just fine in the new Drobo, especially given it was a “sudden death” of the unit itself.

But what makes you suspect it’s a toggle switch problem? For what it’s worth, it could be just about anything.

It could still be the power supply too - just because it shows a green light, doesn’t mean it provides adequate and proper power under load. :slight_smile:

thanks guys,
i actually completed the rma that day and the replacement unit+psu should arrive today/tomorrow.

ah i had a psu a year ago which would sometimes spark, and replaced it with a new one to play safe (which was working fine all this time) but didnt want to risk using that old one just in case it did more damage) :slight_smile:
ive still got that old one sitting in the drobo packaging box somewhere.

i assumed it was the toggle swtich, as the drobo and psu go through 2 surge protectors, and when i just begin to apply some pressure to the toggle switch, it seems to trigger (something) like a very low tick or hiss, but then nothing happens.

you’re right zbig, it could be something else, i just was using it like i usually do, and the toggle switch was the part that didnt power up so i thought it was that :slight_smile:

when the new unit arrives and is working, i might try the old psu (cable&brick) on the old chassis temporarily just to see if it starts up, in case it was a psu issue bhigga,

i dont move the drobo around, and only use the toggle switch when powering it on, usually 1-3 times a week, and i use the dashboard to shut it down. i chkdsk it maybe once every month or 2, and it seems fine, and its protected on the same surge protector as the computer it’s connected to. i thought maybe its just a spring or something which wasnt connecting / closing the toggle circuit, but i’ll try and find out from the support team what the issue was, as am now curious :slight_smile:

If only every time someone’s car won’t start it always turned out to be the ignition switch, world would be so much nicer place :wink:

Indeed! Took a extra hours for my wife’s old car before they discovered the problem wasn’t a faulty starter at all, but the crank position sensor (which controls the starter).

lol nice one zbig :smiley:

(maybe in the future they will blame it on the Flux Capacitor) :slight_smile:

Good news - the new replacement arrived and i did the swap and it works with my drive pack :slight_smile:

it took a while to get back to an all clear status, (including bootups, volume chkdsks, and data compare/verify etc) but thankfully a nice and swift recovery :slight_smile:

as a test, i tried it with the same (old) psu/brick so it’s definitely something else…
i’ll switch to the new psu/brick for completeness of replacements, and will ship the old one back with the faulty drobo soon.

as long as the upgrade/migration path still exists from a Drobo-S to a 5D, i’ll be happy in case anything goes wrong after this, as theres no more drobo-s drobocare available anymore :frowning: