Drobo S disk died, replacement disk light red, cannot mount, reboot loop

I have a drobo S generation 2 attached to a mac running Sierra (10.12.3). The file system on the drobo, in case it matters, is HFS+. One drive has failed, and I cannot get my data off.

It has long been true that if I attach via USB I can attach to the dashboard but not mount the drobo, if I attach via my e-sata to thunderbolt bridge I can mount but not attach to the dashboard, and if I attach via both I can neither mount the drobo nor attach to the dashboard. My firmware version is 2.1.5 [5.41.62910], and my dashboard is version 3.0.0 [88901]

All my disks were 2TB drives, and I was using single disk protection. The top drive failed (so said the blinking red light and the dashboard), and I can no longer mount the drobo.

I replaced the failed drive (which seems to work fine in another enclosure, BTW) with another 2TB drive. When it is not rebuilding, the light next to the new drive is red.

I replaced the new 2TB drive with a new 4TB drive. The drobo recognizes the 4TB drive no problem – no change in behavior. The drobo displays a solid green power light, then all 5 drive lights turn yellow. The drive lights turn off, and I see a blinking green power light along with running blue lights. The blue lights turn off, then the status light turns solid green while the power light blinks, then the power light turns solid green and the drive lights come on – 4 solid greens and one solid red. Shortly after, the dashboard finds the drobo and tells me to replace the 4TB drive with a larger hard drive. I scoff at it – 4TB is my biggest drive. The blue lights slowly turn on from left to right, while the dashboard indicates that more and more data is being used.

During this phase, Disk Utility does not display the drive, and it does not mount (regardless of how I have it connected). “diskutil list” on the command line shows the drive and an 8.8 TB data partition, but “diskuil verifyVolume” claims the partition is corrupted (Underlying error: 8: Exec format error).

Shortly after that, the lights begin to flash green and yellow; the dashboard indicates that data protection is in progress. This lasts for approximately one minute, the disk lights flash 4 red with one white, then all give turn yellow, and the cycle begins again.

Sadly, this loop does not last forever. When I leave it for a few hours, I typically come back to an amber power light.

I have powered down, rebooted, and reconnected both drobo and computer. I have unplugged the drobo and let it sit for 15 minutes. I have tried removing all drives from the drobo and resetting (twice). When the drives are removed, Disk Utility can find the drobo. I have disassembled the drobo and air-cleaned all components. I have tried running the drobo without the computer powered on. I have tried placing the drobo in read-only mode. No improvements.

I have no further ideas. I quite want my data back – some of it is not backed up elsewhere. I don’t really want another drobo, but if I knew for sure that I could get the data back, it would be worth it to me to purchase another drobo enclosure and pull the data.

Does anyone have suggestions?

hi msneergaard, sorry to hear about the issue.
(as a fellow user, i know in part, what it was like when my drobo-s-gen2 had a power switch-related issue, and stopped working in the past)

the good news in my case, was that i was able to follow the migration process, for example as mentioned below, and was able to successfully migrate my diskpack drives into a replacement model and access all data again:

for you, if your diskpack is ok, you may be able to do the same, though currently it sounded as though there were a few different issues…and it looks like you have already tried some of the things i would have suggested too, though can i check a few things…

when you mentioned this:
“When it is not rebuilding, the light next to the new drive is red.”
can i check if this was a solid red light (like when a drobo gets quite full) or was it also blinking and flashing?

as far as i understood things, when you did the reset, you powered down, unplugged all power and removed the disk pack drives, and then did the reset (via dashboard or was this the pinhole reset)?
and then after the reset, you tested the drobo and dashboard found it…
(at this point, could you also verify that the firmware was still what it was before? or has this changed?)

then, when you put your diskpack drives back inside, was this with power still all off?
(and then when you had your diskpack drives back in, and powered up im assuming it did not work and at this point you enabled read only mode too?)

do you happen to have another usb cable and port so that you could try another direct attachment via usb, just in case the port or cable was having some issues?

if that still does not work, i think it will be worth creating a ticket with the support team if you can, as they may be able to help ascertain if the disk pack drives are ok.

if the drobo has since been taken out of read only mode, and if a different usb cable or slot, happens to keep the drobo a bit more stable, then can i also check if you happen to have access to diskwarrior? (generally speaking, that will still require a drobo to be stable, rather than looping or rebooting on its on, but quite often on macs diskwarrior has been able to resolve a lot of issues where a drobo was just not mounting, and am just wondering in case that could help you too?)