Drobo requires activation message - cannot use

I purchased my Drobo a while ago, and just recently got around to setting it up with drives (4x3TB WD Red drives).

I downloaded the latest (2.7.x) dashboard and plugged my Drobo into my network switch. Drobo dashboard found my drobo, BUT when I double click on the Drobo I cannot do anything because the status says “Drobo requires activation”.

To be clear, there is no link to set an admin password, and I cannot create any shares, or access the Drobo in any way that I have found!!

I also cannot upgrade the firmware. Attempting auto update, it says my firmware us up to date (not true: FW is version 3.0.0). I attempted a manual update using the 3.5 version on the support web site, but it failed (unknown error).

I have ports 20/21 totally opened on my firewall (any to any connection allowed) temporarily of course.

I also tried to ssh into the unit using its IP address (from LAN/local). No luck, connection refused.

Ideas? Is my Drobo simply trash since I did not activate it when I bought it? I hope not, or there will be some very negative reviews coming.

Rest assured…no. I had the same issue when I set mine up a few weeks ago – and got that sinking feeling in my stomach. I don’t remember what I did (besides power cycle it a few times) – but eventually it came to. Sorry I can’t be of more help except to say, it’s not hosed.

ME too ! HELP ME

For those who has issue with brand NEW Drobo 5N “Activation” (without drives) with Dashboard v2.7.0 or v2.7.1.

Please try the following:

  1. Shutdown and Power OFF the Drobo 5N.

  2. Go to Drobo.com and manually download the latest Firmware of 5N which is v3.5.5.

  • Manually download the firmware to your Windows or OSX Desktop, and rename it to “release.Drobo5N.zip” (without the “”)
    **If you already have previously manually downloaded 5N firmware… (other version) is ok, we can use it as well. Again rename it to “release.Drobo5N.zip”
  1. For OSX:
  • Open Finder > Applications - Look for Drobo Dashboard app. Then Right-Click “Show Package Contents”
  • Navigate from “Contents” > “Firmware”
  • This is “Firmware” folder… you should see there is a “release.B810N.zip” file. Leave it and don’t touch it. Now copy your “release.Drobo5N.zip” file into this folder. Once done… close the FINDER.

For Windows:

  • Open File Explorer and go to “C:\Program Files (x86)\Drobo\Drobo Dashboard\Firmware”
  • Again in this “Firmware” … you should see a “release.B810N.zip” file. Again leave it as it is. Copy your “release.Drobo5N.zip” file into this folder. Close File Explorer.
  1. Now, with the Drobo 5N without any drives (EMPTY) connect it to your network (router) or you can also do a direct connection to the Ethernet Port of the PC or Mac. Either way is ok… connect via router or direct connect.

  2. Power ON the Drobo 5N, it will go to boot mode with some flashing lights.

  • Finally it will have ALL 10 Blue Capacity Lights blinking. *Is ok… don’t worry. This indicates the new 5N requires Activation.
  1. Open up the Dashboard… now it should detects the new 5N. Click on the Drobo 5N icon… and Dashboard will say “Activation needed etc…” and also “Upgrading … updating to latest firmware (it may takes 5 Mins)”. This screen will stay on until Dashboard completes updating the 5N with the firmware file (you previously copied into that folder inside the dashboard).

**Previously you should have noticed that this screen disappear very fast as if does nothing.

  1. Now just be patient… and wait. After Dashboard successfully updated the firmware of 5N with the “release.Drobo5N.zip” file. The Drobo 5N will then do a reboot and start-up again. This time… Dashboard will show that 5N no longer need Activation. It will show 5N now in the progress of set-up and initialise etc…

  2. Wait for the initialisation set-up completes… then Dashboard should prompt that it does not detect any disk… and ask you to insert a new drive etc… now you can process to set-up your new 5N as the user guide shown.

I’ve just gotten past this same issue (mine was with a 5D but the symptoms were the same) where a fresh out of the box Drobo stuck on the “Updating Firmware, this may take 5 minutes” screen no matter what I did.

I tried the paperclip reset, manually added the new firmware download to the Dashboard Application contents with no avail. I have 2 other Drobos on the same machine and the solution for me was to launch the dashboard and access the bricked Drobo by clicking on another drive and then clicking the Up/Down arrow at the top of the window rather then clicking directly to the drive. Clicking directly on the drive graphic would get me the “Updating Firmware” greyed out screen where I couldn’t interact with the drive in any way. Clicking in from another drive circumvented this overlay and allowed me to use the manual update button which successfully got the drive working.

The only oddity now is that my older Drobo is running 3.2.2 when the most recent download is 3.5.0 and yet the auto updater says that I have the most up to date firmware installed. I’m going to manually update now that I see the issue, but its frustrating that the auto updater is allowing things to get so far behind.