Drobo red lights only with certain drives

I do have problems with my Drobo 5 c, First I check or the Drobo is oké: All green lights on Drobo:

and is mounted:

In Drobo dashboard: everything is “GOOD”

After shutting down the Drobo bij clicking on the shut down in the Dashboard (power off)
I change the emty disks of 2 TB (5 disks) to the disks with my (for me valuable) data disks (in the right order.
I did change the drives with my data disks (there are only four disks) 6 TB+6 TB+8 TB+3 TB
After starting up all the drive bays are RED

Drobo did not detect any drives:

Does not mount

BUT names and sees any drive???

And every drive’s health is GOOD.

Can someone help me with this (for me strange problem)?

Many thanks in advance,

Hi Jan,
I am having a little trouble understanding the actions you took.

In your Drobo 5D, did you have a different HDD array with 5x 2TB HDDs originally and you have changed that by replacing all of them for the new 4x HDDs you show in the image?

Dear twin tiger,

It is exactly as you say.

I tested the Drobo with 5 clean and empty 2 TB drives, everything is oke, it mounds, all lights are green, i can copy to and from the Drobo.


I took the power of the Drobo, took the 5 drives out and replace them with my 4 “data” drives. (6 TB+6 TB+8 TB+3 TB)

drobo says in “knob” volumes in Drobo dashboard “Drobo did not detect any drives. Please insert drives to use Drobo”

when i use the “knob” status in Drobo dashboard drobo sees each drive (in red) and say “Health” is good! see picture.

Thanks a lot!

OK, can you confirm that when you had the original 5x2TB array inserted that the Drobo Dashboard and the Firmware were up to date?

If you are not sure, turn off the Drobo and reinsert the 5x2TB array and check. If it needs updating then please do so.

Can you advise where the ‘new’ 4 HDD with all your data has come from? Another Drobo (which type)?

Dear Twin Tiger,

I appreciate your effort to help me!

I reinserted the 5x2TB array and tried to update the drobo: popup in Dashboard: “Drobo has the latest versions of the Drobo Dashboard and Drobo Firmware”

Shutted down Drobo, and changed the 5x2TB array with my “problem data” array (6 TB+6 TB+8 TB+3 TB) started up again and the same as described 2 days ago happend.

The “problem data” array was in a drobo 5D which broke down en is now again in another Drobo 5D

I was not aware there where different specs between DroBo’s with 2 thunderbolt and one USB connection.

I am going to assume that your new 4xHDD array has been positioned in the same order and slots as the broken 5D. Let me know if not?

The next action will try to flush the 5D
You need 2 spare HDDs (not from your previous 5x array however) - small capacity but make sure they are compatible with Drobo (not SMR)

  • Turn off your Drobo (even remove power);
  • Eject you current array (mark their order);
  • Insert the 2 spare HDDs;
  • Reconnect and boot up;
  • Review if your Drobo become visible on your Mac - if so, let it go through the process of establishing the new array (even test it by moving in a file);
  • When complete, close down and turn off your Drobo;
  • Eject the 2 HDD array, reinsert your original array in order;
  • Reboot.

Let us know whether that gives you access to your data?

Dear Twin Tiger,

  1. turned off and removed power,
  2. two new HDD in Drobo,
  3. booted up,
  4. from beginning is working oke,
  5. was updating data (green/yellow blinking) after that,
  6. visible on mac and moving files up and down the Drobo,
  7. powered off,
  8. inserted my 4 drive array (right order)
  9. red lights, not showing on MAC,

could not acces data.

many thanks for your help, do you have more idea’s to get acces to the data?

That is a little disheartening! On the positive side, it appears that the Drobo is working correctly.
That now points the issue solely at the HDD array and data.

Others may add their suggestions, however you have 2 options that I am aware of:

  1. Rebuild the data directory using DiskWarrior to trouble-shoot and rebuild the file directory if it is HFS+ (but not APFS). DW has the ability to ‘find’ and recover lost volumes. The only other issue is that DW is not (yet) compatible with the current MacOSs and it needs to be installed on an older MacOS therefore check their website to ensure you have a compatible Mac + MacOS to use. I have an older Mac laptop that is designated as my Rescue Mac with DW installed to keep my Drobo 5Dt file directory optimised and I run it each half year or after a massive data download.
  1. Offload your data using UFS Explorer (Mac and Windows downloads) to try to read and recover the data. Here is the link to that information:

Best of luck moving forward.

Dear Twin Tiger,

I go hunting for an older laptop in my friends and bussines entourage!

Dear TwinTiger,

I laid my hands on a laptop air with OSX El Capitan (10.11.6) and i bought Disk Wrior, the problem is that DiskWarior the Drobo nor the drives see, so there is no way to reach it. The disk utility sees the drobo, i tried the “disk first aid” which was very fast…but with no succes.

many thanks,