Drobo

Drobo randomly ejects/unmounts (Mac)

I’ve had my Drobo for quite some time, probably since about 2009-2010. It is a 4Bay (2nd generation/ USB 2.0 model). For the past several months my drobo randomly ejects itself from my mac and reconnects about 30 seconds later. It does this several times a day. All drobo firmware is up to date. Running OS X 10.10.4.

I’ve experienced this problem on 2 computers, I’ve tried 2 different USB cables and 1 firewire cable, multiple wall outlets, bypassed my surge protector, the problem persists in all situations.

Any thoughts or suggestions on how to diagnose & resolve the problem? Thanks.

hi, do you know if there is another usb port that you could try, just to see in case it was that particular port?
(sometimes its the cable but sometimes could be the port.)

also, do you know if drobo dashboard service and app have permissions in the mac firewall, just in case a setting is blocked?

has it been doing this when youre not using the computer for a while? or is it just random?

I am having the exact same problem! I noticed it starting a couple of months ago but have not updated or changed anything regarding the setup since it seems to re-connect itself each time.

Sometimes it mounts back and sometimes I have to go hunt it down and re-mount it myself.

@Paul and @joeycerone, have you called Drobo support? I would be interested in hearing their solution if they had one.

Interesting, when the unit un mounts, what are the lights doing? Does it just un mount at a specific time?

What kind of Drobo is being used? How is the Drobo connected?

Have you tried changing cables and ports?

I have the 4 bay Drobo (I think 2nd gen) and I get a message from my Mac that the Drobo was “Not Ejected Properly” and then the Drobo restarts itself. The blue lights run across the bottom of the device and you can hear each drive booting up and then the lights turn green. Sometimes I have to remount the drobo and sometimes it’s there in the finder already when I look.

I have not tried changing cables or ports. I have it hooked up with a firewire and I only have one port on my Mac. Maybe I should do that :slight_smile:

hi sheila, if you have a chance to try with just usb, maybe give it a go,
over the years, usb always seemed to be more stable than firewire, but maybe a bit more info about how nicely you treat your drobo, could be useful…

eg, do you just pull the powercable out of the back when you finish using it, or do you show it some love and safely power it down? :slight_smile:

Also having the same problem running nearly the same OSX as you here:

http://www.drobospace.com/forums/showthread.php?tid=145343&pid=195794#pid195794

thanks ian i just posted something on your thread, ,and thought of something else here…

i was wondering what happens if you try disabling spotlight indexing (if enabled by default?) just in case it is causing conflicts in some way?

Thanks for the suggestion Paul, I tried disabling the spotlight indexing (as described here: http://recomhub.com/blog/how-to-disable-or-enable-spotlight-in-mac-os-x-yosemite-mavericks-mountain-lion/)

Still getting the same ejecting happening.

I was having this until I replaced the oldest hard drives that I had. I think what’s happening is that a drive is dying, and temporarily goes off line. The Drobo notices, and starts to rebuild, and then the drive comes back and it gets confused and “wigs out” and disconnects. It then gets it’s brains back and mounts itself again. Rinse and repeat…

Once I changed the drives it has (seemingly) stopped happening. The real problem with the Gen 2 is that the logs are encrypted and only Drobo can read them, but they won’t unless you’re in support/warranty or you pay the $99 per incident fee.

Maybe if you had a camera pointed at the Drobo and caught the “glitch” on the lights you might be able to see the light change on one drive bay?

thanks for the info ian,
if spotlight or other auto scanning/indexing programs have been stopped, and it still happes it might be as spiney mentions about a drive.

have you fully shutdown the drobo and mac since changing spotlight? (if not, it might be worth trying)[hr]
btw (for ian) we been posting on another thread here too:
http://www.drobospace.com/forums/showthread.php?tid=145343

(as the original poster was posting about a gen2, can i check that your posts here are definitely for a gen2, or is it possibly about your 5d?)

I have had the same problem. i have recently switched Mac’s and gave it a new home. After about a week it started just ejecting it’s self. when I keep it busy it’s ok. When the computer is not used for awhile an goes to sleep it will disconnect. Not all the time but off andf on. All the lights are green and everything seems ok.

I have the same issue (I have Drobo 2) and it started when I installed El Capitan OS 10.11.3 on my Mac Book Pro. My hunch is that it is related to the OS and I have been told to talk to Apple about issues with the OS.

same issue here renders my Drobo useless, it injects itself within 10-15 minutes, all lights are green it has recently being formatted and has plenty of space. using it for Time Machine

hi bill, david and 4sprung,

is it possible for you to post some more details about your machines and your setup please when you get a chance? (am just trying to see if there are any patterns emerging)

for example,

  1. When it worked before (which operating system and version, dashboard version and drobo model name & firmware version did you have)
  2. Now that its not working properly (same info as above but if you are not 100% sure it’s ok though, please try to fill out as much as you can as it might be useful, along with any other information you have)

Sorry for reviving this thread - but I have the same problem.

I’ve been experiencing this for around a year, but as it’s on my home computer, I wasn’t that bothered; the only real consequence was the need to restart the Drobo and Mac every now and then. It’s also a Gen 2 (USB / Firewire), and it’s attached to a Mac Mini (3Ghz 2014) running Yosemite,

However, the most recent “unmount” corrupted my Photos library - which was a right pain and the only reason I was using something like a Drobo in the first place.

I have two questions:

– Will switching to a newer model fix this? Is this only a legacy / Gen 2 problem?
– If I’m migrating to a USB 3 Drobo or Drobo 5D, can I simply swap over my drives? Or is it a more painful transition?

Many thanks…[/align]

hi brendan,
in terms of migrating, it is essentially a relatively easy thing to do when power is all OFF and unpugged, and there is a page available here with more information about the migrations process, including a table to show which models can migrate to which models:
http://www.drobo.com/resource-center/migration/

(when one of my drobo-s-gen2 models had a power toggle switch problem, i was able to successfully migrate my disk pack to another replacement drobo-s-gen2, and all was ok)[hr]
for the unmounting issue you are experiencing currently, can i check if you are having that, at random times, or even in the middle of doing things? or is it usually only after longer periods of inactivity, or possibly the mac sleeping?

it could be worth trying to use another connection cable, or to alternate from usb to firewire (or vice versa) just to see if that makes a difference, in case it is a faulty cable somehow?

my gen2 (touch wood) is still going strong, via usb, and the only time i ever had a corrupt file, was when it was the fault of a memory card on a camera (the source) which caused the image to have problems, and not the actual drobo, but yes, sometimes the operating system can affect things, though some disk maintenance utilts can help on a das drobo, like checkdisk for windows, and if you have diskwarrior, that has been known to fix a lot of issues on macs, that even the mac utils like diskutility have not been able to fix, and might help you too?

anyone see a resolution yet? Same thing has been happening to my Gen 2. Computer was not asleep - Drobo just randomly ejected itself. And then a few minutes later, it was reconnected. However, Photos had closed since it lost access to my photo library on Drobo. I’ve had my photo library get corrupted and after several tries was able to use disk first aid on drobo and get my library back. Runs fine for a while. but still seeing these disk ejects.

P.S. drobo dashboard is latest and was on at the time. all drives were green and indication that anything is wrong.

hi dougie, if you get a chance, could you try using another cable, just in case it was the cable
(or if you were using firewire, could you try with usb directly from computer to the drobo, just in case it is a loose port connector?)

do you still get the same problems after that?
(its good that you run a disk maintenance on it though, and i usually run a check disk on windows if something disconnects or a program crashes etc)

Since yesterday, I all of a sudden have exactly the same problem.

Any really helpful tip yet?

Drobo is attached via usb and worked without any problems up until now (it’s just a few months old!)

regards