Drobo Problem - Swap in new drive, no protection, new failure

I’ve encountered a problem I haven’t seen before and would appreciate advice.

I had a healthy Drobo S with 5 drives (4-3-3-3-3 TB). Total used capacity was climbing over 70% so I decided to swap a larger drive in. I replaced the 3TB drive in bay 5 with a 6TB WD Red drive (I have used those successfully in another Drobo).

I expected the 5 flashing LEDS saying that a data protection rebuild was in progress, but that didn’t happen. Instead, the LED for bay 2 went red. The new drive in Bay 5 has a green light, and dashboard shows its true size, so it is recognized, but no rebuild happened.

Instead the dashboard has the message, ‘Drobo cannot protect your data until you provide at least two hard drives for single or 3 for dual protection…’

So I’m not sure what to do. I don’t know why the new drive isn’t going through a rebuild, or why a drive that was fine just before replacing a DIFFERENT drive should suddenly fail, and why the message says there aren’t enough drives – even if drive 2 really is bad (which I question), there are still four healthy drives in the unit.

I ran CHKDSK /x a few times… nothing found.

I’m hesitant to replace the drive in Bay 2 because I don’t think the new drive has been allocated any data… that would leave me temporarily with two empty drives, and if something like this happens AGAIN (a new drive fails) I will lose everything.

Has anyone experienced this before? I’ve searched the knowledgebase for days and not encountered this. I wish the dashboard would show if individual drives actually have data on them. Oh, that’s another thing, the drives are now 4-3-3-3-6 (with bay 2 showing red) but Dashboard says total capacity is around 8.1 TB which seems low to me when I compare that to the calculator.

Thanks in advance for any wisdom you may share on this. I’m currently trying to move data off the drive but its like trying to save swimming pool water in all the coffee cups I can scrounge up.

hi kentkacs, i think you’ve done the best thing so far with your research and patience, rather than plowing through (especially if its late depending on your timezone).

when you mentioned a red light, can i check if that 2nd bay light is actually flashing red (which would signify a failure) or is it just showing a solid (always on) red light?

can i also check if you have Single SDR redundancy or dual DDR currently, and also how much data you actually are using on the drobo (as well as how many blue leds are shown?)

also does dashboard show you any additional information about the drive bay drives you mentioned (such as in a drop down tab or if you click on a drive slot in dashboard?)

Thank you for your quick reply! Yes I should have provided those additional details.

None of the five bay LEDs are blinking – four are solid green, bay 2’s is solid red.

This unit is set up for dual disk redundancy.

I’m not seeing much else… clicking on the bays in Dashboard isn’t doing anything. That screen shows all five drives with their correct sizes, again with #2 in red. The message I quoted earlier continues, "Replace the hard disk indicated by the red light with a larger capacity drive…’

The capacity screen is all in red, 2.37 TB free (29%), 5.75TB used (71%).

Firmware is 2.1.5[5.41.62910].

I’ve rebooted, shut it down completely, etc. several times but no change. I feel as if it would only make use of the new 6TB drive and do a rebuild, something might “happen” but I don’t see any way of kicking that off. It’s usually automatic, of course.[hr]
Oh, and seven blue LEDs are showing at the bottom. The flashing green “activity” LED to the right of them is the only light that is not solid.

The Drobo was shutdown when I swapped out the drive. When I restarted, it went through its normal startup sequence, but the 5-light “rebuilding” flashing never happened. It went right to its current, static state.

thanks for the info kentkacs,
i think it could have got confused due to your drive swaps being carried out while power was off…

for example, the usual process of upgrading/swapping drives is a hot swap process, whereby the drobo is running in a stable state (such as with solid lights ideally green), and then a drive is taken out, and shortly after recognised by dashboard, and then the replacement drive is put in still while power is on, and then shortly after recognised by dashbaord. (though in some cases it can take hours for the new drive to be recognised, as per here) https://myproducts.drobo.com/article/AA-00909

i think there are a few ways forward…

  • the safest, would be to continue making backups of your data as you currently might still be doing, (and hopefully that you have enough space elsewhere to accomodate that) which is important, especially for any critical data if you do not have any backups at the moment.

  • then, with verified backups of your data, you could try to use dashboard to shutdown the drobo as before,
    and to unplug the connection cable and power cables from the drobo
    and to try reversing the swaps you made (eg to replaced the current 6TB drive in bay 5 with the original 3TB drive that was there before) assuming that the original 3TB is still unchanged from when you removed it.

  • to then plug in power and power up the drobo
    (it should boot up with the blue capacity led sequence and ultimately show the blue leds from 1 through to 10, and then go into standby mode)

  • to then reconnect the usb cable to the drobo
    (does your drobo wake up and shortly afterwards, become recognised by dashboard, and does it end up in a stable state with green solid lights and about 70% + such as how things were before you tried swapping the drives?)

if so, to keep the power on, and to remove the 3TB drive from bay 5, and to let dashboard and the drobo recognise this and become stable again, and then to put the 6TB into the empty bay 5 and to let dashboard and drobo recognise this and to become stable again (at this point it should hopefully then start a rebuild process, which may take about 6 days depending on how much data you have and how much accessing take place during the rebuild.

thats the theory but please let us know how things go :slight_smile:

Wow, this is a bit of a revelation for me. While I knew that that Drobos could hot swap, I didn’t understand that they SHOULD hot swap. I always power them down, thinking that’s safer, and that’s usually when I encounter problems. Wow.

I will continue to make backups… a few days of that ahead of me I’m afraid… also I’ve already repurposed the drive that I took out to use it ironically to copy some files onto from the ailing Drobo.

Also, you’re saying (I think) that after a drive is removed, don’t immediately install a new one… let it settle down a bit? Again something I didn’t understand, thanks!

I’ll continue making backups… then get up the courage to delete some data from the unit to clear more space. I don’t know what else to do since the original drive is already overwritten.

UPDATE: five and a half days after I first inserted the new drive and all this started, all five drive LEDs started flashing and Dashboard reported that a data protection rebuild was [finally] in progress. The next morning, all five drive bay lights were green and stable. So it gave the appearance that the problem had straightened itself out and all was well.

However… there is no added capacity to the volume! It’s exactly the same as it was before I doubled the size of one of the drives. Dashboard correctly shows the drives as 4-3-3-3-6 (19 TB of raw capacity) but the usable capacity (with dual redundancy) is still 8.1 TB, exactly what it was before I started. The Max volume size is 16 TB. Is that the max RAW capacity, not the logically available capacity?

UPDATE CONTINUES: Although strangely, even though I had written down that my starting capacity was “8.1,” and the used portion was climbing over 70% which is still what it’s showing after doubling one of the drives, using the Drobo capacity calculator, 8.17 is what I should be getting from my present configuration. Hmm. I can’t explain that. But I guess I need to swap out more drives.

hi kentkacs, thanks for the updates,

if you have already repurposed that drive, putting it back in would not really help but yes, its good that youve been carrying on with the backups and a rebuild took place with all looking well again.

here is some more info about how your drives (and sizing) works:

  • single SDR protection usually takes up an amount of capacity which is equal to the size of your largest drive.
  • dual DDR protection usually takes up an amount of capacity which is equal to the size of your 2 largest drives.

in your case, if you have these drives currently inside your drobo:
4TB+3TB+3TB+3TB+6TB = total raw capacity =19TB
-6TB - 4TB (for DDR) = total usable by drobo = 9TB
9TB (*0.9 for filesystem overhead) = approx 8TB available for data

a good feature of the drobo is the ability of being able to use different drives of different sizes, though when using drive redundancy, its usually more efficient to use more (large) drives of the same size.

for example, assuming your drobo was in a stable state (and no flashing lights or rebuilds in progress), then if you were to hot-swap your 4TB drive, with a blank new 6TB drive, that new 6TB would essentially end up being the 2nd of the 2 largest drives, and you would not gain any more usable space yet. (eg, you would have 6+3+3+3+6) =21 - 6 - 6 = 9TB*0.9=8TB usable)

That’s good information, thanks!