Drobo

Drobo Pro/XServe/Firewire 800 problem

I hate to cross-post, but:
http://discussions.apple.com/thread.jspa?threadID=2405471

I have a 2x Dual-Core Xeon XServe, running OS X Server 10.6.3, and a DroboPro. I was able to succesfully connect the Drobo with FW800, but data transfers turned up FireWire errors. They show up on Console, but don’t pop up as drive errors. The errors trace to the method
IOFireWireSBP2ORB:prepareFastStartPacket
in
IOFireWireSBP2ORB.cpp
(the error mesage is “fast packet start length < orblength)”)

Unfortunately, after having spoken with both Apple Enterprise Support and Drobo support, no one has given me a solution. Apple indicated that the problem is known, however; unfortunately, they have no front-facing information. Drobo didn’t know about the problem. Apple stated that the problem may have to do with memory (my XServe has 32GB). I was not able to reproduce the error on a MacBook Pro, but it had much less RAM.

Anyone else having this problem? The best IO I can do right now is iSCSI, which is not as fast (in theory it should be, but that’s ignoring overhead). iSCSI is only marginally faster than USB.

iSCSI is far faster than USB or Firewire 800. If you have a known FireWire800 issue and Apple is not really working to fix it then you should focus on tuning your iSCSI performance.

iSCSI on a pro should see around 70 mb/s read/write.

Using XBench, I’m getting 60.21 MB/sec write, and 67.64 MB/sec, read, but only for 256K sequential blocks (which is, fortunately, a large part of what I do - read large contiguous sectors).

I’m getting about the same performance off of a single SATA drive connected via FW800.

My “real” RAID produces speeds well in excess of double these.

I don’t expect fibre performance; it’s just that with overhead, I’m pretty sure that FW800 would be faster. Are there general performance numbers available?

FW should be up to 50 mb/s read/write.

FW400 or FW8000?

800

Hi all. I am posting to the original topic in the thread, error messages in the console on our Xserve. Here is a complete log entry.

11/10/10 12:36:30 PM kernel IOFireWireSBP2ORB<0x158a5300>::prepareFastStartPacket - fast start packet not full, yet pte doesn’t fit

We use DroboPro as one of our backup destinations for CrashPlan Pro so the errors correspond to CPP writing to the device. Any thoughts about how to get this issue to resolve? We are concerned about data corruption in our backups.

I have; swapped cables, switched ports reformatting isn’t really an option as I don’t want users to loose their history…

Thanks!

We never resolved the issue. We switched to iSCSI, as noted on the earlier post. We only had speed issues with larger transfer (10GB+).

I have the same problem.

I have reformatted and rebuilt my DroboPro from the ground up. This worked for a while, but now it seems that we are back to square one. Does anyone have any suggestions??

I have the same errors on my Mac Pro when I tried connecting my Drobo Pro via FW800.

It completely filled the log files with this junk.

I sold my drobo, it just wasn’t working for a office environment

I found out that per a DROBO tech note that first gen Mac Intel hardware have a Firewire 800 limitation.

What is very odd about this claim is I have never had these errors using ANY OTHER firewire 800 peripheral.

I ended up giving up on FW800 and DROBO and just added an eSATA card to hook my DROBO S up to.