Drobo Pro Lit up Light Christmas Tree

I have an issue where my Drobo Pro powers up, the fans ramp up and all the lights on the front light up, but it does not boot at all. I had it plugged into a UPS and we recently had a power outage. The Drobo was 70% with a mix of 3tb and 2 tb drives. I took all teh drives out and tried to power it up, still no good. Am i thinking that the drobo is toast and i will have to replace it. I believe the data on the drives is still there. Its urgent i get the data off. have almost 900 movies, tv shows and pictures on there. Any help would be appreciated.

hi greg,
you might be right if the drobo is not found by dashboard anymore (even when empty), and maybe a power spike damaged it. if the drives and disk pack is ok though, you might be able to follow the migration process to migrate your disk pack drives to another unit (while power is all off etc), for example as shown here:

you might need to source one yourself though as am not sure if you can buy any more new drobopros from the droboshop, but the migration might work for you.

(when i had a problem with my drobo-s-gen2 power toggle switch, i was able to follow the migration process and all my drives worked fine in the new unit)