Drobo

Drobo Pro - all the drive lights suddenly solid red

on boot up the usual all drive lights are orange then off as the blue lights indicate boot up progress…

  • suddenly all the drive lights turn solid red and the Drobo Pro fitted with 8 x 2TBb WD Green drives goes into standby mode and will not mount and cannot be ‘seen’ by the Drobo dashboard…
  • it appears as if all the drives have been removed, but they are still all in place
  • was originally iscsi direct connection, but tried USB and firewire, still same issue…
  • operating system is Mac 10.6.8
    any ideas what to do next or first would be appreciated…

hi f42,
can you remember anything more about what happened just before the issue when things were still working last, or if any events took place (such as power cuts or something?)

one thing you could try initially could be a test to see whether the main unit is still ok, such as this:

  • to power off the computer, and then the drobo once in standby mode (you might need to unplug the connection cable from drobo and wait a bit for it to go into standby mode, but might also need to power it off if it froze)
  • to remove all cables and power from drobo
  • to remove each drive, remembering the order for later (these make up your disk pack)
  • to then power up the empty drobo on its own
    (does it boot up and then go into standby mode?)

even if not:

  • to then power up the computer, and once that is running, to launch dashboard service and programs
  • to then connect the computer cable to the drobo (starting with your usual method, but all steps might need repeating with different connection slots, and/or different connection methods such as a usb cable)
    (does the drobo wake up shortly after that, and then does dashboard recognise it?)

if yes, then the main unit seems to be ok, and:

  • you can then safely shut down the drobo via dashboard
  • and then power off the computer, and then the drobo
  • to then unpug all cables from drobo
  • to then put yoru drives back into where they were before
  • and to power up the drobo without any connection cable
    (does it now boot up with blue led sequence and then go into standby mode? or do you hve the same issue)

either way, to then power up the computer and dashboard as before,
and to then connect the computer cable into drobo
(does it now wake up and ultimately become recognised by drobo?)

Important:
disk packs should only be removed when power is all OFF
disk packs should only be put back in, when power is all OFF

Paul, thank you for your asistance…

  • with the power off and the connection to the Mac, I removed all the drives and numbered them to maintain the sequence for their re-inserion…
  • then connected the power cable to the Drobo Pro and used the rear toggle switch to start up the Drobo Pro, which went through it’s sequence then went into standby mode, but drive number 1 (on the left) had a solid red light, all the remaining slots 2-8 were not lit at all…
  • Started up the Drobo Dashboard, which could not find any Drobos - then a message appeared on the Drobo Dashboard panel:
    X: “a required portion of Drobo Dashboard is no longer running. Please relaunch or re-install…”
    I tried relaunching several times, same message after a few minutes, so I then downloaded the dashboard again from the Drobo web site and re-installed, re-booted Mac, same thing - X: "a required portion etc…
  • used USB and iscsi connections - same error message.
    Using the rear toggle switch I then shut down the Drobo Pro.
    Next step I tried was re-inserting all the eight drives back into the Drobo Pro in the correct numbered sequence and started the Drobo Pro using the rear toggle switch, this time when it started, after the usual start-up sequence all the Drive lights came on red as before, except that now drives 1 and 3 were flashing red, whereas before they were solid red.
  • was at this point I realised I had not tried connecting via Firewire
  • so then using the rear the rear toggle switch to shut the Drobo Pro down, connected via firewire and started up the Drobo Pro, same result drives 1 and 3 flashing red, the remainer were solid red, but a message appeared on the Mac screen “a disc inserted was not readable” - so this time the Drobo Pro was noticed by the Mac - briefly…
  • any ideas where to go from here would be much appreciated…

thanks for the info f42,

the part about booting up empty with a 1 red light should be ok, though i was wondering about the “required portion of dashboard no longer running”, as maybe tackling that first could be good…

i say this because as far as i know, an empty working drobo should be found by dashboard (as long as nothing is causing dashboard problems etc)

this article mentions some firewall changes likely in mac v10.7, but might be worth a look in case anything similar applies for you, and you might be able to check the same ones to help dashboard to be given the right permissions to run properly:
https://myproducts.drobo.com/article/AA-01816
(usually on windows, we need to restart the service or allow it to communicate with the drobo if we get that message, so maybe for you a tweak of those settings can help it to find the drobo?)

the recent message you mentioned about “a disc inserted was not readable” sounds similar to this one, and if so its probably best to just click ignore on that as per here:
https://myproducts.drobo.com/article/AA-01189

For the drives (1 & 3) which were flashing red, that might possibly indicate problems with those drives, but am not yet sure if the usual process (of replacing a flashing red drive with another one if it happens during normal operation) applies here, since it is not operating normally at this time.

if you are able to try the same kind of tests as you recently did before, but hopefully with dashboard being able to communicate with your empty drobo, does it now find it?

if it does, then that is a good sign at least from a hardware perspective, and you could try putting the drobo into ReadOnly mode, which may have a chance of stabalising its boot up, to let you access the current data on it, as mentioned in this post:
http://www.drobospace.com/forums/showthread.php?tid=143618
(usually it is for reboot/loops, where it has worked successfully, but it might work for you, and i think is a good next step before moving onto raising a ticket, or drive work)

btw you might not be using it though there is also a knowledgbase article here with lots of info about iscsi too in case useful:
https://myproducts.drobo.com/article/AA-01201[hr]
can i also check if you can remember if your drobo was using Single drive redunancy (SDR) or dual (ddr)?

The Drobo Dashboard issue ( “a required portion of Drobo Dashboard is no longer running. Please relaunch or re-install…”) appears to be related to the latest Dashboard version… 2.6.9… Restoring to version 2.5.2 cured the “no longer running” issue…
Must be a software problem with Dashboard version 2.6.9 running under OSX 10.6.8…

  • With Dashboard 2.5.2 the Drobo Pro is “seen” with no drives. Removing the Pack of 7 drives when powered down and a single new 4TB drive inserted, this was formatted and mounts correctly, so no issue with the Drobo Pro Box… Good News…
    Powering down and re-inserting the original 7 drive pack drives 2-8, as Drive 1 had failed and been removed) and booting up again all the lights are red except drive 3 is flashing red.
  • my suspicions are that after drive number 1 failed and was removed, the Drobo Pro was rebuilding the remaining drives 2-8, when drive number three failed. Hence all the lights are red except drive three which is flashing red.
  • My question is now, dare I put the formatted drive into drive slot number 1 with the “Pack” in drives 2-8, will this cause the “Pack” to loose data… Clearly there is an issue with drive number 3, but not sure where to go from here…
  • All the hard disc drives are Western Digital green 2TB, which were recommended by my supplier, Transparent Communications, when I purchased the Drobo Pro, have been failing on a regular basis, although some have been refurbished by WD, now they are out of warrenty. The new drive I placed into drive position 1 to check the Drobo Pro, is a new WD Blue 4Tbm, hope this lasts longer…

hi its good that you were able to get dashboard to work properly again,
and also that the drobo pro is recognised by dashboard when empty.

(these are good news in itself, though sometimes it can arguably be better to find a non-working main unit)

for the drive which failed, (slightly off topic) but mine was also a refurbished/recertified drive as per here: http://www.drobospace.com/forums/showthread.php?tid=144519

before putting any drives in or out, can i check what does dashboard show you (and what does the computer show you or let you see) with your current status of 7 drives in, and a drive flashing red?
are you still getting a message from the mac saying “a disc inserted was not readable”?

Here is my issue and any input would be appreciated. I am not as well versed as you all in providing an accurate articulation of everything but I will try.

  1. Original 5N. 5 drives (various sizes, the largest being 6 TB) all working properly. Went a very long time with no issues.
  2. Come down one day to find all the lights yellow then flicker back to green – accessing drive for a period of time (it is a RAID 0 configuration as I am told) then no access at all.
  3. Then all red, then nothing.
    I load the drives now and the top one shows red and the others show no light at all.
    I bought what I believe is a functional 5N2 (used) empty (thinking something is up with the Drobo itself) and updated dashboard and firmware on Drobo 5N2.
    Powered off it off. Loaded my drives into 5N2 and they mounted but all lights show as red, bay 0 is high lighted as critical, clicking on each individual drive, however, shows each as good (green).
    I just want my data and to be done with this. Sending the drives to a data recover place is not fiscally feasible for me.
    Any thoughts?