Drobo powers itself off after a few minutes of operation

My Drobo 5D was running fine since I bought it about a month ago. I updated the firmware from 3.0.10 to 3.1.1 and it ran fine for a few days. Now, after a few minutes of operation it powers itself off with no lights on the front and a blinking green light on the power switch. It will restart only after leaving the power unplugged for a few minutes, and then it will run for a few minutes and then it powers itself off again.

This does NOT seem to be the same “reboot loop” issue that is described here:

During the few minutes before unit shuts itself off, the drive mounts and all of my data appears to be available.

Support is telling me that the cause is a firmware issue that has “infected” the drive-set. They also indicated that there are metadata differences between 3.0.10 and 3.1.1 and it is not possible to roll back the firmware version.

My primary concern at this point is whether the drive-set can be “fixed,” or will I be restoring from backup.

If anyone in the community has anything to share concerning this issue while I continue to work with Drobo Support, I would appreciate it.

I just started having the exact same problem. Same deal, updated to the latest firmware and all the same problems started happening.

Have they gave you a solution for this problem?

Shall I also open a ticket with them?

I’m having a similar problem on my Drobo 5D with a Mac Mini Server. It will work fine for awhile and then just shut off and unmount (message on my mac). It’s only started recently which is the strange thing and very annoying. I’ve got the latest dashboard running and the firmware 3.1.1 as well.

Data appears to be fine when its online but then it shuts down. I’m using a Thunderbolt cable to the server but was going to try a USB 3.0 cable to see if that makes a difference.

Just to update you on how things are with me, I have actually tried 4 different power supplies and all of them work with no issues, so I can safely tell you that this is not a power related issue.

I can also confirm that all my data is safe and I started the process of getting the data out, but with 14TB stored, it’s going to take a while, specially with the fact that I can only transfer around 120 GB per session, until the Drobo shuts off, but the thing is that if I shut it down from the dashboard, I can immediately transfer another 120GB. So what I have been doing for the last three days is transfer 120GB, shut off the Drobo (from the dashboard) and transfer another 120GB and so on. It has taken forever, but I have not had a shutdown if I do this. If I get busy or forget, the drobo disconnects and shuts down.

As I unplug it from power, all the lights in front stay on (see attached photo) the hard drive light turn orange and stay like that and the back green button blinks like crazy, until I manually shut it off with the power button on the back and reconnect the drobo to power, then I start this dance all over again. Thunderbolt pass-thru never stops working by the way.

Based on all of this and all the testing I have done these last couple of days, I can safely say that this is not a hardware issue, but a firmware one. All this started happening as soon as I updated to the latest firmware and dashboard and I have manage to find several people who are having these same problems and they all started after the most recent firmware upgrade.

As soon as I get all the data off, I will reset the drobo, reformat the disk pack and do some testing. If it continues, I will downgrade the firmware and do some more testing.

Any thoughts and/or suggestions?

Hi Picho -

At this point I think it would be beneficial to log a support case with us and we can review the logs to start off.

Here is the link to create a case: https://myproducts.drobo.com/signup
Let us know how it works out and let me know if you have any further questions.

Picho, I’ve got a case logged with Drobo and tried the process they recommended to me which was flush all the slots/drives and re-apply the firmware manually to see if this helped. It did work for approx 2 hours but then the drive shutdown automatically again, so this fix didn’t work. Waiting for a response from the Support but I recommend you logging a call too so they know it’s happening to more people.

Love my Drobo but this is a little annoying and having 9TB that cannot access all the time.

same issue hier!

sorry for my bad english, it is not my native language. my drobo 5d is connected via thunderbolt to my imac. at first everything was fine, i made a few copy-sessions from other devices to my drobo. then, during a copy-session, the drobo powers itself off, and immediately restart self, that happens 5 or 6 times in a few hours! so, i try to connect my drobo via usb 3.0 to my imac. but the same fu**ing game. one difference, connected via thunderbolt, the drobo restarts always self. but connected via usb 3.0, the drobo shuts off, and remain powerless. even you push the start-button on the back, nothing happens. only when you disconnect the power supply for a while from the mains voltage, the drobo starts up after you push the start-button! that happens 3 times via usb 3.0 !

the data integrity is likely not in question. but so, the hole device is near useless.
imac late 2012, macosc 10.9.4, drobo 5d, msata accelerator 128 gb, wd-red drives, dashboard 2.6.2, firmware 3.1.1

please drobo, this is a very serious issue, help us.
greetings from switzerland

Another user with exactly the same problem. Extremely frustrating. Hopefully this gets fixed soon. If anyone finds a solution - please post to this thread.

I am also having this exact problem as described here.

I have my one month old Drobo 5D that has been doing this thing, powering itself off after a few minutes.
Today I bought a brand new Drobo 5D, so new power supply, new cords, etc.
Unfortunately I updated the firmware before I read this thread, so it has the newest 3.1.1 also. I moved my stack of disks into the new 5D, and it is doing exactly the same thing.
I tried both Drobo 5Ds on two different computers (Macbook Pro and an iMac).
I tried both Thunderbolt (two different cables, one of them also purchased brand new) and a brand new USB 3.0 cable (from today’s new 5D) and a USB 2.0 cable.
All have exactly the same results.

Start up the Drobo 5D.
Runs fine, and all data appears to be fine. Start working, and then a few minutes later the Drobo 5D just shuts off.
Trying to restart it, this is no response. No lights, no movement, nothing. Unplug for a while, then replug and restart, and everything starts fine, except that during the early part of the Drobo boot, the green lights on the right side do not come on. The drive is working, but the right side HD lights are dark.
When I try the Tools>Blink Lights command, they blink normally. Then when you end that command, they go off.
Eventually, when it appears that the Drobo has gone through some kind of long process (the bottom right little light has been blinking to the rhythm like data reads/writes) then the green HD lights come on.
Then after a few minutes, it shuts off again.

I am working on several deadlines, its my busy season, and this is killing me.


To recap, my Drobo 5Ds (both the one month old one and the brand new one with the same data disks) would run and be recognized by the Drobo Dashboard if there were no disks in it, but when I put my five disks back in, it would act like before, going to sleep in a minute or two.
Then I did this:
With the 5D running with no disk in it, looking at it in Drobo Dashboard, I pushed my five disks in slowly, one at a time (counting three seconds in between). This feels very risky, but this time the Drobo started seeing them one at a time, gave me the notice “Too many drives have been removed. Put back the drive”.
Then it changed from all five red, to started green and yellow blinking. This for two or three minutes. Meanwhile I am madly (and successfully) copying off my urgent data to my local HD. Then it switched to top four green, bottom one red (but there was a drive in it), then finally switched back to all five flashing green and yellow, and gave me the notification “Drobo data protection is progress, please do not remove any drives”.
Its been running now for over an hour, still green and yellow flashing, still able to access my data.
I think that putting the partial set of disks in forced the Drobo into data protection mode, and it is rewriting whatever was amiss.
So far, so good. If someone else tries this, please let us know if it works for you. (Your mileage may vary.)


After inserting each disk slowly one by one and apparently forcing the 5D into recovery mode, it ran with green and yellow blinking lights for almost two days. In Drobo Dashboard, under “Status”, there was a progress bar that indicated 54 hours.

At one point after about one day, it unceremoniously restarted itself, causing the Mac notification “Drobo was removed improperly” (I can’t remember the exact phrasing). But it restarted and remounted on its own without me touching it, and then went back into green and yellow blinking lights recovery mode for another day.

And now this morning, after a total of two days, the Drobo 5D has stabilized and shows all green, Good health, and is staying running stably.

Bill Moree

This is using firmware 3.1.1.
Someone mentioned downgrading the firmware back to an earlier version. Before this solution, I had tried downgrading to 3.0.10, but the Drobo would not let me proceed, saying that the disks were using a newer version, and that I should update the Drobo firmware.

Having only purchased my 5D DAS in the last three/four months based on the high reviews it gets, I was fortunate to start from scratch. 4 WD Red 3TB drives. Installed onto a Mac with USB3 and Time Machine (no Thunderbolt cable in the pack Drobo (?) ) it has run 3.1.1 since almost without missing a beat.
I say almost - there are times when it pawers down overnight and I get an error message in the morning saying backup failed - however, if I unmount the DAS and reboot it runs normally - for about a month. Ironically, it’s done so this morning, which is kind of why I’m here - not alarmed, just curious to see if others are experiencing similar issues…

I’m currently having this exact issue on my brand new Drobo mini that I just bought today and updated to 3.1.1. Worked fine for a couple hours, now it will shut itself off completely during data transfers after only a few minutes. Unusable. I’ve submitted a ticket and expect to hear back early tomorrow.

I’m having the same exact problem. Just opened a ticket with support. I hope they find a solution soon. My setup is:

Drobo 5D
5 - HGST Ultrastar 3.5-Inch 4TB
1 - Samsung 840 EVO mSATA 120Gb
Thunderbolt connection

I use it mainly on a MacMini but also on 2 different MacBook Pros every once in a while.
It seems like the time it actually stays connected and useable is decreasing with time.

Drobo Firmware 3.1.1
Drobo Dashboard 2.6.3

I wanted to leave a feedback of my support experience here so other users can decide their course of action.

I’ve been in contact with the Drobo support for a few days sending them a few diagnostic reports and in the end they sent me what I assume is a test firmware version. After the installation my Drobo has been running stable for a week or so. So probably these fixes will be in an upcoming firmware release. So I encourage users with this problem to get in touch with Drobo support and open a ticket to get your situation sorted out.

Getting similar issues as others here are my diags sent to drobo on support ticket I’m very surprised that i have seem to have resolved issue with swapping the drives with an other 5D using thunderbolt connector.

Done following diags

Have 2 way swapped psu stays with this unit.(S/N of swap unit).

Hard reset of unit with drives out same.

With 4 drives in stays up and connects to dashboard add number 5 and unit powers down.

Manually re-flashed firmware.

Have 2 way swapped hd with an other drobo unit issue is resolving with this unit running with no issue and other unit (S/N ) this unit is rebuilding the array with data accessible. I was not expecting this to work. Going to leave running overnight to see what happens.

Any advice or insight you can give both units are running the latest firmware. This unit was running WD RED 3TB WD30EFX-68A drives other unit was running Seagate 4TB ST400VN000-1H4 which are now swapped. (now two way swapped) both with mssd drives Known Good plexor 256GB this unit crucial 256GB

I’m now back where I started with this DOA unit that throws a tantrum and away to start trying to getting diagnostic reports :frowning: with no access to data at all. I’m not a happy bunny would be even less so if i was using this pro level kit as part of a business.


I have the exact same issue hier! My ticket by support is created on 11/22/2014.

The people of drobo support are really on the case … but they need time!

I receive from Drobo Support 2 custom firmware’s but without any success and 3 days ago…

“Technical Support has determined that we need to replace your unit.”

I’m now back where I started with this DOA unit to start trying to getting diagnostic reports.

With no access to data at all. I’m not a very happy for the moment!

My primary concern at this point is whether the drive-set can be “fixed,” or will I be restoring from backup. If anyone in the community has anything to share concerning this issue while I continue to work with Drobo Support, I would appreciate it.

I use almost 5 years Drobo’s without any problem. I have 4 pieces without any significant problem on the office and home.

But this … is killing my and my business! Extremely frustrating. Hopefully this gets fixed soon.

Drobo Firmware 3.1.1s (7.254.69660)
Drobo Dashboard 2.6.3

Ps. Sorry for my bad english, it is not my native language!

What is the resolution of all these self-power-off problems? Are all of you just giving up on Drobo or are you figuring out how to solve the problem? I’m having the same issue a good ten times now on my new Mac-driven 5D with the power suddenly shutting off about 100GB into a file upload. The lights go out but the fan continues to run. I’ve manually reflashed, done soft and pinhole resets, disabled spin down, tried different connection arrangements, etc. I will try to see if it’s one of the drives that is bad…I’ve already pulled out the M500 240GB mSATA (which wasn’t really speeding things up that much btw). Running the latest versions of everything in a 60-65°F room with no obstruction of the unit’s airflow.

I will send this thing back if I can’t get it stable. It isn’t as fast as I hoped, but I was hoping that it would get faster as it self-optimized somehow. Plenty of people warn against anything Drobo and since this is such a frequent complaint with no clear resolution I’m seeing why.

Update: so far, it appears it may be a bad drive that is tripping up my Drobo 5D and making it shut off. Replacing the drives seems to have addressed the problem. So far…

Anyway consider seeing if you have a bad drive if you have this problem. The firmware should be updated to deal with whatever a bad drive trips up and causes the shutdown. It sounds like an unhanded exception…

I’m having the exact same problem, I have 5 drives in my Drobo 5D. I took out the one at the bottom and it runs fine now. That drive was vibrating more than the rest of the hard drives.

Dear Drobo, please fix this issue…

been going back and forth with Drobo tech support for a few weeks and it is going no where.