Drobo OSX Spotlight Indexing and Preview problems

Dear Drobopeople,

I’m having trouble with a 2nd gen Drobo connected via Firewire to a MacPro running OSX 10.6. I searched drobo and apple sites, tried many things but haven’t found a solution :frowning: Hope someone here can help.

Problem1: Spotlight is trying to index the Drobo but hangs on this, stating it will take 3/4 hours but stays like this for days with no progress.

I tried rebooting, reconnecting, leaving Drobo out of the Spotlight indexed drives and adding it again, removing the V00 spotlight index database on the Drobo, etc. I updated the firmware, the latest version of Drobo Dashboard, Nothing helps.

Problem2: Files on the Drobo can’t be previewed with QuickLook (hitting space bar while selecting a file). On other disks this is no problem but as soon as a file is copied to the drobo the preview disappears. My guess is this maybe has something to do with the fact that the Drobo hasn’t been fully indexed yet, but I can’t get a confirmation on this.

I hope someone can help or point me in the right direction. Thanx in advance!

Indexing tends to bash a bunch of little files - since Drobo is not the quickest on “many little files” access likely this can take a while.

But the first thing I’d try is connecting via USB to see if the behavior is different. Firewire can sometimes be problematic.

thanx for the reply bhiga. Actually my experience with Drobo’s via USB isn’t that great, but I’ll have a try!

hi spscheele, if you have an actual usb cable which came with the drobo, try using that instead of any other.
it might work better for you.
(also the usb ports on a machine arent always the say - at least on windows ones, so you might get better speeds when using another usb port)

I think the problem lies more on a system level. I’m a little concerned at the moment.

If I copy a .JPG file which I can quicklook and open in preview to the Drobo, it loses this function instantly. There are also a lot of files (photos) on the Drobo that seem corrupted in some sort of way. They won’t open with quicklook, won’t or only show up half in preview, but in Photoshop they look fine.

Is there a way to do a full file corruption check or something on a Drobo?

Is this the same Drobo we’re discussing in http://www.drobospace.com/forums/showthread.php?tid=12902?

[quote=“spscheele, post:19, topic:12154”]
I’ve received some very good help from Drobo tier3 support already. They advised me to run a deep scan with Data Resque 3, which has been scanning for 4 days straight now and is only at 12%[/quote]

Nope it’s another Drobo :slight_smile: But I come to think this is actually more of a problem of the Mac it is connected to, than of the Drobo itself. I tried connecting it to another Mac and it could index it without any problem and also showed previews of all files instantly. Very weird, but I was relieved to find that the data seemed ok.

i dont have a mac to know for sure, but on windows there is a “refresh thumbnails” option which does something similar.
maybe there a way on the mac to clear out, or flush it’s index. maybe a rebuild index or spotlight database?

I guess it would depend where the index data is stored. In Windows thumbs.db is stored in the folder of the files. Not sure if it’s the same or can be changed in Mac OS.

Spotlight indexes are stored on a volume by volume basis, and live at the root of a volume. To reset the spotlight index, try the following:

sudo mdutil -i off /Volumes/YOURDROBO sudo mdutil -E /Volumes/YOURDROBO sudo rm -rf /Volumes/YOURDROBO/.Spotlight-V100/ sudo mdutil -i on /Volumes/YOURDROBO

That will turn off indexing, delete whatever index exists (in case it’s corrupt), and then rebuild the index. Rebuilding will take time! Be patient. :slight_smile:

As for Quicklook, that is odd as it doesn’t have any particular dependencies to my knowledge. It wouldn’t completely surprise me if Spotlight is involved in some fashion though, as its tendrils are part of a lot of unexpected things (Time Machine, for instance).

So here’s an interesting update on this problem;

When hooked up to another Mac the Drobo worked perfectly with Quick Look en was indexed by Spotlight as it should. So my thinking was the problem must have been OSX related. As I had tried every possible reset and rebuild of indexes, spotlight and quicklook preferences (Thanks for the tip @diamondsw, I had done that already) on the Drobo’s parent Mac (Pro), I tried clean installing OSX (Snow Leopard) to count things out. To my surprise the problem still existed after connecting the Drobo again. No quicklook function, file corruption error messages and crazy spotlight indexing. Then I tried connecting the Drobo via USB and gues what, everything back to normal again!

My conclusion now is that either the Drobo or the Mac has a half broken Firewire port. I haven’t tested this furter because it works now, but I’m still puzzled about how this buggy response could be caused by a firewire connection. I also tried different firwire cables by the way, that wasn’t the problem.

Anyways, thanks for all the replies and hope to hear your thoughts on this.

Open a Support Ticket. You don’t mention which MacPro you have but there is a FW problem on certain models of MacPro that can be fixed using a different .kext

If I knew exactly which models of MacPro or the correct extension, I would just post it… :smiley:

It happens with some pre-2011 Intel macs, so if the Mac Pro’s model identifier is 5,1 or lower it could be the problem.

You can find the model ID here:
About This Mac > More Info > System Report > Hardware

If it is in that range, like mgriffin said, you should probably open a support ticket and just let them know all this.

its good you’re finding more things out - like narrowing it down to problems when on your mac/mac instance.

from what you and the other guys mention, its sounding more like some kind of firewire issue/driver issue, but when you say it was ok again when you used usb on your mac, what connection were you using when you got it working on that other mac you mentioned?

(also, if it now works fine on your own machine with usb, it might be worth simply using usb from now on? just in case something else gets affected if you try updating drivers etc?