Drobo N Apache Install

I was wondering if the apache.tgz from
needed or has been updated since the latest firmware updated. I tried installing this last night and though i could see the directories installed, i was unable to get the webpage “It works!” to appear by going to the drobo ip address.

I am not a linux administrator and really dont want to compile my own apps or even install SSH unless i really have to, but running apache with php and mysql would be useful to me.

On a side note, some way to change my user name on the forums would be nice too.

And to stick with my avatar, HAPPY! HAPPY! HAPPY! JOY! JOY! JOY!

Been a long time since i seen any ren and stimpy stuff.

You probably shouldn’t use that package right now. It conflicts with a “ghost”* app managed by the dashboard. By ghost I mean that there is an “apache” app that is installed by the Dashboard but that won’t show up on the dashboard. It listens on port 8080.

OK, least it wasn’t my lack of following directions. :slight_smile:

What would be the best way to remove that package? Re-flashing with the latest firmware?

What would be the best way in your opinion to get Apache (or some other web server) running so I can host web pages with PHP and MySQL?

Yeah, something is messed up, mySQL will install now from the Dashboard, but will not start. :frowning:

The easiest way is to login using ssh, then go to the folder /mnt/DroboFS/Shares/DroboApps/, delete the folder “apache,” and then restart the Drobo.

I got bored yesterday and just did a factory reset.

MySQL still installs from the dashboard, but still will not start :frowning: Before i did the reset, at least a red message popped up. Now it just acts like its starting, and then goes back to the dashboard showing the service stopped.

At this point i am just kinda frustrated with it.

hi tom, was that mysql specifically for the 5n?
or was it one that was released when only the fs was around?

(maybe something needs to be tweaked for the 5n)?

I am in installing MySQL from the Dashboard connected to the 5N. I would expect it to be the version for the 5N. There is not version that I can see from the Dashboard.

Apache was being installed by simply copying the file to the DroboApp share.

Did you by any chance install Perl before installing MySQL? I remember quite distinctively that MySQL requires Perl to initialize itself. After the initial setup you can uninstall Perl if you don’t need it anymore.

No, I did not install Perl. I assumed any prereqs would be in the package since it was being installed from the Dashboard.

I do not see a Perl install package for the 5N in the app repository. Is the FS package safe to install on the 5N?

It should be safe to install, yes. This seems to be a recurring problem with MySQL, so I’m kind of curious to find out exactly what is going on.

OK that got it. Installing Perl, then install MySQL worked. Was able to start the MySQL service and connect without issue.

Is there anyway to have MySQL check before installing that Perl or at least the parts it needs are installed and either error out stating such or install them with wget or some other app?

Technically speaking it should complain that Perl is missing… If I remember correctly Perl is stated as a dependency in the service.sh startup script.

Apache Link is Invalid, Please Reupload again, Thanks Brother …

I Have some trouble,with below attention from SSH

Directory /mnt/DroboFS/Shares/DroboApps/apache/conf/includes does not exist, exiting.

Droboadmin success Install
Apache2 success Install

Anybody help, Thanks