Drobo mounts but doesn't appear in Drobo Dashboard

I have a drobo 2 or 3 (can’t recall the version) that’s attached to a MacBook Pro. Both have latest OS/firmware. When I boot the mac, the drobo icon appears on the desktop. I can copy files to and from the Drobo, so the Drobo is properly attached to the mac. But when I open Drobo Dashboard, it never appears. I also have a Drobo 5N on the local network and that does comes up on the Dashboard.

I’ve rebooted the mac, have turned off the Drobo, waited, turned back on, rebooted mac. I’ve downloaded Drobo Dashboard and installed again.

Nothing seems to force the Drobo to appear on the Dashboard.

I used to have the Drobo attached to a mac mini and it would appear on the Mini’s Drobo Dashboard.

Any suggestions for getting the Drobo to show up on the Mac’s Drobo Dashboard?

hi pvonk, is it possible to know which version of dashboard you had on the mac mini, and which version you have on your macbookpro?

if the 5n shows up in dashboard, it may not be this, but if you can check this page maybe there is a firewall setting or permission that needs enabling? (for example also within step 8 here) :

btw which cable connection are you using to connect the other drobo?
(if it has a firewire and a usb port it sounds like a gen2 drobo)

The mini’s dashboard is v. 3.0.1 [89480].
Macbook Pro:
Both Macs on OS X 10.12.4

I had three attached Drobos to the mini and a 5N; the Dashboard worked as it should. I’m preparing to add a new 5N2 (next to my 5N), and I removed two of the Drobos from the mini - one is a version 1 and I’m giving that away since it’s no longer supported; the other is the Drobo in question which is now attached to the MacBook (this one was given to me by my brother-in-law years ago). The one remaining Drobo attached to the mini is, I think, a version 2. That third Drobo attached to the MacBook is younger than the version 2, so I’m guessing a version 3.

So, as I said above, NOW… the Macbook’s Dashboard doesn’t see the attached Drobo (but does see the 5N). The mini’s Dashboard sees the one attached Drobo and the 5N. (Am waiting for arrival of the 5N2.) All attached Drobos currently use USB. (yes, old technology)

I have done reboots of the MacBook and the attache Drobo a number of times in different orders and keep checking the Dashboard. But still no attached Drobo appears, only the 5N.[hr]

I’ll start again, being more careful with my nomenclature. Drobo1 is the one I removed from the system - it’s USB only and is a gen 1, I guess.

Drobo2 turns out to be just like Drobo1, (USB only) so again, it must be gen 1 (I was wrong with my guess in the other post, I thought it was newer). Firmware: 1.3.7.

Drobo3 is from my brother-in-law and has USB and Firewire. So, perhaps gen 2. Firmware: 1.4.1,

I’ve disconnected Drobo3 from the MacBook and attached to the mini. It does appear on the mini’s Dashboard. I then put it in standby, reconnected it to the MacBook and powered on. There it does not appear in the Macbook’s Dashboard. (Obviously it’s no longer in the mini’s dashboard.)

If this situation can’t be fixed, I’ll have to try attaching Drobo2 to MacBook and Drobo3 to mini. That will involve swapping higher capacity disks to Drobo2 to get it to Drobo3’s capacity. I want that with the MacBook, less so with the mini.[hr]
And in all cases, the Mac (mini and MacBook Pro) do have the attached drive(s) on the desktop, and I can access them. The problem is only with the MacBook Dashboard.


Today the new Drobo 5N2 arrived. After going through the setup process, it was online. When I opened Drobo Dashboard on the MacBook, The 5N and 5N2 appeared and almost immediately, my “Drobo3” appeared. So I now have the proper connections to the Dashboard. I have no idea why the Drobo3 (this is a Drobo gen 2) would suddenly appear just because the 5N2 is now online.

Turning off firewall helped me, now i can see the drobo in the dashboard on my iMac 27

thanks pvonk for the extra info and updated status - it could be that a new device being enumerated possibly made the computer refresh its connections (which allowed dashboard to rescan and find all attached devices), though am glad its all working again for you.

and hi daniel, am glad the firewall step helped you :slight_smile:

Yes, firewall is off for now.