Drobo mini won't boot

I recently upgraded the firmware on my Drobo mini to v3.5. After the update finished, Drobo Dashboard prompted me to restart the Drobo. After confirming the restart, the Drobo seemed to not boot correctly and would not reconnect to my laptop. All of the drive lights were solid yellow, the power light is solid yellow, the capacity gauge is completely blue and the activity light is solid green.

After initially failing to boot. I turned off the Drobo and left it powered off for a few minutes. After reconnecting the power, the result is the same. When this still didn’t work, I powered it off and removed all of drives and then reconnected the power. Still, the result was the exact same.

I’ve looked at a few other threads on this forum and it seems like this could be a potential hardware failure, but I am looking to get some more information so I can figure out how to proceed. I was considering paying for a single support ticket, however, at a cost of $50, that seems a bit steep considering I’m not certain that it will help to resolve my issue.

Thanks in advance to anyone that has any information that may help.[hr]
Here’s a photo of what the unit looks like when it’s powered on without the drives installed.

hi would you be able to try powering all off (including the computer), (and if the drobo mini is still empty), to try unplugging all cables from it and letting it remain unpowered and unconnected for about 30mins.

if you then try just attaching power to the empty drobo mini, what happens now?
(does it boot up and then after a few minutes, go into standby mode?)

if so, if you then power up the computer, and then dashboard,
and then to connect the mini via a direct usb cable (ideally, though firewire could be tested instead),
does the drobo wake up shortly afterwards, and become visible in dashboard?

(please note: if it shows a red light and asks for drives, please Stop here).

(you might already know this, though one thing to bear in mind, is that all of your drives in the drobo make up the diskpack, and that diskpacks should only ever be removed in their entirety when power is all OFF and unplugged, and diskpacks should only be put back inside in their entirety when power is all OFF and unplugged.)

If the empty drobo does become found again in dashboard, can you see if the version of the firmware matches what you tried to update it to?
If it has, then you could try using dashboard to shutdown the drobo
and then to unplug all power and connection cables from the mini
and then with power still all OFF and unplugged, to put your diskpack drives back into where they were.
and then to power on the mini (but without a computer connection cable)
(does it now boot up with blue led sequence from 1 through to 10 possibly from right to left, and then does it go into standby mode 5minutes later?) - in case it seems to hang in the middle of bootup, please do allow plenty of time / hours here.
then, if you connect it up to the computer again, does it wake up shortly afterwards and then become recognised by dashboard again, and become accessible to the computer again?

If firmware did not update:
in some cases, a firmware update could fail to take, in which case there are a coupe of things that could be tried, though if you can please try the above when you get some time, please let us know how things go so i can make this post no longer than it already currently is :slight_smile:

I left the power off with all cables unplugged all day today (until just now). When I reconnected the power cable, nothing happened. All of the lights remained off. (Is this what you mean by standby mode?) As soon as I press the power button, it goes back into the exact same state as I posted originally and as shown in the picture.

Given that I wasn’t able to get past this step, I wasn’t able to do any of the other steps you posted, but I appreciate you taking the time to type all of that! Thanks for the reminder about the disk pack. That’s what I had been doing already, but it’s good to know that’s a necessary step.

Do you have any other ideas about what I can try at this point? Sounds like maybe the firmware failed to take and there’s some way to resolve that?

ah sorry that it seemed to remain in that same problematic state after you powered it back up via the power button…

i think firstly if you are still in support, it would be worth raising a ticket with the support team - (it should still be possible if you wish, even if out of support via a pay per incident i think).

alternatively, if the drives are still out, can the empty drobo (in this current state of lights in the picture) actually be found via dashboard if connected up to the computer?

if it does, the one idea could be to try applying a manual firmware update to it to 3.5.2 via this page:

if it can not be found in dashboard, one idea “could” in theory be to try pinhole-resetting the empty drobo via the pinhole reset process, and seeing if that seems to get the empty drobo into a more normal state. (if it does, then it would be worth trying to create a fresh-new, 2nd diskpack, using a couple of blank/empty/or un-needed drives, just to check that the 2nd diskpack can be set up fine - as they have been some older reports where a pinhole reset also wiped the next diskpack put inside it) - then if it does work with the 2nd diskpack, you could try to power all down and remove all cables, and then to try putting your 1st diskpack back into where it was before, and then trying to power up with the 1st diskpack already inside and seeing if it boots up normally.

on the other hand, it may just be that something has gone wrong that can not be easily fixed by a reset or firmware reflash, and a replacement unit might be needed. (if that is the case though, it is usually better for the main empty hardware to have problems, rather than the disk pack, as working diskpack can usually be accessed again in a compatible replacement model hardware via the migration process, which can be found here:

(for example another user daniele recently successfully got her diskpack working again in this way)

Unfortunately, I am out of support. I actually tried raising a ticket with them anyway, however they just referred to the knowledge base articles and these forums.

Unfortunately, this didn’t work either. The drobo cannot be found via the dashboard. I tried using the pinhole to reset the unit, but that didn’t seem to have any effect either. I’m starting to think that there is just something wrong with the hardware, though it still seems like something failed with the firmware update considering that was the very last thing that i did before the unit got into this state. I wish there was just a better way to know what state the unit is in. Now i’m just wishing i hadn’t updated it in the first place.

Do you think it would be worth $50 to discuss with support to get more information? I’d rather not bother if the likely outcome is that I had to buy new hardware anyway just to recover my data.

thanks for more info,
i think based on what you have mentioned, it is looking more like something happened to the hardware.

if your diskpack seems ok, then one way that might be a good option, would be to purchase a replacement from drobo, (which you most likely would need to get one anyway to be able to go through a migration process), and i think you also get some migration support as part of the purchase, along with a fresh warranty or whatever is the norm for your location when buying a new unit anyway. in that case, i think there would be more chance of discussing the old/broken unit at that time :slight_smile: (however, if dashboard can never see it, then im not sure how diagnostics logs could be obtained though)[hr]
btw if the psu power supply brick is not showing a solid green, it could be something to do with the psu…