Drobo mini power led flashes but won't turn on

My Drobo Mini abruptly powered down during normal use. It’s populated with 4x2TB drives and all drives were showing green with space available before it switched itself off.

Now whenever I connect the PSU to the unit, the small green LED above the power socket on the back of the unit flashes - one long flash followed by 3 short flashes, and the unit will not power on.

The light on the PSU plug itself is solid green - I’ve tested the PSU and it’s giving out a solid 12.2V.

Holding the power button down causes the power LED on the rear of the unit to blink rapidly after 10 seconds, for as long as the button is held.

No change after leaving the unit to cool overnight (it didn’t seem to be running hot anyway) or removing all of the drives and trying to power up the unit with no drives or connections.

Has anyone else seen this behaviour/remedied it?

hi gingerbeardman (cool name) :slight_smile:

i think if you have tried powering up with an empty drobo too, and it still does not work, and if the psu still remains a solid green, it could be something that has gone wrong with the main unit.

(unless you can get a free replacement via warranty), then while the cheapest option would be to try another psu (brick and cable), i think based on this page, it would not fix the issue:

(if you happen to know of a store near you selling one, or have a friend who is ok to let you try their psu, it might be worth trying though)

if it is the unit that has had a problem, then usually that is the better type of problem to have, because it is far more likely that you could migrate your diskpack into another compatible replacement drobo unit via a migration process as mentioned here:

(i successfully migrated the diskpack from my drobo-s-gen2 into another repacement model)
and another user was recently able to do a successfull migration for example here too:

btw you might already know this, though please note that Diskpack drives should only removed (or inserted) in their entirety and only when power is all OFF and cables unplugged.

Thanks Paul for your reply, I’ve already tried another PSU with no luck…

I’ve got another Drobo Mini unit on the way and will try to migrate the diskpack, I obviously can’t upgrade the firmware on the non-functioning unit, hopefully the firmware on the replacement will be backwards-compatible!

I’ll post an update after I’ve tried the migration.

thanks for more info, it should work in that regard, as i wasnt able to upgrade firmware on my drobo-s-gen2 when it didnt power on, yet the migration process was ok for me.

Well that was painless! I’m back up and running with no data loss :slight_smile:

The warning on the quick start card about data on newly inserted drives being erased was slightly unnerving but I followed this process:

1: Turn on and connect new Drobo Mini with no drives inserted.
2: Update Drobo Dashboard and Firmware.
3: Power off Drobo Mini and transfer disk pack from old unit.
4: Power on and be amazed!

Thanks for the help.

ah well done gingerbeardman, am glad to hear it went smoothly for you too.

i guess now, you can celebrate with actual gingerbreadman cookies :smiley: