Drobo

Drobo - Index corrupt

Hi,

No idea what I did to be honest but all of a suddon my Drobo doesn’t mount anymore when I plug it in. My volume didn’t show up in mount, nor in diskutil in the terminal. So I ended up running DiskWarrior but it tells me it can’t replace the index since the original index is too severely damaged.

What do I do? Back up everything? Or is there perhaps some sort of command you can run to clear the last index or something?

Thx!

ps: Isn’t the drobo supposed to shut itself off when I click ‘Standby’ in the drobo dashboard? It doesn’t do that either … and it stopped doing that before I had this issue. The drive is not even 2 months old. Filled with 2 1TB WD Greens and 2 500GB disks that I can’t recall anymore. Does the Drobo even have a dictionary that is writable by something like DiskWarrior? I also tried Drive Genius … but those geniuses clearly don’t realize that sometimes certain Drives have Volumes that don’t show up. With Drive Genius you can only select the mounted Volumes.

edit2: I can also hear the disks being active … hw is that even possible when the volume isn’t mounted? Is it rebuilding the index itself? Should I just leave it on? sigh … remember … I have no way of putting it into standby. The only way is to yank the cord.

Problem solved. For those wandering:

http://ubuntuforums.org/showthread.php?t=392287bmc.org/

Install Ubuntu (or run a live disc, dunno) and follow the repair guide. I can’t believe linux is actually BETTER at managing hfsplus than OS X. This is just ridiculous … neither Disk Utility, nor Drive Genius recognized the lost Volume. Disk Warrior did recognize it but took 4 hours to recover the data and failed to repair anything.

On Ubuntu though it AUTOMATICALLY mounted with read permissions. All I had to do was unmount, run the tool et voila. A working and mounting disk under OS X. So for people experiencing the same issue … give linux a chance :wink: