Drobo in Data Protection mode but has unmounted itself

Hi all,

One of my drives failed and my Drobo immediately and correctly went into “Data protection” mode with a single flashing red light for the failed drive and four flashing green lights for the okay drives.

Drobo Dashboard was showing it had over 100 hours to complete the data protection HOWEVER, about 15mins into the data protection, my Drobo 5D3 suddenly become unmounted from my iMac and the lights turned from “flashing” to ‘still’. They are also now single red (for the failed drive) and amber/orange for the drives that were previously flashing green.

  • Should I be worried?
  • Is the Data protection still happening (even though the lights aren’t flashing anymore)?
  • Should I wait until the continuous amber lights switch to green to confirm that data protection has finished?

Support said I should:

  • Shutdown the Drobo using Drobo Dashboard > Tools > Shutdown or by using the toggle switch on the back of the Drobo
  • Safely eject your Drives
  • Power up the empty Drobo (do NOT insert drives while Drobo is powered on)
    • Leave unit in this state for 5 minutes, does the light status change, if so to what?
  • What is the status of the Drobo lights without drives installed?
  • If Drobo Dashboard recognizes the Drobo, generate a diagnostic file
  • Shutdown the Drobo using Drobo Dashboard > Tools > Shutdown
  • With Drobo powered OFF, insert the drives and power on Drobo

Let us know the status of the all the lights without drives installed :

  • Drive Bay Lights (color, solid or blinking)
  • Power Light (Green, Red or Yellow)
  • Number of blue capacity light lit

But I am worried about powering down my Drobo when it is in data protection mode! I have read this is a NO NO!

Thanks

Well my first question would be, what is the outcome if you do as support say?

If it’s showing in dashboard, shutting down from there ought to be safe.
If it’s not showing in dashboard, try unplugging & re-plugging the data connection, & or rebooting…
If it STILL doesn’t… I don’t see you’re left with much choice but to follow the directions support gave you.

About the only other suggestion I have, if you have one available, is install dashboard on a Windows machine, see if that sees it… the drives are probably the wrong filesystem to read, but it might give you other clues about status.

Yup! Be very worried. I just went through this and the drobo kept ejecting drives and rebooting over night so next morning I woke up and the Drobo had only 1 light on top right as red. It stopped rebooting obviously but I couldn’t get it to start correctly again much less mount. Long story short I sent it back since it was still with drobo care for a replacement but thinking it could happen again, I took measures to be ready migrate my data before I got a replacement and I read about what could be doing this ejecting thing. I bought a used Drobo on ebay since support was very slow and was trying to tell me it was out of warranty. So that worked and about 2-3 weeks after that I got the replacement Drobo.

Thanks for the responses, gents. I gambled and rebooted my Drobo, and it is now in “Data Protection” mode again. So hopefully this will be completed, and then see what happens.

Well it completed Data Protection, but Data Protection keeps starting again and then stopping every hour. Anybody experienced this before?

Some questions.
What does Dashboard have to say about the health of the individual drives?
Have you replaced the drive that originally failed?
If so with what? (Exact make & model would be helpful)

Since you’re in contact with support, are they aware of this & have you sent or have they requested logs? They should be able to tell what’s going on from the content of the logs.

Hey there, thanks.

  1. Dashboard says the remaining drives are all healthy.
  2. Haven’t replaced it yet, as had to order one. Coming tomorrow from WD.
  3. as above
  4. Yes, I’ve been in contact w/Support and they have the diags file but replies from them are very slow. Oh well, I hope replacing the bad drive will be the solution and data protection will stop starting and stopping all the time.

I hope the new one is not SMR or DM-SMR
List here: What WD and HGST hard drives are SMR? (hddscan.com)

You get all sorts of issues if any drive in a Drobo is SMR, particularly when rebuilds are involved…
I’d double check none of the existing drives are SMR too given the odd behaviour, the model numbers and serials are shown in dashboard if you select the drive on the status page.

Drobos aren’t compatible with SMR drives. Reference: Can I really use any hard drive I want in Drobo?

Thanks for that information; really useful and I wasn’t aware of that. It’s CMR. I ordered a WD Red Plus NAS 12TB hard drive.

The Drobo should not reboot during the data protection, if it does there is an issue with one of the drives in Drobo. Would you let the agent know the Drobo is rebooting during data protection, they can send you instructions to put Drobo into Read Only mode so we can review a diagnostic file to see which drive is the culprit. Your support case lists a 5D3 but I only see 5D registered to you, would you also let the agent know the serial number of the unit.
Thank You.

Hi there, thanks for your reply. The Drobo is not rebooting, it unmounted itself from my iMac 15mins after data protection started. Anyways, Drobo Support says that Data protection cannot complete as my Drobo is 100% used, so I need to replace the bad drive with a new drive before it can complete data protection.