Drobo

Drobo going into standby on an AirPorte Extreme

Hello everyone!

I am having an issue where my Drobo will be fine but as soon as Time Machine goes to make a backup itll mount the Drobo from the network and then Time Machine will do its “calculating changes” and then the Drobo will go into standby and not wake again.

I and in doing so crashes my AirPort Extreme and the only wake to recover both of them is to disconnect power and reboot both.

Ive tried 3 different usb cables as well as two diff drobo’s and they both do the same thing.

Any ideas?

Hi,

I’m having a similar problem with my new Drobo as well (firmware 1.3.6) with the AE. I’ve thin provisioned it to 16TB and have 3x 500 gig drives. I made a complete Time Machine backup of both my Macs (one running Leopard and the other Snow Leopard). This seemed to go well.

When I went to do a restore test from Time Machine, the Drobo shutdown and shortly thereafter rebooted itself. After further investigation I found that all the other files were corrupted and neither Mac could read the data (sparsebundles in addition to other stuff).

So I’m at a loss because the Dashboard says all is OK. I’m in the process of re-doing the work, but this time I made a 2 TB partition …

Unplugging and replugging the AE should wake the Drobo up - you shouldn’t need to power cycle both. Drobo likely sees AE in the crashed state equivalent to a computer that’s turned off, hence it’s going into standby.

Do either of you have another drive you can try on your Airport Extreme? That would help determine whether it’s AE dying under heavy load (a lot of embedded-type devices have this behavior), or if it’s a specific Drobo interaction.

http://support.datarobotics.com/app/answers/detail/a_id/266

Thanks for the tip. Just to clarify I’m not having to pwer cycle the Drobo, it just sort of reboots itself during Time Machine restores.

I do have another drive and it’s working fine (1 TB Hitachi from my fried Time Capsule in a $30.00 enclosure).

I just finished my second experiment. I created a 2 TB partition on the Drobo and used hdiutil to manually create a journaled sparsebundle which I copied to the Drobo. I then performed a complete Time Machine backup directly connected to the Mac (running Leopard)

I’ve reattached it to the AE and did a small restore. No crash yet.

The next test is to do the same thing with the other Mac (running Snow Leopard). That’s the one that had initially caused the Drobo to freak out and reboot during the restore.

I’ll let te group know the outcome of the test later today.

Definitely check the AE’s firmware version as the KB article suggests too, if you haven’t already.

The AE is running 7.5.1 which I believe is the latest. To clarify once more, the Drobo reboots itself only during Time Machine restores. Repeated attempts to restore files via Time Machine also corrupts the volume. Other than that the Drobo is operating OK. I even pulled a drive during a data copy and was impressed with the rebuild time. The Drobo acts perfectly at all other times.

I suspect I have something faulty (obviously!), whether it was a corrupt sparsebundle, bad AE, or bad Drobo or some odd combination remains to be seen. I’m leaning to a bad sparsebundle as I created it over the network. If the hdiutil method works OK that will be it. Also, as I noted previously, I have no problem with Time Machine backups to the 1 gig Hitachi, so that suggests the AE is OK.

Will keep folks posted (I so don’t want to RMA this thing).

If you contact support, we will have you test with the Drobo directly attached. Leaving the AE out of the equation.

Yes I opened up a support ticket for this issue and am waiting to hear back. I also found an interesting comment from this link regarding multiple simultaneous backups through the Airport Extreme.

http://fabienne.us/2009/02/26/drobo-airport-extreme-time-machine-multiple-macs/

The failure noted by Leon is similar to my issue. My backup (via Firewire) is almost done so I will be able to do a directly attached restore test and then I’ll move it to the AE and try a network test.

Hah! Partial success so far. My Firewire backup finished (surprisingly quickly) and it all looked good. So I went to restore some test files. While the Time Machine mounted the Drobo correctly it would not let me restore. How wierd is that?!? I could enter the Time Machine, but it wouldn’t mount the sparsebundle via Firewire.

Wierd eh? It will backup but not let me restore …

So I unmounted the Drobo and reconnected via USB to the Airport Extreme. And guess what? It worked! I was able to restore a larger file and a few thousand smaller files correctly.

The fact that the Drobo couldn’t access the sparsebundle while it was directly attached via Firewire concerns me, but I’m not going to obsess about it yet :slight_smile:

I’m in the process of adding more data to the Drobo and we’ll see if it continues to work OK. I’ll need to fiddle with it for a few weeks before I make a decision on this product’s interoperability with Time Machine, but I can’t see it being a problem now (hope I haven’t spoken to soon).

In summary here’s what I did:

  1. Created a 2 TB partition on the Drobo using the Dashboard on my Macbook (HFS+ File system).

  2. Creates a sparsebundle image on my Mabook’s desktop using hdiutils:

sudo hdiutil create -size 500g -type SPARSEBUNDLE -nospotlight -volname “My Backup” -fs “Case-sensitive Journaled HFS+” -verbose ~/Desktop/MyMachine_##########.sparsebundle

where ###… is en0’s mac address. Variations of this script are everywhere.

  1. Copied that sparsebundle file to the Drobo.

  2. With the Drobo directly attached via Firewire initiate a Time Machine backup

  3. After the backup is complete eject the Drobo and attach it to the Airport Extreme.

  4. Reselect the backup target in Time Machine.

There’s a lot of seemingly unnecessary weirdness with apple’s fancy rsync, but if this does end up working OK I have every confidence the Drobo will work as advertised.

I think the initial problem was relying on the AE to create the initial sparsebundle and then perhaps having too much data traversing the wimpy AE’s USB port. Perhaps that caused the AE to shutdown the port and the Drobo then reset itself?

Meh. Looked good there for a few hours, but now whenever I try to copy a large file (over 50 meg) to my desktop the Drobo reboots. Works fine when it’s directly connected though.

Guess it’s RMA land for something (either AE or Drobo)!!!

Oh well :frowning:

OK. Issue narrowed down to definitely the Airport Extreme. I’ve got the Drobo now shared off a Shuttle PC running XP and it has been fine so far with lot’s of data I/O and successful Time Machine backups.

So anyone have ideas why the Airport Extreme might be having an issue? It’s only a few weeks old and is running the 7.5.1 firmware.

As I noted earlier, the AE works fine with a Hitachi drive in a cheapo external enclosure. I’d like to keep the Airport Extreme and use it with the Drobo, but if it’s an issue, what additional options could I look at? Pogoplug? Mac Mini … I would really like to use HFS+ and the 16 TB limit as there will be a lot of media files on the Drobo in the future.

Thanks for any tips!

In my experience the best way to get full performance out of Drobo is to connect it to a computer and share its contents via the computer. I have my Drobos connected to my Windows Home Server machine and I get better performance and reliability there compared to when I used Drobo+DroboShare.

Of course, this is coming from someone who had a 802.11g wireless bridge that would crash under high sustained load too (Netgear WGE101) so take my words with a grain of salt.