Drobo (Gen 3) no lounger mounts on mac

I have a Drobo (Gen 3) 4 bay device and as of a few weeks ago it stopped mounting on my mac’s desktop. All the lights are active on the Drobo itself and it shows up in Disk Utility, so I’m pretty sure it hasn’t failed or lost any data, but it shows grayed out and clicking the “mount” option just does nothing.

Drobo Dashboard shows the device and it’s fully active and healthy, I can’t figure out why it just won’t mount anymore. It happened after restarting my computer, it was a controlled shutdown, nothing unusual at all.

I’ve tried going into the terminal and forcing a mount there but it tries and then gives me a message that the effort timed out. I’m really hoping someone can help! I’ve also tried changing USB plus and power cycling it (both using Dashboard and manually) but nothing helps.

hi dean, it may be that some filesystem maintenance is required.
the good news is that since you have a DAS model, it might be easily fixable with another tool such as diskwarrior (which seems to be fixing a lot of similar problems for macs). it doesnt seem to be free though, but if you are still in support you could try raising a ticket in the meantime too, just in case it is caused by something else.

You could try the Mac’s own built in file system repair tools before trying a paid-for solution such as diskwarrior

The mac’s disk utility verify/repair function didn’t help unfortunately, so DiskWarrior might? What particular function should I perform when/if I buy it? Does the free trial do it? :slight_smile:

Because of the RAID setup, I’m always very cautious to do any kind of scans or repairs to the Drobo for fear it’ll lose the ability to understand what’s on the drives.

hi dean, there is an email you could try on this page to check with the maker in case there is a specific process regarding diskwarrior here: https://myproducts.drobo.com/article/AA-01169 (though im not able to advice myself as i do not actually have a mac)

there is some more info here and you could try the full shutdown and reboot test, of both the drobo and the mac (but waitning at least 5 minutes before powering either back up again) https://myproducts.drobo.com/article/AA-01928

(if you do email the diskwarrior team, its probably best to not ask them abotu how to fix it for free :slight_smile: though to be fair i think even as a possible future customer they will probably be happy to advice you if they can)

I tried the full shutdown and reboot test and unfortunately it didn’t do anything. Then I found that I had a tool called DiskTools Pro that has a filesystem verify and repair function, so I tried that. The verify found a problem and the repair says it fixes it, but it doesn’t. The Drobe drive still won’t mount, and doing another verify shows it still to have a problem, and repairing says it fixes it again. Feels like I’m in a loop.

:frowning: I just want my data.

hi dean, sorry just saw this now… if you have not been able to try diskwarrior, would you be able to try a process which puts the drobo into a readonly mode, to see if that somehow allows your drobo to mount, for example as mentioned here?