Drobo Gen 2 Infinite Reboot Loop

After I powered off my Drobo, which was (apparently) working fine before, when I plugged the power back on, the Drobo seemed to boot normally (bottom blue dots progressing right) up to the point when I should have lighted all the 4 right disk leds to green… but they all turned red and stayed so.
Then the Drobo started to reboot, and repeated the same cycle over and over again.

I tried to power off/on again : no dice.
I tried to replace the power brick with a spare one I had : no dice.
Tried to power off, unplug all 4 disks, power on/off, replug them, power on : no dice.

Apparently the Drobo Pro suffered from something very similar, I hope my latest firmware update did not bring that plague to my Gen 2 one.

Since the Drobo is not seen from the Mac, I cannot even get a log.
Anybody with an idea ?

Does your Drobo boot with no disks installed?
If so, are you able to grab a diagnostic from that?

How about a pinhole reset with the drives removed?

Thanks rdo, no initially it did not boot when empty.
Thanks mgriffin34, I did not try that but since I found this Drobo support page “What should I do if my Drobo storage device keeps rebooting?”, and following it religiously step by step, I was able to recover all my disks.
I am glad everything ended happily (apparently), but I still find the Drobo susceptibility to power offs worrisome, since it is not the first such problem I had, although previous ones were not so persistent.

hi geej, am glad you got it sorted out.
when you get a chance could you post your dash and firmware versions please?

All the latest versions :
Dashboard 2.5.2
Firmware 1.4.2
Connected via Firewire to an Apple Mac Mini running OS X 10.6.8

Note that at that point, I have no hint if the same problem would not have occurred too under a previous version.

ok thanks geej