Drobo FW 4.1.4 broke SMB (for me). What is your experience with 4.1.4?

I just installed Drobo FW 4.1.4 this afternoon and all my SMB mounts stopped working. I tried resetting all my computers and my Drobo 5N with no luck. So I reinstalled FW 4.1.3 and SMB mounts all work again.

Let me know if you have seen a similar result or if 4.1.4 works for you on your Drobo 5N.

UPDATE: I just couldn’t leave it alone after I downgraded to FW 4.1.3 so I installed Dropbear which allowed me to SSH into my Drobo 5N system so I could look at system log files. I found a number of file system corruption warnings in the startup log files.

Since I keep a full backup of my Drobo files, I Reset my Drobo, Installed FW 4.1.4 and rebuilt it will the same Volumes structure and files that I had on it before. Now SMB and AFP mounts both work as expected.

I guess I’ll just have to check the log files from time to time to make sure everything is OK since the Drobo Dashboard didn’t give me any indication of a problem. :frowning_face:

1 Like

4.1.4 provides an option to disable SMBv1 in Network Settings. Have you checked what happens if you toggle that setting?

I did toggle the SMBv1 setting and it didn’t make any difference for me either way.

Same thing for me. 4.1.4 broke my drobo 5n. I can still dashboard to the drobo, it has an IP. I can ping it, just cant mount anything. Also tried turning off the checkmark for smb1 and it does not make a difference. this all happened after I updateed to the firmware 4.14. and the dashboard. I tried rolling back to an older firmware and its still broken so I am not sure if it was the drobo dashboard app that broke things.

Anyone got a fix for this?

I manually reinstalled Drobo FW 4.1.3 and SMB works again just like it did before I installed 4.1.4. I’m running version 3.4.1 (108281) Dashboard on my MacBook Pro running macOS 10,14,3. It also works on an older iMac running Dashboard 3.4.0 and MacOS 10.11.6 so I’m pretty sure it’s the Drobo FW 4.1.4 that’s the problem.

1 Like

Where did you get the 4.1.3 firmware?

I still had the previous release download on my computer. It’s a 39MB .zip file so it’s too big to email but if you have a Dropbox or Google Drive account or something like that I could put it, I’d gladly give you a copy.

You can re-download the 4.1.3 firmware here:
Drobo 5N2 4.1.3 Firmware

and the 3.4.0 Dashboard here:
Drobo Dashboard 3.4.0

As soon as I installed 4.1.4, my file copies started to fail from my Windows 10 computers (Desktop and Laptop). For a 5GB file, it would get about 80% done and then just stop and timeout. I downgraded to 4.1.3, but it didn’t help, it had the same behaviour. I uninstalled the 3.4.1 dashboard and reinstalled 3.4.0 and so far, so good… I will test its stability more over the next couple of days.

What’s funny, is that I have an old DroboFS that I play with now, and as soon as I upgraded my dashboard it also had connectivity issues (I couldn’t mount any shares or alter any shares). I didn’t connect the two issues, but maybe I should. I will try my old FS again shortly…

I’ve lost all faith in this Drobo, it has been nothing but trouble since I got it. Seriously regret not purchasing a Synology right now…

1 Like

Yes, I think I can safely say that it was the Dashboard 3.4.1 (for Windows) that pooched my connectivity to BOTH my Drobo’s. I couldn’t mount any shares on my old DroboFS and file copies failed on my Drobo5N2. Reverting back to the 3.4.0 seems to has rectified it. I am not going to try re-updating my 5N2 back to 4.1.4 at this time. It’s too risky, I hold my breath and close my eyes every time I do a firmware update on these machines…

4.1.4 went in fine on both of my 5N2’s. Had to reboot my Windows 10 box for them to be seen by Drobo Dashboard 3.4.1 [108281], even though I could see them from the File Explorer.

Haven’t tried mounting them on a Mac or on a Linux box. Going to look for a spare hard drive around here to throw into my old 5N. Will check to see if I can update it to 4.1.4, and then I’m going to try to upgrade Python 3 using pip.

Follow up: 4.1.4 installed just fine into my 5N. It was found by Drobo Dashboard immediately after it rebooted.

I’m also have the same issue after update to 4.1.4 for my drobo 5n.
SMB mounts doesn’t work, but APF works.

Where can I get the 4.1.3 FW?


Drobo 5N 4.1.3 FW release. http://files.drobo.com/webrelease/5N/Drobo5N_Firmware_4-1-3.zip

1 Like

Hi djdoornink,

Thank you for the URL.
After downgraded to FW 4.1.3, I can mount via SMB as well as APF.



Adding to the list of SMB broken when upgrading to 4.1.4. I’m trying to connect on a Mac (using Finder) and iPad (using VLC), and both fail after the formware upgrade.

I tried downgrading (using the link given above), but the same result so far. I can mount using AFP on the Mac, but not SMB. The SMB server can be started manually on the Drobo, but then stops after a short time…

Do I need to downgrade the Drobo Dashboard too?

Any thoughts welcome - besides the obvious of starting to consider migrating to other options… :-/

Drobo support ended up suggesting a reset to resolve the issue. Which did work, but left the problem of where to place the data while resetting ($$ for harddrives), and taking a loooong time to do.

Now I have to either copy everything back, or consider alternatives.

Yup, that’s what worked for me. Just two things…

  1. Yes, it takes time to write the data, but it only took about 8 hours to reload my 2.5TB
  2. Now that you have the extra drives, you can use them for keeping an incremental backup of your Drobo, which is best practice :slight_smile:

I was just locked out of my files for 5 days. It started when firmware updated to 4.1.4. Drobo wanted to charge me for support. Fortunately I found the cause a moment before I entered the credit card:

Here is what I found: even though Drobo Dashboard showed everything as running perfectly (all green) the truth is that Samba was not running. That explained why it was impossible to mount any of the shares from any of our 5 Windows and 3 Mac machines.

I had already DropBear installed so I logged in via SSH. I did a search on the files on /var/log and noticed a number of ext4 errors. Unfortunately I was not able to run fsck or e2fsck. However I did see hundreds of lines indicating “smbd process is not running”. Clearly the system “knew” Samba was not running but the Dashboard didn’t report that.

Then I found the command to start Samba “/usr/local/sbin/samba.sh start” and when I ran it, an error like “chown error input/output” (sorry I don’t have the exact text) and made reference to file: /mnt/DroboFS/SystemLogs/samba/logs/log.nmbd.1.

I couldn’t find a way to fix the error. When trying ls, vi, mv, cp, or any other command on that file I would get the “input/output” error.

So my workaround was to rename the folder to logs.bak and create a new logs folder. After rebooting Drobo all my machines connected “magically”.

This is beyond annoying - isn’t the main function of Drobo to run Samba? How come the Dashboard kept saying everything was good? Also, isn’t there an automatic fsck run on this?

I hope this helps you if you have the same problem.

I’ve got a similar problem but not exactly the same. Also, I can’t confirm it started with upgrading to FW 4.1.4.

My problem: I can still use SMB but only as a guest. Logging in as any other user is not possible. Downgrading to FW 4.1.3 didn’t help either.

I’m going to continue posting about my issue here: Drobo 5N won't mount as registered user