Drobo-FS throughput near zero???

I am a sports photographer and I have three external drives attached to my Win7 system. A USB2 drive, a Drobo-5N and a Drobo-FS. The Drobos are configured to NOT power off the drives and all my equipment is on a UPS.

I consistently get 25-30MB/s on the USB and Drobo-FS drives and 65-100MB/s on the Drobo-5N

I normally store thousands of images per week but due to an injury I have been inactive the past couple months. So my writes to the two Drobo systems have been minimal.

Last week I had a bunch of files that I wanted to copy to the two Drobos and I noticed the throughput on the FS had dropped to the point that even browsing the share is difficult. On a file copy I am getting between 5-9MB/s if I’m lucky. The other two drives are working normally.

The Drobo-FS is not showing any errors. I have tried restarting the Drobo-FS multiple times and reseating the network connection. It always comes back up without any errors but the throughput remains at around 5MB/s.

Does anyone have any ideas why this FS array would suddenly slow down after 4 years of flawless performance? The FS array consists of 5 x 2TB drives and the Drobo dashboard shows it at 55% full.

I appreciate any suggestions.

Could be a number of things, but likely it’s a drive that’s going bad, but hasn’t misbehaved enough to be kicked out of the disk pack and marked red yet.
You can try submitting your diagnostic log to Drobo and see if they’ll tell you if any drives are misbehaving, but don’t hold your breath as I believe the FS is out of the support period.

Yeah, I had similar symptoms from my 5N recently. When I SSH’ed in I found processor load was through the roof, despite the CPU being idle. Ultimately replaced a Seagate HDD that was marked with “Warning” in Dashboard (but did not get a yellow light or marking on the graphic in Dashboard!), and everything went back to normal.

hi have you left the computer or drobos running for a long time?
just wondering if you have tried safely shutting down the drobo and restarting (and/or the computer)?

Yes, the Drobo-FS has been running for almost 2 years without being shut down as I have everything running on a UPS which is in turn backed up by a generator.

However, when this problem started one of the first things I did was power-down and restart the Drobo-FS. It’s been restarted a few times now - along with the computer. There are actually three PC’s that talk to the Drobo-FS and they are all experiencing slow throughpuit.

It’s odd that the problem seemed to start after three months of inactivity (my photography hiatus) although it might just be a coincidence.

hmm ok, well lets try a few things…

  1. do you have a backup of all data files that are on the drobo currently?
    (best it you can do that before anything else to play safe)

  2. diamond got some info from the dashboard
    (have a look to see if it shows you anything?)

it could be a drive having problems like bhiga said
(can you take a diagnostic file?)

there may be a way to decode it if its using an old firmware, but the DataRobotics Encrypted Data File v2 might not be. However, the support team have been known to be helpful especially if you’ve had some drobocare in the past, and should be able to quickly tell you if a particular drive is going bad.

this is one key area which has differentiated them from other vendors, and i honestly hope they are continuing to do at least basic diag info to point to a failing drive etc)

  1. have you tried, as a test, disconecting all other external drives etc, and internet, and just leaving the fs connected,
    (if you have antivirus, or other drive indexing/scanning utils, try turning those off… just to see if anything else is causing the issue. if it is, it will be progress… if not, then maybe items 1 and 2 might help?)
  1. The contents of the Drobo-FS are replicated onto the Drobo-5N
  2. Not sure what you mean by this.
  3. What is the procedure for checking for a failing drive?
  4. I have three different PC’s that talk to the Drobo-FS and all of them show similar throughput - slow.

thanks jay,

well done for 0) :slight_smile:

for 1) have a look at the dashboard program, in case it shows you any additional information such as warning messages or similar, within its tabs/areas.

for 2) there should be a button or option called Create Diagnostics log.
it might be on the bottom-right taskbar icon, where you rightclick on it to get the option, but i cant remember for the FS version. this page may help:
once you have the log, you can open a ticket and attach as attachment asking them to please let you know if they can see any hard drive problems etc.

for 3)
have you disconnected all pcs from the drobo, and then try just using 1 pc to talk to it?
just as a test…

I wanted to follow up on my Drobo-FS problem. Yesterday out of nowhere the second drive up from the bottom failed with a red light. Upon inserting my boxed spare drive the Drobo immediately went into rebuild mode. It continued to rebuild for about 24 hrs. Once everything went green I re-checked the throughput and everything seems back to normal. It seems safe to say that the problem all along was a marginal drive that was giving problems but not yet failed. It’s too bad this type of information isn’t available on the dashboard. I’ve placed an order for a new spare 2TB WD Green drive. The only one I found in stock and readily available was the version with 64MB cache. All the existing drives in the array are 2TB WD Green’s with 32MB cache.

I appreciate everyone’s assistance with this problem.

hopefully when you swap out the failed drive with a good replacement, it will fix your main issues.
(i dont think it will affect anything in a bad way if the new drive is 64mb vs 32mb)